Mail broken links issue - MacRumors Forums
Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > OS X > OS X 10.8 Mountain Lion

Reply
 
Thread Tools Search this Thread Display Modes
Old May 19, 2013, 08:59 AM   #1
Tech198
macrumors 68040
 
Join Date: Mar 2011
Location: Australia, Perth
Mail broken links issue

Hi all..

When sending email fro other clients (aka Outlook 2007, or Microsoft Outlook), when receiving via Apple mail, why do these links in the body of the email get "broken" ?

Part of the link is a hyperlink, but the trail end is just text.

I know it would be easy, just to copy and paste, which is what i do anyway, for security, but i wanna know why this happens ?
__________________
13" MBP-R, i5, 256Gig SDD, 8 Gig Ram, Apple TV (3rd-Gen.), iPhone 5S 16Gig, iPad (4th-Gen.) 16Gig, Mac Mini 2.3Ghz i7, 1TB HD

"There are no stupid questions, just stupid people."
Tech198 is offline   0 Reply With Quote
Old May 19, 2013, 09:04 AM   #2
Weaselboy
macrumors G5
 
Weaselboy's Avatar
 
Join Date: Jan 2005
Usually when I see that it is because of spaces or carriage returns in the URL from the way it was pasted in at the other end.

If it is a really long link I either surround it with <> this character to the mail client picks up the whole thing as a link. Or you can use a link shortening service like TinyURL.
Weaselboy is offline   0 Reply With Quote
Old May 19, 2013, 09:41 AM   #3
Tech198
Thread Starter
macrumors 68040
 
Join Date: Mar 2011
Location: Australia, Perth
ok thanks,,

the ink in question ends the link with AU_

everything after the _ is text, not linked.

i just did a test via Apple Mail to my own email and again its cut...

Seems Apple mail doesn't like _ in URL's, as anything after that is text only.
__________________
13" MBP-R, i5, 256Gig SDD, 8 Gig Ram, Apple TV (3rd-Gen.), iPhone 5S 16Gig, iPad (4th-Gen.) 16Gig, Mac Mini 2.3Ghz i7, 1TB HD

"There are no stupid questions, just stupid people."
Tech198 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > OS X 10.8 Mountain Lion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Links not opening mail app davidra Mac Applications and Mac App Store 1 May 6, 2014 08:16 AM
Resolved: Anyone else seeing Mail.app crashes when they click on links? kalirob99 Jailbreaks and iOS Hacks 6 Mar 10, 2014 04:45 PM
Mail links won't open in browser NeoCool Mac Basics and Help 1 Jul 19, 2013 08:35 AM
iPad: Links in MAIL wont Open mikeo1069 Jailbreaks and iOS Hacks 1 May 31, 2012 07:33 PM

Forum Jump

All times are GMT -5. The time now is 03:08 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC