Go Back   MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Reply
 
Thread Tools Search this Thread Display Modes
Old May 23, 2013, 03:43 PM   #1
gaussianblur
macrumors newbie
 
Join Date: Sep 2007
MP4Tools - file deletion?

Finally got around to ripping old blurays and am following the MakeMKV > MP4Tools > iTunes/Apple TV(3) formula.

MakeMKV process worked fine. When trying to go from .mkv to m4v vis MP4Tools I'm running into difficulty.

The process seems to be running normally up an through the "Finalizing..." phase. I note two large m4v files generated, one with an "out_..." prefix and another with the "expected" file name, both several GB large. However, once MP4Tools hits completion, just a single .m4v file remains, but with a size of a few MB, amounting to essentially the first few seconds of the movie.

Am I missing something/committing newbie sin?
gaussianblur is offline   0 Reply With Quote
Old May 25, 2013, 02:45 AM   #2
Che Castro
macrumors 601
 
Join Date: May 2009
I only use mp4tools to remove an audio track from an mkv

You should try going from makemkv to a program called iFlicks

iFlicks will add the mkv to iTunes in .m4v format as long as the mkv is not mpeg inside it shouldn't take long for the process to finish in iflicks , maybe a few minutes

Iflicks will also add the metadata for you
Che Castro is offline   0 Reply With Quote
Old Jun 9, 2013, 03:56 PM   #3
misfit1978
macrumors newbie
 
Join Date: Jun 2013
same problem

Hi there,

experiencing the same problem. Worked with 3.1.4 and everything seemed fine.
Updated to 3.2.5 and it looks like it is deleting the wrong file after the "Finalizing"-step. There is one file with an "out" before the name and another one just like the original file name.
When I pause the finalizing step and create a copy of the big file, I can use it.
After finalizing there is just a VERY small m4v-file that contains just a few seconds of the file converted.

I even tried to switch to the legacy encoder but the result was just the same.

btw: Maybe it depends on the input file. The problem described above does not occur with every file, just some of them.
The log-file does not help me identifying the cause of the prob..

iFlicks is not an option for repacking the mkv into m4v as you are not able to influence, what audio tracks to select.
In my workflow I just use iFlicks to add the metadata.

Anyone experiencing the same problems?
Any help is appreciated..
misfit1978 is offline   0 Reply With Quote
Old Jun 13, 2013, 12:56 AM   #4
emmgunn
macrumors member
 
Join Date: Jul 2008
There was a bug in one of the "tools". Try the latest beta. This bug should be taken care of, and you should see speed improvements with conversions.
emmgunn is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
mp4Tools photogpab Digital Video 14 Mar 1, 2013 09:13 AM
File deletion requires a password, results in missing files that don't free up GBs! JohnnyRocketSk8 Mac OS X 10.7 Lion 0 Feb 22, 2013 04:09 AM
External HD Attached to TC File Deletion glennsan Mac Peripherals 2 Jan 13, 2013 05:25 PM
Subler/MP4Tools Help DaGrandMastah Apple TV and Home Theater 55 Jan 4, 2013 08:19 PM

Forum Jump

All times are GMT -5. The time now is 10:58 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC