Go Back   MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 7

Reply
 
Thread Tools Search this Thread Display Modes
Old Jun 15, 2013, 05:03 PM   #1
prtcool1193
macrumors member
 
Join Date: Jun 2010
iOS 7 Beta Wifi Problems

Does anyone else seem to have major wifi problems with the beta? My iPhone 5 has wifi turned on, recognizes the network but continuously fails to join. This has happened at numerous locations. I've tried resetting network settings but it still is giving me problems. The interesting thing is that this has only started happening yesterday. Before then it was fine with ios 7
prtcool1193 is offline   2 Reply With Quote
Old Jun 15, 2013, 05:06 PM   #2
throys
macrumors 6502
 
Join Date: Dec 2011
Location: London
Quote:
Originally Posted by prtcool1193 View Post
Does anyone else seem to have major wifi problems with the beta? My iPhone 5 has wifi turned on, recognizes the network but continuously fails to join. This has happened at numerous locations. I've tried resetting network settings but it still is giving me problems. The interesting thing is that this has only started happening yesterday. Before then it was fine with ios 7
No problem seen here with home wifi from initial installation of iOS 7
__________________
iPad Mini Retina 32gb & iPhone 6 Plus Space Grey 128GB
throys is offline   0 Reply With Quote
Old Jun 15, 2013, 05:49 PM   #3
zhandri
macrumors regular
 
Join Date: Sep 2012
Location: Germany
no problems! actually i think my wifi performance got better. iphone seems to connect faster to wifi compared to ios 6
zhandri is offline   0 Reply With Quote
Old Jun 15, 2013, 11:40 PM   #4
jmantn
macrumors regular
 
Join Date: Mar 2012
Location: Tn
I've seen it take a few seconds to reconnect from sleep. Also if ur in a business or hospital where u join their wifi and it takes u to a safari page to accept terms or put in ur log in info it now incorrectly pulls up podcasts instead of safari.

Really is the biggest pain I'm experiencing but relatively zero issues on home wifi.
jmantn is offline   0 Reply With Quote
Old Jun 16, 2013, 12:07 AM   #5
eaglesteve
macrumors 6502
 
Join Date: Aug 2009
My experience with iOS7 wifi connection is the reverse of what the OP has.

I have two wifi in my house. With iOS7, changing from one to the other is almost instant whereas with iOS6 it takes a little longer to complete.
eaglesteve is offline   0 Reply With Quote
Old Jun 16, 2013, 06:33 PM   #6
ferwindjacks
macrumors newbie
 
Join Date: Jun 2013
Yeah I have the same issue. It only seems like its causing a problem at my home though, as my work wifi works fine. I tried switching my specific frequency on my router to "automatic" but that still hasnt fixed it. It wont even find the network most of the time, and when it does connect, drops within a minute. Yes, I am on an actual dev account, my OS is not pirated.

If you find a fix, please tell me.

-fer
ferwindjacks is offline   1 Reply With Quote
Old Jun 16, 2013, 06:37 PM   #7
gmanist1000
macrumors 68020
 
gmanist1000's Avatar
 
Join Date: Sep 2009
Quote:
Originally Posted by prtcool1193 View Post
Does anyone else seem to have major wifi problems with the beta? My iPhone 5 has wifi turned on, recognizes the network but continuously fails to join. This has happened at numerous locations. I've tried resetting network settings but it still is giving me problems. The interesting thing is that this has only started happening yesterday. Before then it was fine with ios 7
Mine is pretty spotty.

My phone has issues staying connected to the Wi-Fi network in my office (which is far pretty far from the router). Never had the issues on iOS 6 though.

Not concerned though, it'll be fixed by launch. (I hope...)
gmanist1000 is offline   0 Reply With Quote
Old Jun 16, 2013, 09:48 PM   #8
prtcool1193
Thread Starter
macrumors member
 
Join Date: Jun 2010
Quote:
Originally Posted by gmanist1000 View Post
Mine is pretty spotty.

My phone has issues staying connected to the Wi-Fi network in my office (which is far pretty far from the router). Never had the issues on iOS 6 though.

Not concerned though, it'll be fixed by launch. (I hope...)
So i tried restoring back to ios 6 and then putting ios 7 back on and im still having the problem :/
prtcool1193 is offline   0 Reply With Quote
Old Jun 16, 2013, 09:51 PM   #9
jrodsep
macrumors 6502
 
Join Date: Jun 2010
Quote:
Originally Posted by zhandri View Post
no problems! actually i think my wifi performance got better. iphone seems to connect faster to wifi compared to ios 6
This. I had huge problems with wifi in 6.1 but wifi performance has been improved vastly since using 7.0 and then reverting back to 6.1.4. Tried a couple of appstore downloads and they have been quite fast.
jrodsep is offline   0 Reply With Quote
Old Jun 16, 2013, 10:48 PM   #10
FlatlinerG
macrumors 6502a
 
FlatlinerG's Avatar
 
Join Date: Dec 2011
Location: Prince Edward Island, Canada
I've had some issues. Mostly with auto joining known networks. I've had to forget my network a few times to get it to join when I get home.
FlatlinerG is offline   0 Reply With Quote
Old Jun 17, 2013, 09:29 PM   #11
newtestleper
macrumors member
 
Join Date: Jun 2013
Same problem here, fixed by going in and out of Airplane Mode.
newtestleper is offline   0 Reply With Quote
Old Jun 17, 2013, 09:34 PM   #12
eaglesteve
macrumors 6502
 
Join Date: Aug 2009
Quote:
Originally Posted by zhandri View Post
no problems! actually i think my wifi performance got better. iphone seems to connect faster to wifi compared to ios 6
Same as above. It seems to perform a lot better.
eaglesteve is offline   0 Reply With Quote
Old Jun 18, 2013, 08:43 PM   #13
newtestleper
macrumors member
 
Join Date: Jun 2013
Quote:
Originally Posted by newtestleper View Post
Same problem here, fixed by going in and out of Airplane Mode.
But that only worked yesterday. It didn't auto-connect when I got home, and I can't connect manually. As above, it works at work.
newtestleper is offline   0 Reply With Quote
Old Jun 18, 2013, 09:45 PM   #14
Syndicate0017
macrumors 6502
 
Join Date: May 2013
Pretty sure this same thing happened to me on iOS 6.1.1. Whenever I would try to connect to my home wifi, it would just say "failed to join". A few times I got it to connect, but once the device locked, it would instantly forget my pass phrase and I'd have to re-enter it (and yes I had ask to join networks disabled).

Tried upgrading my router firmware, restoring my router to factory defaults, and I even tried restoring my iPhone with no luck. Always the same error.

In order to connect to my home WiFi and stay connected, I had to enter my SSID and password as an "other" wifi network. Fixed the issue immediately.
Syndicate0017 is offline   0 Reply With Quote
Old Jun 20, 2013, 09:35 AM   #15
TG1
macrumors 6502a
 
Join Date: Feb 2011
On my iPhone 5 I've noticed that wifi will occasionally drop out, even when actively using my phone, and the symbol moves to LTE. This happens for a few seconds and then wifi will reconnect. Also, sometimes I'll have a hard time connecting to wifi at all. A reset of the phone corrects this. Never saw this on iOS 6.
TG1 is offline   0 Reply With Quote
Old Jun 20, 2013, 09:55 AM   #16
sonicdissent
macrumors member
 
Join Date: Jun 2010
I am having some trouble when relatively far from the router where I didn't before. My guess is that 6 always preferred wifi no matter the strength so long as it was present, but 7 will switch to cellular if it is stronger. I hope it's either a bug or at least a choice in the final version, because I don't want to use that data.
__________________
Unibody Macbook (Late 2009); 21" iMac (Fall 2011);
; iPhone 4s; 16GB iPad WiFi plus LTE VZW
sonicdissent is offline   0 Reply With Quote
Old Jun 20, 2013, 02:52 PM   #17
toffa813
macrumors regular
 
Join Date: May 2007
Location: Chicago/IU Bloomington
Unhappy

I have the same issue. It knows my home and office networks, but I never get the wifi icon, and when I try to play iTunes radio, it always asks if I want to use cellular data (proving its not just an icon thing).

The only other issues I have is Reminders doesn't work at all, and when it tried to update the Facebook and Kindle apps, it shows that its waiting and I get the status bar for the update. Can still launch either through App store or multitasking (although whether or not that's the newer version I have no idea)


Frustrating stuff but not a deal breaker for me. Just hope it gets better (on Monday?!?)
__________________
Indiana University '14
Mid 2010 15" MBP 2.66 i7, 8GB RAM, 120 GB Samsung 840 & 500GB HDD
16GB Black iPhone 5
toffa813 is offline   0 Reply With Quote
Old Jun 23, 2013, 08:55 PM   #18
iPhonePlaya
macrumors regular
 
Join Date: Jun 2007
I'm probably about to downgrade back to iOS 6 because of the wifi issue I'm having. My phone basically just doesn't use my home wifi anymore since installing iOS 7. When I try loading something it switches back and forth between wifi and LTE and is very slow, it's rather annoying and battery consuming.
__________________
2.4GHz Black Macbook, iPhone 4 16GB soon to be black iPhone 5 32GB, waited out through the 4S bologne
iPhonePlaya is offline   0 Reply With Quote
Old Jun 24, 2013, 01:55 PM   #19
prtcool1193
Thread Starter
macrumors member
 
Join Date: Jun 2010
Any improvements after beta 2? I'm still having the issue
prtcool1193 is offline   0 Reply With Quote
Old Jun 24, 2013, 02:42 PM   #20
Rift
macrumors newbie
 
Join Date: Jun 2013
No, there's nothing changed. It's not just a bit faster, more stable or something like that... Too sad.
Does Apple know about the wifi problems? I don't think so because nothing was changed now and in the notes I can't find something related to these wifi problems.
Rift is offline   1 Reply With Quote
Old Jun 25, 2013, 05:37 AM   #21
Rift
macrumors newbie
 
Join Date: Jun 2013
On which iPhone 5 wifi works perfect, on which it looses connections, on which you can't connect and what router do you have?
Have a netgear WR841N and lose connection after ~1-2 minutes.

How much users still have this problem? Maybe it's a hardware defect?
Rift is offline   0 Reply With Quote
Old Jun 25, 2013, 05:38 AM   #22
bbfc
macrumors 68020
 
bbfc's Avatar
 
Join Date: Oct 2011
Location: Gosforth, England
I've noticed no change in the behaviour of wifi. It will connect to my home network and to my work network automatically. No issues at all.
__________________
MacBook Pro (Early 2011), 2.3 GHz Intel Core i5, 4GB RAM, OS X Mavericks | iPhone 5 16GB White, iOS 8.1
bbfc is offline   0 Reply With Quote
Old Jun 25, 2013, 01:53 PM   #23
Sir Spiff
macrumors newbie
 
Join Date: Jun 2013
I detect that being within a range of 5 meters of the WiFi router, I have access to the Wifi nettwork. By moving further 2-3 meters, the signals from the WiFi router remains for a few secound, with "full throtle" and then the phone changes to LTE, resulting in lost connection to the WiFi router. It seems to me that since the LTE signals are stronger (or just represented), the iOS 7 automatically swap to the LTE... If I walk towards the router again, the iOS switches back to WiFi. WHY, and is there any settings in iOS 7 that forces the phone to remain connected to the WiFi nettwork as long as there are signals represented?
I've searched the net for answers the three last days, and cant find anytihing that solve this issue.
I've tried everything from turning off cellular data, in a desperate try to force the phone to remains in "WiFi" state, without any luck.. I also tried to reset the nettwork settings etc, without any further results..

Everything works fine with iOS 6.1.4....

Help.... Someone...?
__________________
IPhone 5 - 64 Gb, IPad 3
Sir Spiff is offline   1 Reply With Quote
Old Jun 26, 2013, 02:08 PM   #24
prtcool1193
Thread Starter
macrumors member
 
Join Date: Jun 2010
I really hope this is fixed in beta 3. it's VERY annoying
prtcool1193 is offline   0 Reply With Quote
Old Jun 26, 2013, 03:45 PM   #25
CamiMR
macrumors member
 
Join Date: Oct 2012
Quote:
Originally Posted by eaglesteve View Post
Same as above. It seems to perform a lot better.
I agree!! When turning wifi on, ios 6 would sometimes take 10-15 secs to connect, now 1-2 secs and presto!! Very happy with that!!
CamiMR is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 7

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iOS 7.1 beta 5 WiFi issue as11ley iOS 7 15 Feb 11, 2014 06:16 PM
iPhone: iOS 7 Beta 3 Wifi issues? shahrezsyed iOS 7 14 Jul 28, 2013 02:47 AM
iOS 7 beta always stays on wifi does no switch from LTE to wifi wplynx iOS 7 3 Jun 16, 2013 11:01 AM
Ios 7 beta always stays on wifi does no switch from LTE to wifi wplynx Mac Basics and Help 0 Jun 15, 2013 10:56 PM

Forum Jump

All times are GMT -5. The time now is 02:12 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC