Go Back   MacRumors Forums > Special Interests > Digital Audio

Reply
 
Thread Tools Search this Thread Display Modes
Old Jul 11, 2013, 05:09 PM   #1
LucyMal
macrumors newbie
 
Join Date: Jul 2013
Traktor Kontrol S2/Pro 2 USB indicator issue with Mac - please help!

Hi all,

I have a MacBook (early 2008 - Intel Core 2 Duo 2.1 GHz) which I recently upgraded to 4GB RAM (from 2GB) and subsequently installed Lion (OS X 10.7.5), ready to then install Traktor Pro 2 for use with a Kontrol S2 (both brand new). Having installed the hardware/software as instructed in the setup guide for the controller, when running Pro 2 and plugging in the S2 to my laptop, only the USB indicator light flashes on the controller but it does not appear to be 'syncing' with the software/laptop. The software itself seems to be working fine as selected tracks are playing out of the laptop's speakers, it is the controller which has no functionality and no sound is coming out of the active monitor speakers hooked up to it (with XLR to RCA cables).

Having looked on the Native Instruments Service Centre and other internet forums for solutions, as has been suggested on these I have tried deleting and reinstalling the software/drivers, have checked the MIDI setup on the laptop and have checked whether the Controller Editor shows an error message (it doesn't) and none of the above have resolved the problem! I assume I have the correct driver installed as the software download is supposed to include the most up to date version (1.1.0), although I can't find this in the Native Instruments folder that appears once installation is complete to check (I did read on a forum though that this folder is apparently 'invisible' for some reason). I have also read that the issue can be related to the USB cable/port etc, however I am using the brand new USB cable that came with the controller and have checked that I am inserting this into the correct port directly into the laptop (2.0 high speed bus not sharing port with iSight etc).

If anyone has any ideas as to why none of the above have resolved the issue and what could be causing it, any advice would be much appreciated - I am at a total loss as to how to get the S2 working!

Thanks!
LucyMal is offline   0 Reply With Quote
Old Jul 18, 2013, 08:46 AM   #2
ItsJackNi
macrumors newbie
 
Join Date: Jul 2013
Have you got anywhere with this.. im having the same problem and have been for ages.. did you find a solution?
ItsJackNi is offline   0 Reply With Quote
Old Jul 25, 2013, 06:54 PM   #3
mth79
macrumors newbie
 
Join Date: Jul 2013
i had the same problem. i had installed the latest update etc but it still flashed and had no sound from my s2. so i checked which version i had on my macbook pro - i have 10.7.5 so i downloaded the update from the support page 1.0.8 and then it worked fine

i hope this helps
mth79 is offline   0 Reply With Quote
Old Jul 31, 2013, 05:43 AM   #4
LucyMal
Thread Starter
macrumors newbie
 
Join Date: Jul 2013
Quote:
Originally Posted by mth79 View Post
i had the same problem. i had installed the latest update etc but it still flashed and had no sound from my s2. so i checked which version i had on my macbook pro - i have 10.7.5 so i downloaded the update from the support page 1.0.8 and then it worked fine

i hope this helps
Hi,

Thanks for responding. I've tried downloading the 1.0.8. version but it won't install - the 'install' button is greyed out once I've downloaded/opened the update. I assumed this was because I already have a more recent version of the software downloaded (1.1.0) but maybe not? Will give it another go though tonight as getting to the point now where I just want to send the S2 back altogether!

I did contact NI support and they've sent me a replacement controller but I'm still having the same issue so it's gotta be something to do with the drivers etc, just not sure what exactly!

----------

Quote:
Originally Posted by ItsJackNi View Post
Have you got anywhere with this.. im having the same problem and have been for ages.. did you find a solution?
Not as yet but going to try the suggestion above tonight again. Any luck with yours?
LucyMal is offline   0 Reply With Quote
Old Aug 12, 2013, 10:27 AM   #5
mth79
macrumors newbie
 
Join Date: Jul 2013
Quote:
Originally Posted by LucyMal View Post
Hi,

Thanks for responding. I've tried downloading the 1.0.8. version but it won't install - the 'install' button is greyed out once I've downloaded/opened the update. I assumed this was because I already have a more recent version of the software downloaded (1.1.0) but maybe not? Will give it another go though tonight as getting to the point now where I just want to send the S2 back altogether!

I did contact NI support and they've sent me a replacement controller but I'm still having the same issue so it's gotta be something to do with the drivers etc, just not sure what exactly!

----------



Not as yet but going to try the suggestion above tonight again. Any luck with yours?
I'd say that you don't have enough space on you hard drive you may need to delete a couple of files
mth79 is offline   0 Reply With Quote
Old Nov 14, 2013, 01:25 AM   #6
aaronhbridges
macrumors newbie
 
Join Date: Nov 2013
Possible solution

I have gotten past a few issues with Traktor Pro 2 / S2 / Early 2008 Macbook Core2Duo. I downgraded to Snow Leopard but I think that this might actually work with Lion as well because I had to try a few things even after downgrading before things started working.

Initially on Lion I installed the latest 2.6 update from the NI site and after that no matter what I did, fresh Lion install, install drivers then Traktor, Traktor then drivers, etc all I ever got was the flashing USB panic light.

BTW I know that the S2 is fine b/c it works on my macbook pro without any problem.

After failing on Lion I reinstalled Snow Leopard, then installed the 1.0.8 driver update then I tried to install Traktor but NI actually dropped support for SL after 2.6.0. I couldn't find any way on the NI site to download the older versions (except updates, we'll get to that in a minute) so I torrented 2.6 and installed that. Same issue, no control, flashing usb panic. I noticed on the torrented release that it did not install drivers or service center so I downloaded the 2.6 update from the NI site under updates and installed that with default options to install all drivers and bingo, working S2 with Macbook Early 2008.

I suspect that the 1.0.8 driver is somehow not compatible with the older macbook so using that older update's version fixed it. Hopefully this will work on Lion as well for you!
aaronhbridges is offline   0 Reply With Quote

Reply
MacRumors Forums > Special Interests > Digital Audio

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
MacBook Pro weird USB issue saturnotaku MacBook Pro 0 Jan 11, 2014 02:39 PM
traktor kontroler s2 with mac ItsJackNi Digital Audio 0 Jul 19, 2013 12:35 PM
First issue with Macbook Pro: USB Port Failure Totty1987 MacBook Pro 4 Sep 2, 2012 09:57 AM
MacBook Pro Retina USB 3.0 Issue solved? alexduff MacBook Pro 0 Jul 22, 2012 06:42 PM
rMBP Battery Indicator Issue reRESERVEDMD MacBook Pro 11 Jun 29, 2012 04:25 PM

Forum Jump

All times are GMT -5. The time now is 08:18 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC