Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > OS X > Mac OS X Server, Xserve, and Networking

Reply
 
Thread Tools Search this Thread Display Modes
Old Jul 22, 2013, 02:49 PM   #1
carlosribas
macrumors newbie
 
Join Date: Jun 2013
Error creating Open Directory Replica in Mountain Lion

I am encountering problems setting up an Open Directory Replica using the Server.app version 2.2.1 (169) in Mountain Lion (10.8.4) in the OD Mater and OD Replica. I receive the error attached when it attempts to create the replica.

The message says it is a network error, but the command "changeip -checkhostname" shows that everything is ok with ODM and with the server I want to use as ODR.

Any help would be greatly appreciated. Thanks.
Attached Thumbnails
Click image for larger version

Name:	replica error.png
Views:	32
Size:	149.3 KB
ID:	424241  
carlosribas is offline   0 Reply With Quote
Old Aug 26, 2013, 01:03 PM   #2
dvdborn
macrumors newbie
 
Join Date: Aug 2013
Location: Belgium
I've got the exact same problem.

I setup 2 clean installed 10.8.4 servers.

I configured one as an OD Master with no problems.
I then tried to configure the second as a replica and it always fails.

Both servers have a FQDN.
sudo changeip -checkhostname shows no error on both servers.

I tried these instructions: http://www.mountainlionserver.com/se...in-lion-server

But running sudo slapconfig -preflightreplica 172.16.2.23 diradmin on the replica-wanna-be server gives an error.

Has anyone succeeded in setting up a replica under 10.8.4?
dvdborn is offline   0 Reply With Quote
Old Aug 26, 2013, 01:43 PM   #3
chrfr
macrumors 68000
 
Join Date: Jul 2009
Quote:
Originally Posted by dvdborn View Post
gives an error
Helpful tip: when asking questions about errors, state the error.

And yes, I have a 10.8.4 OD Master/replica working fine.
chrfr is offline   0 Reply With Quote
Old Aug 26, 2013, 04:55 PM   #4
dvdborn
macrumors newbie
 
Join Date: Aug 2013
Location: Belgium
Good to hear that someone has succeeded in setting up a 10.8.4 replica.

When I run the slapconfig -preflightreplica command I get the following message.

2013-08-26 15:03:30 +0000 NSMutableDictionary *_getRootDSE(const char *): rootDSE not found
2013-08-26 15:03:30 +0000 Error: Unable to determine the master's software version
dvdborn is offline   0 Reply With Quote
Old Aug 26, 2013, 05:55 PM   #5
chrfr
macrumors 68000
 
Join Date: Jul 2009
Quote:
Originally Posted by dvdborn View Post
But running sudo slapconfig -preflightreplica 172.16.2.23 diradmin on the replica-wanna-be server gives an error.

Has anyone succeeded in setting up a replica under 10.8.4?
Is 172.16.2.23 your OD Master's IP address?
What is your DNS setup? Are both master and replica on the same network? Is there a firewall in the way?
chrfr is offline   0 Reply With Quote
Old Aug 27, 2013, 10:51 AM   #6
dvdborn
macrumors newbie
 
Join Date: Aug 2013
Location: Belgium
I managed to create an OD replica 10.8.4 from a 10.8.4 OD Master.

I followed the instructions in this discussion:
https://discussions.apple.com/thread...rt=15&tstart=0

What I can't create now is an OD replica from an OD Master that's also bound to AD.
dvdborn is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > Mac OS X Server, Xserve, and Networking

Tags
mountain lion, open directory, replica

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:38 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC