Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 7

Reply
 
Thread Tools Search this Thread Display Modes
Old Jul 30, 2013, 08:58 AM   #1
hodor123
macrumors newbie
 
Join Date: Jul 2013
iOS 7 beta 4 screen goes black after update

I have been using iOS 7 betas without any issues. However, yesterday after the OTA, my iPhone 4 booted up with the Apple logo and then went black. iTunes is able to detect it and even when I tried calling on my number from another phone, the call went through but I didn't see anything on my iPhone.

I tried restoring it by downloading the ipsw. I got the setup screen and after completing the setup, the iPhone again booted and went black.

I then restored to 6.1.3, which worked fine. I tried to restore it again to beta 4, and same issue again.

I doubt its a hardware issue, since I get the setup screen and it works. Any suggestions?
hodor123 is offline   0 Reply With Quote
Old Jul 30, 2013, 08:59 AM   #2
Tyler23
macrumors 601
 
Tyler23's Avatar
 
Join Date: Dec 2010
Location: Atlanta, GA
Quote:
Originally Posted by hodor123 View Post
I have been using iOS 7 betas without any issues. However, yesterday after the OTA, my iPhone 4 booted up with the Apple logo and then went black. iTunes is able to detect it and even when I tried calling on my number from another phone, the call went through but I didn't see anything on my iPhone.

I tried restoring it by downloading the ipsw. I got the setup screen and after completing the setup, the iPhone again booted and went black.

I then restored to 6.1.3, which worked fine. I tried to restore it again to beta 4, and same issue again.

I doubt its a hardware issue, since I get the setup screen and it works. Any suggestions?
Hold the home and power buttons until you see the Apple logo. This is a hard reset, and has fixed this issue for others.
Tyler23 is online now   0 Reply With Quote
Old Jul 30, 2013, 09:02 AM   #3
hodor123
Thread Starter
macrumors newbie
 
Join Date: Jul 2013
Hi,

Thanks. I have tried that, doesn't work. It boots up, the Apple logo shows up, and again goes blank.
hodor123 is offline   0 Reply With Quote
Old Jul 30, 2013, 09:02 AM   #4
Topher227
macrumors member
 
Join Date: Sep 2012
Location: CT
If you continue having this issue but are able to get to the homescreen, you may have some app data/settings causing the problem.

Try resetting all settings by going to Settings > General > Reset.
If you still have problems... you may need to restore and then start as a new iPhone.

Hope this helps.
Topher227 is offline   0 Reply With Quote
Old Jul 30, 2013, 09:04 AM   #5
bbfc
macrumors 68000
 
bbfc's Avatar
 
Join Date: Oct 2011
Location: Gosforth, England
Quote:
Originally Posted by Topher227 View Post
If you continue having this issue but are able to get to the homescreen, you may have some app data/settings causing the problem.

Try resetting all settings by going to Settings > General > Reset.
If you still have problems... you may need to restore and then start as a new iPhone.

Hope this helps.
I would set up as a new phone.

Restore to iOS 6 and set up as new and then update to the beta.
__________________
MacBook Pro (Early 2011), 2.3 GHz Intel Core i5, 4GB RAM, OS X Mavericks, OS X Yosemite DP7 | iPhone 5 16GB White, iOS 8
bbfc is offline   0 Reply With Quote
Old Jul 30, 2013, 09:08 AM   #6
hodor123
Thread Starter
macrumors newbie
 
Join Date: Jul 2013
Quote:
Originally Posted by Topher227 View Post
If you continue having this issue but are able to get to the homescreen, you may have some app data/settings causing the problem.

Try resetting all settings by going to Settings > General > Reset.
If you still have problems... you may need to restore and then start as a new iPhone.

Hope this helps.
I can't get to the homescreen. It goes blank right after the Apple logo.
hodor123 is offline   0 Reply With Quote
Old Jul 30, 2013, 10:25 AM   #7
Topher227
macrumors member
 
Join Date: Sep 2012
Location: CT
One last thing i'd try before restoring and setting up as a new phone:

Restore to the latest OS you can successfully run, with all your data.
Reset all settings.
Goto Settings > iCloud and disable Find My iPhone (this helped in previous betas...)
Update to iOSb4 from iTunes.

If it works, make sure to re-enable Find My iPhone. If it doesn't, it looks like your only other option is to start as a new phone
Topher227 is offline   0 Reply With Quote
Old Jul 31, 2013, 11:06 AM   #8
ttrelva
macrumors newbie
 
Join Date: Nov 2010
the same thing has happened to me. i can't access through iTunes because it is awaiting for me to press the "i trust this computer" on my iPhone - but obviously i can't do that because the screen is black

if i call it, the call goes through but the iPhone doesn't ring or vibrate or anything
ttrelva is offline   0 Reply With Quote
Old Jul 31, 2013, 01:26 PM   #9
ttrelva
macrumors newbie
 
Join Date: Nov 2010
i had to put it in DFU mode and trying to restore to 6.1.3. it tried to restore to iOS 7 beta 3 but an error occurred
ttrelva is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 7

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iOS 7.1 BETA 5 update smooth as ever. cammyg123 iPad Tips, Help and Troubleshooting 2 Feb 12, 2014 03:18 PM
Should I update from Beta iOS 7 Fuma419 iOS 7 6 Sep 19, 2013 09:42 AM
iOS 7 beta 6 STILL no ota update option since beta 2 BigB82 iOS 7 14 Aug 17, 2013 11:08 PM
iPhone: Options for Jailbreaking after update to iOS 7 beta (currently on iOS 5.1.1 ) polzii Jailbreaks and iOS Hacks 3 Jul 14, 2013 02:56 PM
iPad: ipad 2 ios update black screen silver apple help gharris129 iPad 1 Feb 8, 2013 10:10 PM

Forum Jump

All times are GMT -5. The time now is 11:07 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC