Go Back   MacRumors Forums > iPhone, iPod and iPad > Alternatives to iOS and iOS Devices

Reply
 
Thread Tools Search this Thread Display Modes
Old Dec 18, 2013, 10:44 AM   #1
radus
macrumors newbie
 
Join Date: Jan 2009
Nexus 5 Bluetooth Problems - Car Audio

hello I have massive problems pairing my Nexus 5 to the BMW Bluetooth module - it pretends to pair but stays in "Please Wait"

Is there anybody here without "bluetooth problems"?

had to switch back to the iphone 5s because of this ! (iphone 4 , iphone 5, xperia zl, iphone 5s are pairing remarkable good...)
radus is offline   0 Reply With Quote
Old Dec 18, 2013, 11:34 AM   #2
mattopotamus
macrumors 604
 
Join Date: Jun 2012
Quote:
Originally Posted by radus View Post
hello I have massive problems pairing my Nexus 5 to the BMW Bluetooth module - it pretends to pair but stays in "Please Wait"

Is there anybody here without "bluetooth problems"?

had to switch back to the iphone 5s because of this ! (iphone 4 , iphone 5, xperia zl, iphone 5s are pairing remarkable good...)
Mine works fine. Are you pairing when you first start your car? I know a lot of cars will only pair within the first few seconds and if no device is connected it will auto shut off.
mattopotamus is offline   0 Reply With Quote
Old Dec 18, 2013, 12:27 PM   #3
Lloydbm41
macrumors 68020
 
Lloydbm41's Avatar
 
Join Date: Oct 2013
Location: Central California
Quote:
Originally Posted by radus View Post
hello I have massive problems pairing my Nexus 5 to the BMW Bluetooth module - it pretends to pair but stays in "Please Wait"

Is there anybody here without "bluetooth problems"?

had to switch back to the iphone 5s because of this ! (iphone 4 , iphone 5, xperia zl, iphone 5s are pairing remarkable good...)
No problems pairing my Nexus 5 with Ford Focus, Chevy Volt, wireless headsets, wireless BT speakers or anything else. Works perfectly with everything.

Are you stock or using a ROM? Have you made any changes to the phone at all?
__________________
Current Phone: iPhone 6
Current Tablet: Venue Pro 8 running Win8.1
On the shelf: Lumia 925/1020, original Moto X, Nexus 4/5/7, original Apple iPad, Dell Venue 8
Lloydbm41 is offline   0 Reply With Quote
Old Dec 18, 2013, 02:13 PM   #4
radus
Thread Starter
macrumors newbie
 
Join Date: Jan 2009
stock android, pairing procedure as BMW wants it

thanks for your help!

I use stock android (now 4.4.2) - there are no problems using a bt-headset, but pairing with the cars bluetooth just does not work (beginning from the cold), the cars bluetooth works flawlessy with iPhones and Sony xperia zl (Android 4.2.2)
radus is offline   0 Reply With Quote
Old Dec 18, 2013, 02:19 PM   #5
Lloydbm41
macrumors 68020
 
Lloydbm41's Avatar
 
Join Date: Oct 2013
Location: Central California
Quote:
Originally Posted by radus View Post
thanks for your help!

I use stock android (now 4.4.2) - there are no problems using a bt-headset, but pairing with the cars bluetooth just does not work (beginning from the cold), the cars bluetooth works flawlessy with iPhones and Sony xperia zl (Android 4.2.2)
Sounds like an a2dp issue. Clear all of your BT connections from your nexus 5. Reboot nexus 5. Start your car and go into phone pairing mode. Start BT on your nexus and then click search for devices. You should now see your car and the car should reset its display to match pin numbers with your phone.
__________________
Current Phone: iPhone 6
Current Tablet: Venue Pro 8 running Win8.1
On the shelf: Lumia 925/1020, original Moto X, Nexus 4/5/7, original Apple iPad, Dell Venue 8
Lloydbm41 is offline   0 Reply With Quote
Old Dec 18, 2013, 02:40 PM   #6
mattopotamus
macrumors 604
 
Join Date: Jun 2012
I did have an issue that started this Monday out of nowhere. Every time my phone would pair it would auto launch google music (I have audio off under the paired settings). The only way I was able to fix it was to disable google play music totally.
mattopotamus is offline   0 Reply With Quote
Old Dec 18, 2013, 02:48 PM   #7
radus
Thread Starter
macrumors newbie
 
Join Date: Jan 2009
--> Lloydbm41

that is what I did - I even deleted all the car’s connectiones, rebooted the nexus 5, enabled ART (as the last trial) … did not work, the phone is able to find the car and I can enter the car’s bt-passkey … and then “Plaese wait” … for ever
radus is offline   0 Reply With Quote
Old Dec 19, 2013, 07:22 PM   #8
Delorean2006
macrumors 6502
 
Join Date: Feb 2012
Quote:
Originally Posted by Lloydbm41 View Post
No problems pairing my Nexus 5 with Ford Focus, Chevy Volt, wireless headsets, wireless BT speakers or anything else. Works perfectly with everything.

Are you stock or using a ROM? Have you made any changes to the phone at all?
You have a Chevy volt? I love that car! My favorite electric car, I despise pretty much any electric car other then that, how do you like it and I only came here because I'm getting a nexus 5 and I strictly use Bluetooth when I'm in my car
Delorean2006 is offline   0 Reply With Quote
Old Dec 19, 2013, 07:42 PM   #9
Lloydbm41
macrumors 68020
 
Lloydbm41's Avatar
 
Join Date: Oct 2013
Location: Central California
Quote:
Originally Posted by Delorean2006 View Post
You have a Chevy volt? I love that car! My favorite electric car, I despise pretty much any electric car other then that, how do you like it and I only came here because I'm getting a nexus 5 and I strictly use Bluetooth when I'm in my car
Chevy Volt is probably my favorite car I have ever owned in my nearly 3 decades of driving. Not because it is the most luxurious or the fastest or the best looking, but all around it is just a fun a little car. And the fact that I go on average 1200 miles before needing gas... and it only costs $33 here in California to fill up (on Premium!) Electric cost is roughly $35 a month on your home electric bill. In California, you can get special rates for home electric if you own the Volt. And the $7500 I got back on my tax return from the Federal government was quite nice!

Anyway, I have no issues connecting my Nexus 5 or previously my Nexus 4 or Nexus 7 to my Volt. It connects right up every time. Doesn't matter if I use a custom ROM or stock Android. Additionally, you can use your steering wheel controls to change tracks on Pandora, G Music and a couple other music players I have used. Calls are crystal clear and also controlled by the steering wheel controls.
__________________
Current Phone: iPhone 6
Current Tablet: Venue Pro 8 running Win8.1
On the shelf: Lumia 925/1020, original Moto X, Nexus 4/5/7, original Apple iPad, Dell Venue 8
Lloydbm41 is offline   0 Reply With Quote
Old Dec 19, 2013, 08:32 PM   #10
Vegastouch
macrumors 601
 
Vegastouch's Avatar
 
Join Date: Jul 2008
Location: Las Vegas, NV
No issue. My Nexus 5 works better with my car (13 Nissan Altima) than my GS3 did. And you dont have to start the car to pair it. Just turn on to accesssaries so the bluetooth is on. There is no difference from that and starting it.

Last edited by Vegastouch; Dec 19, 2013 at 09:06 PM.
Vegastouch is offline   0 Reply With Quote
Old Dec 20, 2013, 01:03 PM   #11
AutoUnion39
macrumors 68030
 
Join Date: Jun 2010
Quote:
Originally Posted by radus View Post
--> Lloydbm41

that is what I did - I even deleted all the car’s connectiones, rebooted the nexus 5, enabled ART (as the last trial) … did not work, the phone is able to find the car and I can enter the car’s bt-passkey … and then “Plaese wait” … for ever
Do you have iDrive? What I usually do is delete the devices from both the car and phone. Then reboot phone. Then when you are search for devices, make sure to punch in the same pass-key for both (usually do 1111 or 0000).

My 4.4 ROM (on my GS4) works perfectly with my BMW and Audi.
AutoUnion39 is offline   0 Reply With Quote
Old Dec 20, 2013, 03:09 PM   #12
radus
Thread Starter
macrumors newbie
 
Join Date: Jan 2009
its a 2005 e53 x5 without iDrive - may be i should by a new car, but it is nearly as good as a new one and i am the first owner.
so i bought an iPhone 5s and use it all the day.

in the evening i play half an hour with my Nexus 5 - I love it so - it is such a shame that i can not get it to work with the car's bluetooth
radus is offline   0 Reply With Quote
Old Jan 1, 2014, 01:39 AM   #13
Rampant Lion
macrumors newbie
 
Join Date: Jan 2014
Angry Same issue

I have a 2004 BMW X5 e53 without Nav, never had a problem pairing any phone but now Nexus 5 pairs ok with the car then drops the bluetooth connection 10 seconds later... All I want to do it use the car kit.
Rampant Lion is offline   0 Reply With Quote
Old Jan 1, 2014, 12:13 PM   #14
kevinof
macrumors 6502a
 
Join Date: Jul 2008
Location: Dublin/London
could it be anything to do with this?

http://www.androidpolice.com/2013/12...etooth-issues/
kevinof is offline   0 Reply With Quote
Old Jan 6, 2014, 05:08 AM   #15
Rampant Lion
macrumors newbie
 
Join Date: Jan 2014
Quote:
Originally Posted by kevinof View Post
could it be anything to do with this?

http://www.androidpolice.com/2013/12...etooth-issues/
Yeah already tried the remedies suggested there... Sadly looks like I am without a car kit until I give up and buy back into an iPhone.
Rampant Lion is offline   0 Reply With Quote
Old Jan 7, 2014, 07:11 AM   #16
pojo1806
macrumors 6502
 
Join Date: Feb 2013
I have issues with my car not seeing all my contacts on the Nexus 5.
__________________
iPad Air 16gb Space Grey | Apple TV 3 | Samsung Galaxy Note 3 32gb Black | Moto 360 Black
pojo1806 is offline   0 Reply With Quote
Old Jan 7, 2014, 12:52 PM   #17
daveathall
macrumors 68000
 
daveathall's Avatar
 
Join Date: Aug 2010
Location: North Yorkshire
Mine works with my 1 series BMW flawlessly.
daveathall is offline   0 Reply With Quote
Old Jan 7, 2014, 03:15 PM   #18
Vegastouch
macrumors 601
 
Vegastouch's Avatar
 
Join Date: Jul 2008
Location: Las Vegas, NV
Quote:
Originally Posted by pojo1806 View Post
I have issues with my car not seeing all my contacts on the Nexus 5.
Has to be your car. My Nexus 5 works better with my car than my GS3 did in that respect. Could be thebphone i guess. I dont really kow why my car wouldnt remember my contacts w/ the GS3 but does w/ my Nexus.
Vegastouch is offline   0 Reply With Quote
Old Jan 7, 2014, 05:32 PM   #19
radus
Thread Starter
macrumors newbie
 
Join Date: Jan 2009
it was the car

the nexus 5 works perfectly with a friends Porsche PCM 3.1 ...
radus is offline   0 Reply With Quote
Old Jan 8, 2014, 03:29 AM   #20
pojo1806
macrumors 6502
 
Join Date: Feb 2013
Quote:
Originally Posted by Vegastouch View Post
Has to be your car. My Nexus 5 works better with my car than my GS3 did in that respect. Could be thebphone i guess. I dont really kow why my car wouldnt remember my contacts w/ the GS3 but does w/ my Nexus.
I thought that but it worked perfectly with iPhone 4 and 5S.
__________________
iPad Air 16gb Space Grey | Apple TV 3 | Samsung Galaxy Note 3 32gb Black | Moto 360 Black
pojo1806 is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > Alternatives to iOS and iOS Devices

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iPhone: Any way to pass iPhone audio notifications through bluetooth audio to car speakers? shenan1982 Jailbreaks and iOS Hacks 25 Jul 7, 2014 12:22 PM
Bluetooth audio receiver for the car CTYankee Buying Tips and Advice 7 Jul 3, 2014 09:13 AM
Audio Bluetooth Dongle (Car use) Kleber20 Digital Audio 2 Apr 14, 2014 06:13 PM
iPhone car head unit stereo like Oxygen Audio O'car (iphone interface with bluetooth) musio iPhone Accessories 4 Jan 24, 2014 02:21 PM
Bluetooth Car Audio Controls hypervish89 iOS 7 3 Aug 28, 2013 01:07 PM

Forum Jump

All times are GMT -5. The time now is 02:05 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC