Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Desktops > Mac Pro

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 27, 2006, 10:15 PM   #1
cliffrouse11bas
macrumors regular
 
Join Date: Oct 2005
Temperature Sensor Problem In New Imac Intel?

Is anyone else having this problem. None of my Heat Widgets are working. Thanks

Cliff
__________________
Check Out My Ebay Auctions
cliffrouse11bas is offline   0 Reply With Quote
Old Jan 27, 2006, 10:25 PM   #2
Laser47
macrumors 6502a
 
Laser47's Avatar
 
Join Date: Jan 2004
Location: Maryland
I dont have a iMac Duo. But its most likely because the new imac uses a different sensor and the software you are using doesn't know how to read it. Im sure sooner or later there will be an update though.


Edit::
Try typing this into terminal, it will show you temp readouts
Quote:
#!/bin/bash
#
# TP Probe v.0.2 alpha
# by 31d1 2005 djbidi@gmail.com
#
# displays (somewhat accurate) hardware sensor readouts on some current macs.
#
# seems to work on new Powerbooks, ibooks, and PowerMacs
# does NOT seems to work on G4 Powermacs, or G4 Titanium Powerbooks

# help

if [ "$1" == "-h" ]
then
basename=`echo $0 | sed 's/.*\///'`
echo "usage: $basename [option|regex]"
echo " regex - display only matching lines"
echo " -h - display this message"
exit
fi

# get data

sensors=`ioreg -n IOHWSensor | awk '/location/ || /current-value/ || /"type"/' | sed -e 's/[^"]*"//' -e 's/" =//' -e 's/location//' -e 's/type//' -e 's/"//g' | awk '{ if ((NR % 3) == 0) print $0; else printf $0 " " }'`

# temperatures require strange manipulation

temps=`echo "$sensors" | grep 'temperature' | awk '{ for(i=1;i<5;i++) if ($i=="current-value") $(i+1)=((( (($(i+1) / 2^13) - ($(i+1) / 2^13) % 1 ) / 2^3) - .5)" C\t"); print $0 }' | sed -e 's/current-value //' -e 's/temperature//'`

# the rest merely need to be divided by 2^16

therest=`echo "$sensors" | grep -v 'temperature' | awk '{ for(i=1;i<5;i++) if ($i=="current-value") $(i+1)=(substr((($(i+1)/2^16)"\t"),1,8)); print $0 }' | sed -e 's/current-value //'`

# optionally display Machine Name and Type

if [ "$1" == "-l" ]
then
system_profiler SPHardwareDataType | awk '/Machine Name/ || /Machine Model/ || /CPU Type/' | sed 's/[^:]*: //' | awk '{printf $0 " " }'
machine
echo -e "\n$temps\n$therest"
exit
fi

# grep for $1 or display all

if [ "$1" ]
then
echo -e "$temps\n$therest" | grep "$*"
else
echo -e "$temps\n$therest"
fi
From http://www.macosxhints.com/article.p...51021115356696
__________________
iBook G4 14" 1.42ghz, 1.5gb RAM, 100gb 7200rpm Travelstar, 4G iPod 40gb
Laser47 is offline   0 Reply With Quote
Old Jan 27, 2006, 11:40 PM   #3
cliffrouse11bas
Thread Starter
macrumors regular
 
Join Date: Oct 2005
Anyone else having this problem?
__________________
Check Out My Ebay Auctions
cliffrouse11bas is offline   0 Reply With Quote
Old Jan 30, 2006, 10:44 AM   #4
bertieuk
macrumors newbie
 
Join Date: Jan 2006
The above script returned nothing on my intel imac

Where are you getting the temp widgets from ? I'll try them then.

Bertie
bertieuk is offline   0 Reply With Quote
Old Jan 30, 2006, 01:58 PM   #5
Laser47
macrumors 6502a
 
Laser47's Avatar
 
Join Date: Jan 2004
Location: Maryland
Here are some pretty good temp programs and widgets.
__________________
iBook G4 14" 1.42ghz, 1.5gb RAM, 100gb 7200rpm Travelstar, 4G iPod 40gb
Laser47 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Desktops > Mac Pro

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
thread Thread Starter Forum Replies Last Post
new iMac 27" i5 & i7 - is there still display problem? onefine iMac 15 Nov 24, 2010 01:31 AM
new imac intel - sound output device problem fookey Mac Pro 0 May 14, 2006 05:05 PM
Can i Put DDR ram in the new iMac Intel?? poolin1243 Mac Pro 3 Mar 9, 2006 03:37 PM
USB problems in new Intel iMacs maverick808 Mac Pro 25 Feb 6, 2006 10:39 PM
Screen Saver Problems on new iMac w/ Intel jleigh Mac Basics and Help 1 Jan 28, 2006 07:25 AM


All times are GMT -5. The time now is 04:33 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC