Go Back   MacRumors Forums > Apple Hardware > PowerPC Macs

Reply
 
Thread Tools Search this Thread Display Modes
Old Mar 25, 2006, 08:22 AM   #1
Thomas Harte
macrumors 6502
 
Join Date: Nov 2005
Tibook 667Mhz: weird USB (?) problem

I have a 667Mhz Powerbook without DVI connector. The touchpad has long had issues of suddenly ceasing to work, which I gather is relatively common due to issues with internal grounding and/or insulation. I actually know more or less nothing about electronics, so please excuse my vagueness on the issue. I'm not a big fan of touchpads anyway (especially when they only have a single button and I can't change which one it is without paying), so this never bothered me.

So, I have happily been using a USB mouse. For the last few months the computer has developed a fun game where every so often it instaneously "forgets" about the plugged in mouse and subsequently ignores it. It would still be listed in the System Profiler as attached, and was obviously still getting power (as an optical mouse, the little red LED on the bottom would keep lighting up) but the machine would ignore it. Unplugging it and plugging it back in would fix the problem. At first this would happen maybe once every few days. Lately it had been as often as once or twice a day.

I don't have anything I can plug into the various other ports on the back (ethernet, firewire, modem, etc), so I'm not sure if this is a "back panel" or a USB specific problem.

Then on Thursday the machine decided it wasn't interested in recognising anything plugged into USB. My mouse gets power but doesn't otherwise do anything. Ditto for my iPod.

All this time, the bluetooth adapter I had plugged into the PCMCIA slot continued working (via Card Blues Suite). But if I plug in a USB PCMCIA card then my machine ignores that as well. So frustratingly I can no longer use USB peripherals.

This problem shows itself in OS X v10.4.5 and in the boot folder selection screen that you get if you hold down option while booting, so I am quite sure it is a hardware issue.

I'm on a severe budget at the minute, so a new machine is not a realistic prospect for the foreseeable problem. Will Apple still service machines like mine (from 2001), or is there perhaps some software fix I can apply to work around the problem? It seems very strange to me that my USB PCMCIA card gets ignored while my bluetooth card works fine.
Thomas Harte is offline   0 Reply With Quote
Old Mar 26, 2006, 01:52 AM   #2
California
macrumors 68040
 
California's Avatar
 
Join Date: Aug 2004
Quote:
Originally Posted by Thomas Harte
I have a 667Mhz Powerbook without DVI connector. The touchpad has long had issues of suddenly ceasing to work, which I gather is relatively common due to issues with internal grounding and/or insulation.
I'm on a severe budget at the minute.
I happen to have a working trackpad from a DVI tibook. The case was bent and I stripped it of all working parts, including the trackpad. It is just taped onto the underside of your topcase. Five bucks! Don't know what to say about the usb thing but it I think Tibooks were usb 1.0, not 2.0; that could be the problem.
__________________
2.66ghz 13" MBP/1.67ghz Powerbook G5 15" DLHR/iPhone 16gb/30" ACD
California is online now   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > PowerPC Macs

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
MacBook Pro weird USB issue saturnotaku MacBook Pro 0 Jan 11, 2014 02:39 PM
Weird USB problem - MPro OS 10.7.5 macmesser Mac Pro 0 Jan 2, 2014 07:19 PM
Weird problem HeyKatie iOS 7 1 Aug 19, 2013 05:17 PM
Weird music playback behaviour when plugged into car USB Moccasin iPhone 2 Apr 19, 2013 06:16 PM
Weird USB behaviour using CD's ripped from iTunes when played on BMW iDrive (2012) snerkler Mac Applications and Mac App Store 0 Jul 27, 2012 10:13 AM

Forum Jump

All times are GMT -5. The time now is 12:13 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC