Go Back   MacRumors Forums > Apple Hardware > PowerPC Macs

Reply
 
Thread Tools Search this Thread Display Modes
Old Nov 27, 2006, 12:58 AM   #1
optima
macrumors newbie
 
Join Date: Nov 2006
MacBook Pro, Powerbook Wireless conflict

I have a MacBook Pro C2D and a 12" Powerbook and my wireless network runs on a Motorola SBG900 using WPA for security.

I'm having an issue where, every time the 12" Powerbook joins the network, my MacBook Pro is disconnected from the wireless network and displays the following message:

"The wireless network appears to have been compromised and will be disabled for about a minute."

After this, I cannot reactivate the wireless connection for a minute and on some occasions it will not reactive at all.

I am using DHCP and have allocated enough IP's and allowed the MAC addresses for both machines. I've also had no problems when sharing the network with a number of Windows laptops and the Powerbook, but the MacBook Pro is always kicked off.

Has anyone experienced this problem, is it possible that there is some conflict between the laptops regarding IP, MAC, WPA Protocol. And does anyone have any tips on how to debug this?

Searching google for this exact phrase only returns 2 pages of results, there is a site with a screenshot of the dialog box, which looks like this.

Any help much appreciated.
optima is offline   0 Reply With Quote
Old Nov 28, 2006, 03:15 AM   #2
mad jew
Moderator emeritus
 
mad jew's Avatar
 
Join Date: Apr 2004
Location: Adelaide, Australia
There was a bug a while back that I thought was fixed. I only saw it once but from memory, changing the password on the router fixes it.

If that doesn't help, turn off the WPA to see if that has any effect. This isn't necessarily a long term solution so much as a test to see if it is the WPA causing this conflict.
__________________
Some things are better mad...
mad jew is offline   0 Reply With Quote
Old Nov 29, 2006, 06:13 PM   #3
optima
Thread Starter
macrumors newbie
 
Join Date: Nov 2006
Thanks for the reply.

Turning off WPA did stop the problem occurring but that's not really a workable solution

I noticed that if the Powerbook was on the wireless network first, the MacBook Pro could join and remain on. But, if it was the other way around the MacBook Pro would get disconnected.

Looking at the Network / Airport settings of both machines I tried to see what might be different.

The only thing I could see was that the Powerbook had AppleTalk ticked in the AppleTalk settings area of the Airport configuration. I haven't turned this on so I assume that it might default to on with Powerbooks (?). I turned this off and connected both machines and now they work.

Just to be sure, with both machines on the network, I turned AppleTalk back on and the MacBook Pro was kicked off immediately.

I don't really know why AppleTalk was on, or why it causes the WPA wireless to panic and disconnect machines, but that seems to have solved the problem.
optima is offline   0 Reply With Quote
Old Nov 29, 2006, 06:47 PM   #4
smueboy
macrumors 6502a
 
smueboy's Avatar
 
Join Date: Oct 2006
Location: Oz
That's interesting. I just got my MBP, and tried to connect to my Airport with my PB also in the room. I could not connect to my airport at all, until i turned the airport Off on my PB (even though my PB was Not connected to my airport at the time). strange.
smueboy is offline   0 Reply With Quote
Old Nov 29, 2006, 09:35 PM   #5
optima
Thread Starter
macrumors newbie
 
Join Date: Nov 2006
Did you check if AppleTalk was activated on the PB, if it is, try turning it off and see if that solves it. Worked for me.
optima is offline   0 Reply With Quote
Old Nov 30, 2006, 12:26 AM   #6
mad jew
Moderator emeritus
 
mad jew's Avatar
 
Join Date: Apr 2004
Location: Adelaide, Australia
AppleTalk shouldn't be doing this. Did you try changing your WPA password?


Quote:
Originally Posted by smueboy View Post
That's interesting. I just got my MBP, and tried to connect to my Airport with my PB also in the room. I could not connect to my airport at all, until i turned the airport Off on my PB (even though my PB was Not connected to my airport at the time). strange.

What sort of wireless security do you have?
__________________
Some things are better mad...
mad jew is offline   0 Reply With Quote
Old Nov 30, 2006, 08:29 AM   #7
smueboy
macrumors 6502a
 
smueboy's Avatar
 
Join Date: Oct 2006
Location: Oz
Quote:
Originally Posted by mad jew View Post
AppleTalk shouldn't be doing this. Did you try changing your WPA password?
The apple talk setting is inactive on both machines. I did not try changing the WPA password.
I think the problem may stem from the fact that both of my computers have the same name - my PB just automatically renamed its' network identity and now i can connect both computers to my airport with no problem.
smueboy is offline   0 Reply With Quote
Old Jan 2, 2008, 10:21 AM   #8
nashccast
macrumors newbie
 
Join Date: Jan 2008
How I solved this problem.. sort of...

Here's my setup - Motorola SBG900 (Comcast firmware, WPA PSK, MAC address access control), one iBook G4, one SR MacBook Pro, (both running latest Tiger).

I started getting the 'network compromised' error on my SR MBP (but not on the iBook). It got progressively worse - Initially I would get the error when the iBook woke up while the MBP was already connected. Later, the network started getting compromised randomly, even when both the machined were already active, and even the iBook network became unreliable - although it never got the compromised error message.

A LONG phone call to Apple tech support proved fruitless. (They had me verify the network connection order on the SysPref pane, but then blamed it on the router when that didn't work)

Finally, as a last try before buying a different router, I switched the security protocol from WPA PSK to WEP. Since then, no problems!

I know, of course, that WEP essentially unsecured against attacks, but since this is a home network, I chance of having to face anything like that is probably pretty low. So, if you have a similar setup, switching from WPA to WEP might work.
nashccast is offline   0 Reply With Quote
Old Aug 25, 2008, 09:54 AM   #9
tcurtin
macrumors newbie
 
Join Date: Aug 2008
Use AES to stop "wireless network appears to have been compromised" messages

Randomly ran across this post during a search for the problem online. It looks like the solution isn't so much WPA2 versus WEP as it is choosing the AES encryption method instead of TKIP. Some routers allow you to choose - TKIP seems to cause problems during periods of heavy use. (I was having the problem while using a Linksys WRT54Gv8 with DD-WRT installed. It would show up most often while using Skype. Switching from TKIP to AES solved the problem immediately.)

Good luck!
tcurtin is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > PowerPC Macs

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Wireless speed on MacBook Pro oldmanmax MacBook Pro 1 Jan 6, 2014 05:36 PM
best wireless mouse for macbook pro boateng Mac Peripherals 12 Aug 8, 2013 10:21 AM
X3:reunion (not terran conflict) on 2009 5,2 macbook dogboy122 Mac and PC Games 6 Aug 14, 2012 08:19 AM
could my macbook run X3 terran conflict? dogboy122 MacBook 1 Jul 26, 2012 03:26 PM
Conflict with MailEnhancer Pro and IntelliscreenX robdam1001 Jailbreaks and iOS Hacks 2 Jul 17, 2012 08:33 AM

Forum Jump

All times are GMT -5. The time now is 07:21 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps