Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPod

Reply
 
Thread Tools Search this Thread Display Modes
Old May 24, 2007, 04:06 PM   #1
bmcgonag
macrumors 65816
 
bmcgonag's Avatar
 
Join Date: Mar 2007
Location: Texas
Send a message via Skype™ to bmcgonag
iTunes plays whole song...iPod cuts it off...Why?

I have a song in iTunes in .mp3 format. iTunes on my iMac Core 2 Duo plays it fine, also on my MBP plays it fine, but when I sync it to my iPod, the iPod plays about the first 3 or 4 seconds, and then quits abruptly, and moves on to the next song in the playlist.

I tried to play it straight as a song, same thing, and same from artist or album view. I have unloaded it and reloaded it using itunes, I restored my iPod to original settings, and let it reload the latest software, and then synced again, and it still does the same thing.

Any help with this is appreciated.

thanks,

Brian
__________________
OS X Tech Tips
24" White iMac Core 2 duo, 3 GB Ram, 1 TB, Orig & 2nd Gen AppleTV, iPhone 3GS, iPad Gen 1 - 16 Gig WiFi
Innovative CR
bmcgonag is offline   0 Reply With Quote
Old May 24, 2007, 05:10 PM   #2
kuebby
macrumors 68000
 
kuebby's Avatar
 
Join Date: Jan 2007
Location: Orange County
I've had the same problem before, previously I've just had to re-encode the song from the CD or wherever I got it from. I have no idea what causes that problem.
__________________
Plus ça change, plus c'est la même chose.
2.3 i7 rMBP / 32GB iPhone 5 / 160GB 7G iPod classic / 2G Shuffle
kuebby is offline   0 Reply With Quote
Old May 24, 2007, 08:38 PM   #3
DCBass
macrumors 6502
 
Join Date: Jan 2004
Location: Washington, DC
I have the same problem as well from time to time. abrupt skips on the iPod, and consistently at the same spot in an affected song. if i scroll past this point, the rest of the song usually plays. none of this happens in iTunes.

Another annoyance is that a lot of the artwork is screwed up on my iPod (not matching the proper songs), but there is no problem in iTunes. Perhaps they're related?

I don't really care about the second matter, but the first is very annoying. Much praise goes to the one that can solve our woes.

DCBass
DCBass is offline   0 Reply With Quote
Old May 25, 2007, 11:35 AM   #4
bmcgonag
Thread Starter
macrumors 65816
 
bmcgonag's Avatar
 
Join Date: Mar 2007
Location: Texas
Send a message via Skype™ to bmcgonag
Quote:
Originally Posted by DCBass View Post
I have the same problem as well from time to time. abrupt skips on the iPod, and consistently at the same spot in an affected song. if i scroll past this point, the rest of the song usually plays. none of this happens in iTunes.

Another annoyance is that a lot of the artwork is screwed up on my iPod (not matching the proper songs), but there is no problem in iTunes. Perhaps they're related?

I don't really care about the second matter, but the first is very annoying. Much praise goes to the one that can solve our woes.

DCBass
Using a bit of advice from the first reply I right clicked the song (even though it was already mp3) and selected convert to mp3. Deleted the original, and replaced the song in my playlists, and voila....it works fine now.

You might give it a try.

Brian
__________________
OS X Tech Tips
24" White iMac Core 2 duo, 3 GB Ram, 1 TB, Orig & 2nd Gen AppleTV, iPhone 3GS, iPad Gen 1 - 16 Gig WiFi
Innovative CR
bmcgonag is offline   0 Reply With Quote
Old May 25, 2007, 12:19 PM   #5
micvog
macrumors 6502
 
Join Date: Sep 2003
I have had this problem ever since I got my 1G Nano (right when they came out) and never found the ultimate solution. Almost my entire library is 192AAC, so it is not a MP3-specific problem.

My current solution is, whenever I encounter this problem on my iPod, is to change the rating to 0-stars (my entire library is rated). That then shows up on a smart playlist in iTunes the next time the iPod is synced. When I play the song in its entirety in iTunes, then re-sync the iPod, the song then plays fine on the iPod.

Unfortunately, other songs will become randomly "infected". I have about 5,000 songs in my library, and about 700 songs on my iPod, and I would estimate that I encounter this problem 1x/week.
micvog is offline   0 Reply With Quote
Old Jun 10, 2007, 05:29 PM   #6
miriamnz
macrumors newbie
 
Join Date: Feb 2007
I have this problem regularly now, though I did not before. I tried updating to iTunes 7 adn the problem got waorse so I went back to iTunes 6 and the problem persisits. I have a 4G iPod. I think it is a writing-to-the-ipod problem.
Like others I have found that the song is all there and OK in iTunes, adn that if you can scroll past the break then everyhting plays fine.
RIght now probably 1/3 of each set of copying is flawed. Deleting them from the iPod and copying again can fix it, but sometimes I have to do it several times, adn then tediously check through each one to see whetehr or not it is all there.
I can no longer copy podcasts to the iPod and expect them to work. True for songs too, but I don't swap them about so much.

I thought it might be a disk problem so I wiped and reformatted the disc with a multi-pass writing of zeros to make sure every part of the disk was attended to. This has made no difference.

I wonder whether there is an old piece of disk-writing software invoked by iTunes that the newer operating system has problems with - I think when I get the whirly cursor in the middle of a copy action that the copied file might be flawed. I wonder whether 4G iPods are being somehow not looked after in the software so we will get frustrated an upgrade. Unfortunately it is working, as it is so annyoing not to be able to trust the Ipod will have on it the stuff I have just put there.

MIriam
miriamnz is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPod

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Song plays at time where I press next. Sprhmn Unknwn iPhone Tips, Help and Troubleshooting 1 May 21, 2014 10:38 AM
Itunes Video Playback Cuts Out jon1987 Mac Applications and Mac App Store 0 May 4, 2014 12:55 PM
iTunes movie only plays on 3 of 5 of our ATV's??? GhostMac24 Apple TV and Home Theater 4 Dec 25, 2013 11:20 AM
Alarm App that plays more than one song adammgaines iPhone and iPod touch Apps 0 Oct 30, 2013 09:29 PM
If iTunes Match matches a pirated song, is it now a legal song? KarlJay Mac Applications and Mac App Store 15 Oct 1, 2012 11:44 PM

Forum Jump

All times are GMT -5. The time now is 11:52 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC