Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > Programming > Mac Programming

Reply
 
Thread Tools Search this Thread Display Modes
Old Jun 20, 2007, 01:11 PM   #1
vishwa
macrumors newbie
 
Join Date: Jun 2007
NFS - operation not permitted

Guys,
I tried to mount an NFS on to my Mac Tiger OS X (10.4.9) by using "sudo mount -t nfs /path_to_NFS ./directory_in_my_home" and the resultant terminal response is "mount_nfs: /Users/vishwa: Operation not permitted"
I have already tested this on a linux desktop and it works fine without any problems. Also tried changing target directories on my Mac, but ended up with the same result.
Any ideas on this?

Thanks,
vishwa
vishwa is offline   0 Reply With Quote
Old Jun 26, 2007, 12:12 AM   #2
hacksawSA
macrumors newbie
 
Join Date: Jun 2007
We must be insecure together!

So, I was having the same problem.

It turns out the the Darwin default is to assume the nfs'ing will take place on an "insecure" port, i.e. >1024.

The suggested solution is to add "insecure" to the export options.

For instance, I have

/usr3 192.168.4/24(rw,insecure)

In the /etc/exports file.

Good luck.
hacksawSA is offline   0 Reply With Quote
Old Jul 5, 2008, 07:34 AM   #3
dimitri001
macrumors newbie
 
Join Date: Jul 2008
works

Looking at the exports man page on my Linux box, you will always need this option to export NFS shares for OSX.

Thanks.
dimitri001 is offline   0 Reply With Quote
Old Oct 28, 2010, 01:57 PM   #4
yetanotheruser
macrumors newbie
 
Join Date: Oct 2010
NFS - operation not permitted, another solution

This thread is quite old, but I recently experienced the same problem with OS X 10.4.11 while trying to mount a NFS share on my DNS-323.

My solution was to mount with "-P" to force the use of a reserved port number, as described in mount_nfs(8) page. The command was

$> sudo mount_nfs -P <host>:<remote shared dir> <local mount point>

This solution probably addresses the secure/insecure port issue mentioned by hacksawSA, but I don't know enough to confirm that. It's also slightly less intrusive in that you don't have to modify /etc/exports.

-Ken
yetanotheruser is offline   0 Reply With Quote
Old Oct 28, 2010, 02:16 PM   #5
ulbador
macrumors 68000
 
ulbador's Avatar
 
Join Date: Feb 2010
Quote:
Originally Posted by yetanotheruser View Post
This thread is quite old, but I recently experienced the same problem with OS X 10.4.11 while trying to mount a NFS share on my DNS-323.

My solution was to mount with "-P" to force the use of a reserved port number, as described in mount_nfs(8) page. The command was

$> sudo mount_nfs -P <host>:<remote shared dir> <local mount point>

This solution probably addresses the secure/insecure port issue mentioned by hacksawSA, but I don't know enough to confirm that. It's also slightly less intrusive in that you don't have to modify /etc/exports.

-Ken
Direct from the man page:

This command is expected to be executed by the mount(8) command. Direct use of mount_nfs to mount NFS file systems is strongly discouraged because there is little practical benefit of using it
instead of mount(8).
ulbador is offline   0 Reply With Quote
Old Nov 27, 2011, 10:13 PM   #6
fishtoprecords
macrumors newbie
 
Join Date: Nov 2011
Quote:
Originally Posted by ulbador View Post
Direct use of mount_nfs to mount NFS file systems is strongly discouraged because there is little practical benefit of using it
instead of mount(8).
Which is cool, except that the mount(8) command does not have the -P switch.
Since I need the -P switch, now what?

Thanks
fishtoprecords is offline   0 Reply With Quote
Old Nov 27, 2011, 11:29 PM   #7
Red Menace
macrumors 6502
 
Join Date: May 2011
Location: Littleton, Colorado, USA
Now you read the manual pages - pay attention to the resvport option.
__________________
MacBook Pro / OS X Mavericks (10.9.4) / Xcode 5.1.1 / RubyMotion FTW
Red Menace is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Programming > Mac Programming

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Error 1 operation not permitted, terminal not working SuperHero87 OS X 4 May 20, 2014 02:04 AM
how to change NFS share name as displayed in OSX without reconfiguring NFS server? mrjayviper OS X Mavericks (10.9) 0 May 5, 2014 03:07 AM
Resolved: NSFileManager copyItemAtPath Operation not permitted Tex-Twil iPhone/iPad Programming 14 Sep 25, 2013 08:41 AM
Are animated GIFs permitted in ads? FloatingBones Site and Forum Feedback 6 May 21, 2013 06:04 PM
Networking Issue -- Outbound Connections Not Permitted NightStorm Mac OS X 10.7 Lion 1 Jul 2, 2012 09:40 AM

Forum Jump

All times are GMT -5. The time now is 04:48 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC