Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > PowerPC Macs

Reply
 
Thread Tools Search this Thread Display Modes
Old Jun 24, 2007, 07:25 AM   #1
MoscowErik
macrumors newbie
 
Join Date: Jun 2007
Powerbook G4 will not load - help!

So, I have read numerous times over about this problem. I have tried everything to fix it yet I cannot anymore. I am giving this problem to you guys to help. However, I think it may just be best to buy a new hard-drive.

So here is the problem:

I have noticed for the last few weeks that my Powerbook has been running very slow. And thus I decided to run a few tests. The tests came back negative from the disk utility on the mac (well they said they fixed the problem) however there was one glaring problem.

Under the S.M.A.R.T. Status it read - Failing.

The computer worked still at this point. Then I shut it off. Got the strange blinking globe which after 2.5 minutes went to the flashing mac finder folder for 2.5 minutes then the computer finally loaded. Still very slow.

Thus, I came online and read something about this problem. The recommended solution was to do a cmd 's' start. Then do a fsck -yf run. I did this - it turned up some errors but said it repaired the Macintosh HD volume.

So then the computer worked for about a week - still slow however.

Then here is where my real problems began. I got the internet which meant I would be running lots of files at once. Now the computer began to freeze then finally catch up and work again - this was happening constantly. So then I decided to give the computer a break. I turned it off for about 2 hours. Came back and then I got the ominous Grey Apple screen and the forever spinning loader.

So I went back and reset the PMU (thinking that it was a power management issue) then did a fsck -yf and then the computer worked again - but only for about 2 hours. Now we are at the point where I am at now.

The last errors I got were the following:

disk0s3: I/O error (3 times)
Overlapped extent allocation (file 54419d)
Jnl: do_jnl_io: strategy err 0x5
Jnl: replay_journal; could not read journal entry data @ offset 0x6b3a00!
Jnl: journal_open: error replaying the journal!
hfs: early jnl init: failed to open/create the journal (retval 0)

The computer at this point would still allow me to do the fsck -yf process.

Now the only thing that comes up when I do a cmd 's' launch is the following:

BSD root: disk0s3, major 14, minor 2
jnl: journal Start/end pointers reset! (jnl 0xld3fdc4; s 0x609400 e 0x6b3a00)

Then it does nothing. I cant even run a fsck -yf command or anything.

Does anyone have any idea what is wrong.

Is this something that I can fix myself or should I go to some sort of specialist. I am thinking of just upgrading to a 160GB hard drive which would likely solve all the problems and give me 100GB more!

But I would like to be able to save some of the documents on my computer, but it is not that vital.

Also - I am in Moscow and forgot to take with me the disks so I have no way of using any of the restore disks that came with the Mac.

Also - My computer is running OSX 10.3.9.

The thing that caused me to shut down the computer for the last time was that upon trying to load MSN Messenger (how ironic and typical) it got to the sign in screen and then just froze and would not respond to even a force quit (typical of microsoft).

So if someone could help me that would be great. Or do you think it would be too much of a hassle to fix and that I should just upgrade to the 160GB hard drive? Would this solve all my problems though?
MoscowErik is offline   0 Reply With Quote
Old Jun 24, 2007, 08:45 AM   #2
Killyp
macrumors 68040
 
Killyp's Avatar
 
Join Date: Jun 2006
Cool down your PowerBook (with some ice packs so it's VERY cold), take a disk image of the HDD, and then replace it. No point in repairing hard drives, you need a laboratory to do it...
Killyp is offline   0 Reply With Quote
Old Jun 24, 2007, 08:53 AM   #3
MoscowErik
Thread Starter
macrumors newbie
 
Join Date: Jun 2007
Interesting proposition.

Just one problem - I cant get on the computer to take an image of the HDD.

Perhaps - maybe tonight again, I will try my luck with a safe mode boot and maybe that will work.

Or I will try to zap the PRAM.

Who knows, I have an appointment tomorrow to get it fixed. I will probably just end up replacing the hard-drive for a bigger better one anyways.

Hitachi 160GB hard-drive here I come!
MoscowErik is offline   0 Reply With Quote
Old Jun 24, 2007, 03:07 PM   #4
MoscowErik
Thread Starter
macrumors newbie
 
Join Date: Jun 2007
Update

So now I can no longer do anything.

I try to run in single user mode:

Computer runs to the point of saying:

Jnl: Journal start/end pointers reset! (jnl 0x1d3fdc4; s 0x609400 e 0x6b3a00).

Then it stops working - I cant type anything or do anything with it.

I have tried to log using safe mode - not possible.

I do not have the disks so I cant boot from them.

I have done a PMU reset, zapped the PRAM & NVRAM, fsck -fy and nothing.

So now I think I will just have to replace the hard-drive. Is there any other option besides this? Also, I am not 100% certain that this will solve the problem also - will it?

Any help would be great.
MoscowErik is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > PowerPC Macs

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
pinwheeling under load jackotack OS X 3 Feb 27, 2013 08:31 PM
PowerBook G4 won't load CDs Daryl lee PowerPC Macs 1 Feb 2, 2013 05:05 PM
How do I load programs onto my PowerBook 520c? Ariii Apple Collectors 6 Dec 17, 2012 11:09 PM
Can't load iWork 09 paulsenglish Mac Applications and Mac App Store 11 Nov 1, 2012 06:50 PM
Can't load Youtube. Pikabuddy OS X 0 Sep 28, 2012 10:35 AM

Forum Jump

All times are GMT -5. The time now is 09:14 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC