Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone

Reply
 
Thread Tools Search this Thread Display Modes
Old Jun 26, 2007, 07:46 PM   #1
phototravel
macrumors newbie
 
Join Date: Oct 2006
iPhone and sending email on Port 25

Just read in a review online of the iPhone: "I had some problems with one of my accounts—sometimes the mail was blocked, other times it wouldn’t send outgoing mail. Apple looked into it and told me that it has something to do with my ISP blocking Port 25."
Cox is my ISP and it does block Port 25 - on Mac Mail, I use port 587. Does anyone know if the iPhone imports your Mac Mail settings, or is it stuck on Port 25? (making sending email via my ISP and iPhone impossible)...
phototravel is offline   0 Reply With Quote
Old Jun 26, 2007, 07:59 PM   #2
kdarling
macrumors Demi-God
 
kdarling's Avatar
 
Join Date: Jun 2007
Location: Device engineer 30+ yrs, touchscreens 23+.
http://www.postcastserver.com/help/P..._Blocking.aspx

Oops sorry. probably not what you need.
kdarling is offline   0 Reply With Quote
Old Jun 26, 2007, 07:59 PM   #3
SirOmega
macrumors 6502a
 
Join Date: Apr 2006
Thats a good point - with Cox and most other ISPs, you cant use their SMTP (outgoing) mail servers unless you're on their network (you have a Cox IP). Otherwise just anyone could open a connection to Cox's SMTP server and spam.

Hopefully we can ask for SMTP Auth enabled from the ISP's side to fix this. Its not an issue for me since I run my own SMTP server with SMTP auth enabled. And hopefully SMTP auth is a feature the iPhone supports.

(I have a Cox business acct so I can run whatever servers I like as long as its legal)
SirOmega is offline   0 Reply With Quote
Old Jun 26, 2007, 08:00 PM   #4
JNB
macrumors 604
 
JNB's Avatar
 
Join Date: Oct 2004
Location: In a Hell predominately of my own making
Send a message via Skype™ to JNB
The iPhone is supposed to import your accounts & settings, so I'd imagine that includes both POP & SMTP ports selected in Mail. I'm in the same boat - Cox blocks 25, so all of my accounts are on 587 or 995.
__________________

JNB is offline   0 Reply With Quote
Old Jun 26, 2007, 08:04 PM   #5
phototravel
Thread Starter
macrumors newbie
 
Join Date: Oct 2006
Quote:
Originally Posted by SirOmega View Post
Thats a good point - with Cox and most other ISPs, you cant use their SMTP (outgoing) mail servers unless you're on their network (you have a Cox IP). Otherwise just anyone could open a connection to Cox's SMTP server and spam.

Hopefully we can ask for SMTP Auth enabled from the ISP's side to fix this. Its not an issue for me since I run my own SMTP server with SMTP auth enabled. And hopefully SMTP auth is a feature the iPhone supports.

(I have a Cox business acct so I can run whatever servers I like as long as its legal)
Ahhh, but you did give me an idea...it just hit me that the email on Port 25 issue will only be an issue when I'm on wi-fi at my local coffee shop or at home, as that is the only time I'd be using Cox (monopoly on all ISP service here in New Orleans). All other outgoing email will be sent (slowly, apparently) through the EDGE network, so it won't be an issue, as I assume EDGE doesn't or can't block Port 25...correct?
phototravel is offline   0 Reply With Quote
Old Jun 26, 2007, 08:11 PM   #6
SirOmega
macrumors 6502a
 
Join Date: Apr 2006
Quote:
Originally Posted by phototravel View Post
Ahhh, but you did give me an idea...it just hit me that the email on Port 25 issue will only be an issue when I'm on wi-fi at my local coffee shop or at home, as that is the only time I'd be using Cox (monopoly on all ISP service here in New Orleans). All other outgoing email will be sent (slowly, apparently) through the EDGE network, so it won't be an issue, as I assume EDGE doesn't or can't block Port 25...correct?
Nope. In fact, the opposite.

When you're using a Cox internet service you should have access to their SMTP server. When you're not on Cox's internet service (starbucks WiFi, AT&T edge) you wont be able to send email through Cox's SMTP server. Like I said, I'd call cox and petition them to enable SMTP Auth on their SMTP servers so you can use it from the outside.
SirOmega is offline   0 Reply With Quote
Old Jun 26, 2007, 10:30 PM   #7
phototravel
Thread Starter
macrumors newbie
 
Join Date: Oct 2006
Quote:
Originally Posted by SirOmega View Post
Nope. In fact, the opposite.

When you're using a Cox internet service you should have access to their SMTP server. When you're not on Cox's internet service (starbucks WiFi, AT&T edge) you wont be able to send email through Cox's SMTP server. Like I said, I'd call cox and petition them to enable SMTP Auth on their SMTP servers so you can use it from the outside.
Actually, Starbuck's Wi fi is a different beast than ATT Edge - Starbucks USES Cox as their ISP, as does every single wi fi point - they all connect to the internet using Cox Service. ATT's EDGE would obviously be different. So the problem is that when I am using Cox (either at home or at Starbuck's) Cox blocks port 25, but ATT may not. Make sense?
phototravel is offline   0 Reply With Quote
Old Jun 27, 2007, 02:03 AM   #8
Deanster
macrumors regular
 
Join Date: Jun 2005
Hard to imagine that a device for use on all kinds of different networks wouldn't allow you to select alternate SMTP ports, since that completely stops you from sending in soooo many cases.

I'll add this to 'copy and paste' as things that I just can't believe they would have left out.
Deanster is offline   0 Reply With Quote
Old Jun 27, 2007, 03:53 AM   #9
SirOmega
macrumors 6502a
 
Join Date: Apr 2006
Quote:
Originally Posted by phototravel View Post
Actually, Starbuck's Wi fi is a different beast than ATT Edge - Starbucks USES Cox as their ISP, as does every single wi fi point - they all connect to the internet using Cox Service. ATT's EDGE would obviously be different. So the problem is that when I am using Cox (either at home or at Starbuck's) Cox blocks port 25, but ATT may not. Make sense?
No. Perhaps you dont get what blocking port 25 is. Its actually an unrelated issue.

Like I said above, you cant send outgoing mail through Cox's server outside of their network (AT&T's edge in this case).

Cox also blocks port 25 for residential customers (and port 80 as well IIRC) so you cant run your own SMTP server to work around that issue.
SirOmega is offline   0 Reply With Quote
Old Jul 2, 2007, 06:27 AM   #10
xserveG5.PB.G4
macrumors newbie
 
Join Date: Dec 2006
Location: Doylestown, PA
Angry Possible NOT Likely AT&T Blocking Port 25 when using Edge

I called Apple last night about the inability to send email from my iPhone and I got two different answers on two calls: 1) it's AT&T's fault and 2) many people have complained about it and an software update will be issued in a few hours - never happened.

I doubt it's a port issue, since we run our own server and don't block 25 and allow other ports to open if I'm someplace that does block port 25, which I haven't been. I've been using our own WIFI network to attempt to send email.

However, it may be possible (incredibly stupid) that AT&T blocks port 25. But that shouldn't make a difference when sending from WIFI rather than Edge since you're not using AT&T's network.

The only work around so far is to sync my iPhone with my MacBookPro and send from there.

I have noticed that the iPhone loses my outgoing password (doesn't save it), but that wouldn't explain why .mac email doesn't work.

:mad
xserveG5.PB.G4 is offline   0 Reply With Quote
Old Jul 2, 2007, 06:41 PM   #11
jhawley
macrumors newbie
 
Join Date: Jul 2007
Got iPhone working with Groupwise...

Howdy - not sure if this will help with your issue or if anyone caught this little workaround on Apple.com, but you can easily set the Port for the smtp on the iPhone.

Example: If you enter smtp.att.yahoo.com:587 then iPhone will use smtp.att.yahoo.com as your SMTP server with port number 587.

I successfully used this method to define a port for an outgoing Groupwise SMTP server.

Hope this helps!

http://docs.info.apple.com/article.html?artnum=305634
jhawley is offline   0 Reply With Quote
Old Jul 2, 2007, 07:45 PM   #12
traceyd
macrumors newbie
 
Join Date: Jul 2007
Angry Cox IPhone Outgoing Email

Just got off the phone with Cingular/ATT, at the store with Apple, and on the phone with Cox.

I was formerly a Cingular customer, so I knew using the 8525 (3G technology) that their outgoing SMTP was cwmx.com. When that didn't work I contacted them. Their response was that cwmx.com does not work with the EDGE technology, so therefore, you can NEVER send email using your COX account unless you go to webmail.cox.net and use EDGE or Wi-Fi.

Apple concurred and Cox walked me through trying smtp.cox.west.net:587 - which did not work.

So...bottom line... ATT/Cingular just went backwords in time by allowing the EDGE technology on the I-Phone.
traceyd is offline   0 Reply With Quote
Old Jul 3, 2007, 01:27 AM   #13
darthjulian
macrumors newbie
 
Join Date: Jul 2007
Port 25 and iPhone

Well, I guess it's AT&T. The only way I could send mail while on this EDGE network thing was to configure my SMTP server to spin an additional listener on an unused port and then configure my SMTP options to include that port, using the above described method of addr.host.tld:5353.

I mean, it's just sort of ridiculous. What are all those people with weird domains for their email going to do? Is this a widespread problem, or what?

Julian
darthjulian is offline   0 Reply With Quote
Old Jul 3, 2007, 03:34 PM   #14
Bunsen
macrumors member
 
Join Date: May 2007
Location: Orlando FL
AT&T does have an SMTP server for EDGE use

I found this online.
https://cingular.atgnow.com/cng/tutorials/KB72769.html

However it only works when you're on EDGE, not from WiFi (out of network)

It did seem to work with an address I was having trouble with.

ATT or Apple needs to create and Authenticated SMTP server for the iPhone/.Mac users that will let us send mail from anywhere!

Or, at least, we need an option in the iPhone to pick the appropriate SMTP server depending on where you are/how you're connected.
Bunsen is offline   0 Reply With Quote
Old Jul 5, 2007, 12:05 PM   #15
paymaster
macrumors newbie
 
Join Date: Apr 2006
Quote:
Originally Posted by Bunsen View Post
I found this online.
https://cingular.atgnow.com/cng/tutorials/KB72769.html

However it only works when you're on EDGE, not from WiFi (out of network)

It did seem to work with an address I was having trouble with.

ATT or Apple needs to create and Authenticated SMTP server for the iPhone/.Mac users that will let us send mail from anywhere!

Or, at least, we need an option in the iPhone to pick the appropriate SMTP server depending on where you are/how you're connected.
I discovered this today as well. I use Road Runner at home, and my work does to. Road Runner, like most ISP's I guess block email from off their network, and I can't authenticate either. So the bottom line is to either turn off wi-fi and always use edge when sending email, or to have to change the out going server settings every time you move from wi-fi to edge. I assume hotspots that are out there will also have their own settings. What a pain.
paymaster is offline   0 Reply With Quote
Old Dec 22, 2007, 03:27 AM   #16
senia
macrumors newbie
 
Join Date: Dec 2007
smtp.com

I solved this problem by getting an account from http://smtp.com. It costs a few bucks a month, but i've been using it not only from my iphone but also from my laptop, which used to often give me smtp trouble when i logged in from cafes or hotels.
senia is offline   0 Reply With Quote
Old Jan 3, 2008, 01:38 PM   #17
justben1369
macrumors newbie
 
Join Date: Nov 2007
WiFi

Thanks everyone. At least I am finally able to send email (even if it is only via the Edge network)

I'm just not smart enough to know.....how can you set it up to send via WiFi assuming you're happy to do the manual thing? Or is it a case of "depends which Wifi?" That is, if I'm at home on my comcast related wifi would it be the outgoing SMTP settings for Comcast etc?

Just curious. I'm sure I'm missing something
justben1369 is offline   0 Reply With Quote
Old Jan 3, 2008, 11:26 PM   #18
klimegreen
macrumors newbie
 
Join Date: Sep 2007
cox smtp

you can't relay (send) mail via SMTP on Cox if you aren't on their network. the iPhone will fail if trying from EDGE since this isn't on their net. perhaps authenticated send will work, but they may not allow this either.
klimegreen is offline   0 Reply With Quote
Old Jan 22, 2008, 07:04 AM   #19
alexrb
macrumors newbie
 
Join Date: Jan 2008
I'm using smtp.com for the outgoing, they offer multiple ports and if ISP has one of them closed it is always possible to switch to another port and send out well.
alexrb is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
thread Thread Starter Forum Replies Last Post
Sending Email Using Telnet - STARTTLS first rebello95 Mac Programming 5 Nov 7, 2011 05:52 PM
iPhone can't send emails on WiFi carlmattheis iPhone Tips, Help and Troubleshooting 0 Aug 14, 2009 11:50 AM
iPhone and Bellsouth Email on Wifi Macman756 iPhone Tips, Help and Troubleshooting 2 Jan 28, 2009 08:40 AM
Iphone won't send emails on MM? bigmat1201 iCloud and Apple Services 1 Oct 21, 2008 12:59 PM
iphone won't SEND email on mobileme accou wackymacky iPhone Tips, Help and Troubleshooting 2 Sep 2, 2008 07:12 AM


All times are GMT -5. The time now is 06:28 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC