Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Reply
 
Thread Tools Search this Thread Display Modes
Old Jul 9, 2007, 10:38 PM   #1
Khurram
macrumors 6502
 
Join Date: Aug 2006
Sound stopped working on iPhone!!

Something strange just happned to my iphone.

None of the phones sounds are coming thru the speaker!
The keyboard clicking sound is not working, the sleep button sound is not working, the music is not playing thru the speaker, nothing!
I tried doing a soft reset and it didn't do anything

Weird thing is, the sound is working thru the headphones! This sucks...hope someone has a quick fix for this , I really dont want to do a hard reset

Any suggestions?
Khurram
Khurram is offline   0 Reply With Quote
Old Jul 9, 2007, 10:42 PM   #2
Khurram
Thread Starter
macrumors 6502
 
Join Date: Aug 2006
And another thing I just noticed.
When I unplug my headphones , the ipod function starts up on it's own, but without any music or other sounds coming from the phone.

This happens even when the headphones are plugged in and not running the ipod. I just unplugged them to see if the sounds would work and it repeatedly starts the ipod function when I unplug my headphones?!
Khurram is offline   0 Reply With Quote
Old Jul 9, 2007, 11:05 PM   #3
ricksbrain
macrumors regular
 
Join Date: Aug 2005
Location: Miami, FL
Even after you reset it?
ricksbrain is offline   0 Reply With Quote
Old Jul 9, 2007, 11:07 PM   #4
Andrmgic
macrumors 6502a
 
Join Date: Jun 2007
Quote:
Originally Posted by Khurram View Post
Something strange just happned to my iphone.

None of the phones sounds are coming thru the speaker!
The keyboard clicking sound is not working, the sleep button sound is not working, the music is not playing thru the speaker, nothing!
I tried doing a soft reset and it didn't do anything

Weird thing is, the sound is working thru the headphones! This sucks...hope someone has a quick fix for this , I really dont want to do a hard reset

Any suggestions?
Khurram
Check your silent mode switch? It affects everything, not just the ringer.
Andrmgic is offline   0 Reply With Quote
Old Jul 9, 2007, 11:18 PM   #5
Khurram
Thread Starter
macrumors 6502
 
Join Date: Aug 2006
Quote:
Originally Posted by Andrmgic View Post
Check your silent mode switch? It affects everything, not just the ringer.

The silent button is not on.

I did not do a restore thru itunes but I did do a soft reset by holding down the home key and the power button.

The sound just came back a minute ago, but then it went again.

It just came back and again, and now it's gone again.
This sucks...gonna have to go to the apple store tomorrow I suppose.
Do you think I should do a factory restore?
Will that erase all my itunes data on my iphone if I do that?
Khurram is offline   -1 Reply With Quote
Old Jul 9, 2007, 11:35 PM   #6
hexonxonx
Banned
 
Join Date: Jul 2007
Location: Denver Colorado
Yes, everything will be erased but that may just work at restting the sound so it works.
hexonxonx is offline   0 Reply With Quote
Old Jul 10, 2007, 12:45 AM   #7
dwsolberg
macrumors 6502
 
Join Date: Dec 2003
Location: Mineapolis, MN
Weird. I just had it happen, too.

Weird. Just after I read this, the same thing happened to me. I tried putting the phone to sleep, then waking it up. That did not work. Then I called myself from the landline, and the iPhone did not make a ringing noise and I did not answer the iPhone. After that it made the clicking sound as it went to sleep. So far, the sound's been working after that, but I guess it could stop working again.

It seems there's a bug in the software. Let me know if the sequence that worked for me works for you.

Also, does anyone know where to log iPhone bugs with Apple?
dwsolberg is offline   0 Reply With Quote
Old Jul 10, 2007, 08:45 AM   #8
Khurram
Thread Starter
macrumors 6502
 
Join Date: Aug 2006
Quote:
Originally Posted by dwsolberg View Post
Weird. Just after I read this, the same thing happened to me. I tried putting the phone to sleep, then waking it up. That did not work. Then I called myself from the landline, and the iPhone did not make a ringing noise and I did not answer the iPhone. After that it made the clicking sound as it went to sleep. So far, the sound's been working after that, but I guess it could stop working again.

It seems there's a bug in the software. Let me know if the sequence that worked for me works for you.

Also, does anyone know where to log iPhone bugs with Apple?

Mine started working again on it's own after messing around with it.
I dont know exactly what sequence I used to get the sound back, but if it happens again i'll be sure to post.
It's def a software bug
Khurram is offline   0 Reply With Quote
Old Jul 10, 2007, 03:23 PM   #9
Khurram
Thread Starter
macrumors 6502
 
Join Date: Aug 2006
Sound is still coming and going at random.

Once it goes, i can't figure out how to get it back other than to wait it out..
I'm gonna do a hard restart or reinstall whatever it is thru itunes and see if that fixes it.
otherwise i'm gonna make an appointment at the genius bar.
Khurram is offline   0 Reply With Quote
Old Jul 10, 2007, 09:21 PM   #10
lilnyc
macrumors 6502a
 
Join Date: Jun 2007
Quote:
Originally Posted by Khurram View Post
Sound is still coming and going at random.

Once it goes, i can't figure out how to get it back other than to wait it out..
I'm gonna do a hard restart or reinstall whatever it is thru itunes and see if that fixes it.
otherwise i'm gonna make an appointment at the genius bar.
Your iPhone is backed up via iTunes each time you sync it. I found that out at the Apple store after giving the okay for them to restore it to factory condition to solve a crashing issue. We were all relieved when they plugged it into my computer and iTunes popped up a backup restore option. Your minor settings (wallpaper, configurations, etc) will not be saved.

Sidenote -- my iPod Nano did this sometimes. The sound didn't play and/or the songs would continuously forward themselves. I did a hard reset and resolved the problem.

But a Nano is cheaper than an iPhone. Please take it to Apple.
lilnyc is offline   0 Reply With Quote
Old Jul 10, 2007, 09:30 PM   #11
desenso
macrumors 6502a
 
desenso's Avatar
 
Join Date: May 2005
Mine did this once... when i sync'd it, iTunes asked for permission to send a bug report.

Hasn't happened since...
desenso is offline   0 Reply With Quote
Old Jul 10, 2007, 09:43 PM   #12
macbook123
macrumors 68000
 
Join Date: Feb 2006
I had it happen today too.

Other annoying thing: the iPod came on once after I ended a call - although I had never switched the iPod on!
macbook123 is offline   0 Reply With Quote
Old Jul 11, 2007, 10:32 PM   #13
marshalljones
macrumors newbie
 
Join Date: Feb 2006
Possible Sound Problem Fix

I had a similar (if not the same) problem with my iPhone's sound. I could hear people when on speaker and with the headphones, but not when my ear was to the phone. It was infuriating me ... this is my second iPhone. I use the iPod section of the phone quite a bit so I clicked on iPod and noticed that, although I turned the sound all the way up using the volume switch on the side, the volume on the iPod was turned all the way down. As soon as I turned it back up (using the touch screen) I could use my phone without a problem.

I really hope this helps anyone else who runs into this problem.
marshalljones is offline   0 Reply With Quote
Old Jul 11, 2007, 11:26 PM   #14
longofest
Editor emeritus
 
longofest's Avatar
 
Join Date: Jul 2003
Location: Falls Church, VA
Send a message via AIM to longofest
There is clearly a bug with the sound settings in the iPhone. I also had a similar problem happen to me today. The only way I could get it to resolve itself was to plug the headphones in, and then unplug them (thinking that the iPhone might have not recognized that the headphones were not there).

I'm going to mark this as a confirmed bug in our bug tracking thread.
longofest is offline   0 Reply With Quote
Old Jul 12, 2007, 10:37 AM   #15
daveo123
macrumors newbie
 
Join Date: Jan 2005
Location: San Diego, CA
Same thing here....

Sound was working no problem until I plugged in the headphones. Wasn't playing anything out of the external speaker until I plugged in and unplugged the headphones again. Like it didn't recognize that I unplugged them the first time.

But when it did recognize it, it paused the song I was playing just like when you pull the head phones out of an iPod.
daveo123 is offline   0 Reply With Quote
Old Jul 15, 2007, 07:04 PM   #16
mgrogan
macrumors newbie
 
Join Date: Jul 2007
Hold the Phone

in the upper left above the volume control buttons, there is a slider that will toggle sound off and on. give that a try.
mgrogan is offline   0 Reply With Quote
Old Jul 16, 2007, 10:06 AM   #17
Arbitrary
macrumors newbie
 
Join Date: Jul 2007
I had this same issue where I was getting no speaker sound when watching YouTube videos or playing music. I went into my settings and changed my ringtone and that played fine through my speakers. Audio from videos and songs still did not work. I then tried plugging in my earphones and unplugging them and my sound returned. It's definitely a bug related to the switching of sound when plugging and unplugging the headset.

Quote:
Originally Posted by longofest View Post
There is clearly a bug with the sound settings in the iPhone. I also had a similar problem happen to me today. The only way I could get it to resolve itself was to plug the headphones in, and then unplug them (thinking that the iPhone might have not recognized that the headphones were not there).

I'm going to mark this as a confirmed bug in our bug tracking thread.
Arbitrary is offline   0 Reply With Quote
Old Jul 16, 2007, 12:13 PM   #18
kqwik78
macrumors member
 
Join Date: Jun 2007
Location: Fresno, CA
Man, i thought i was the only one. I just happened to me this morning. I can hear my ringtones and all just fine, but inorder for me to talk to someone i have to use the speakerphone.

My music/videos do not play sound through the speaker. I made an appointment with a Genius today and hopefully they can fix it. It's past the 2 week mark so will they have to send it back or can they do a replacement for me there?

I was thinking that I just may need a restore, but I'm currently at work so I can't do that at the moment. They can do a restore at the Apple store right?
kqwik78 is offline   0 Reply With Quote
Old Jul 17, 2007, 05:52 PM   #19
yoman
macrumors 6502a
 
yoman's Avatar
 
Join Date: Nov 2003
Location: In the Bowels of the Cosmos
I had the same problem and the sound ended up working after I turned off my WiFi then plugged and unplugged the headphones.
__________________
My first computer was an Apple IIGS at the meager age of 6 1/2 years.
I was raised with an APPLE and I will die with an APPLE.
yoman is offline   0 Reply With Quote
Old Jul 27, 2007, 03:49 PM   #20
Chooser
macrumors newbie
 
Join Date: Nov 2003
I just got my iPhone yesterday and the earpiece speaker has been on and off. I've been trying to recreate the problem with no success. It seems completely random when the earpiece speaker wants to quit. At one point it stopped working in the middle of a call. Everything else (headphones and speaker) work just fine.

Did restarts and a restore and didn't really notice a change for the better or for the worse.

The one thing I am noticing is that the amount of time it does work is becoming longer.
Chooser is offline   0 Reply With Quote
Old Jul 27, 2007, 06:20 PM   #21
oogje
macrumors regular
 
Join Date: Jun 2002
Location: nyc
Same symptoms (I believe as OP). No sound out of the speakers - iPod, rings, ring tones in setttings, dialing, speaker phone, etc. Can hear callers with the phone to my ear and earphones work with all sounds. Went through the whole routine with Apple iPhone Support - Ring/Silent switch, volume settings, power cycle, reset, full restore. No go. Additionally I plugged/unplugged the headphones a dozen times to no avail.

Support offered to send me a free loaner while I send mine in or I could trot it over to the Apple Store. I chose a 10:05pm EDT appointment at the store. Will update.

ETA: Not much to report. The Apple Store ran through the same procedures as the phone support had me do with the same results. I was handed a free loaner and my phone will repaired or replaced and mailed back to me.

August 1st update. Fedex delivered my phone this afternoon. It included a letter stating:

...
The reported symptom(s) that is not reproducible:
774/Cannot Hear Incoming Caller
...

Well, that wasn't the problem. The Genius Bar Work Authorization states:

Problem Description/Diagnosis
ISSUE: Speakers not working. Restored. Same issue.
POSSIBLE LIQUID DAMAGE (Y/N): No
STEPS TO REPRODUCE: Attempt to use iPod/speaker phone etc

And yes, the sound through the speakers still doesn't work. I'll take it over to the Apple Store today. I wanted to go there anyway to buy more stuff despite the little snafu.

Last edited by oogje; Aug 2, 2007 at 02:31 PM. Reason: update
oogje is offline   0 Reply With Quote
Old Sep 22, 2007, 04:38 PM   #22
desertmonkey
macrumors newbie
 
Join Date: Aug 2007
try toggling the speaker phone setting

Quote:
Originally Posted by Khurram View Post
Something strange just happned to my iphone.

None of the phones sounds are coming thru the speaker!
The keyboard clicking sound is not working, the sleep button sound is not working, the music is not playing thru the speaker, nothing!
I tried doing a soft reset and it didn't do anything

Weird thing is, the sound is working thru the headphones! This sucks...hope someone has a quick fix for this , I really dont want to do a hard reset

Any suggestions?
Khurram
I had this same issue this morning, after 2 months of relatively trouble free use. Talk about frustrating! No audio unless I had the headphones plugged in, so system sounds or anything, and making calls I could not hear the phone ring, the other person answer, and the other person could not hear me.

After ineffective resets, what ended up working for me was toggling the speaker phone setting -- turned speaker phone on, then off, now the phone works fine.
desertmonkey is offline   0 Reply With Quote
Old Sep 25, 2007, 06:07 AM   #23
MarkW19
macrumors 65816
 
Join Date: Sep 2002
Location: Surrey, UK
I've got the same problem as of today as well! I thought it was to do with the activation/unlock I did last night using the new iNdependance (I've been unlocked and activated using the OLD iNdependance with absolutely no issues for 2-3 weeks now!), but maybe not. I seem to lose sound when I put it on Silent, and then back on Ring. I can restart the phone and then it's ok....for a bit.

Hmmm...
MarkW19 is offline   0 Reply With Quote
Old Sep 25, 2007, 10:05 AM   #24
pilotError
macrumors 68020
 
pilotError's Avatar
 
Join Date: Apr 2006
Location: Long Island
Quote:
Originally Posted by Khurram View Post
Something strange just happned to my iphone.

None of the phones sounds are coming thru the speaker!
The keyboard clicking sound is not working, the sleep button sound is not working, the music is not playing thru the speaker, nothing!
I tried doing a soft reset and it didn't do anything

Weird thing is, the sound is working thru the headphones! This sucks...hope someone has a quick fix for this , I really dont want to do a hard reset

Any suggestions?
Khurram
I had the same issue the other day. I don't often use the headphones, but that day I did.

There must be some sort of mechanical switch that gets stuck when you pull the headphones out (not sure if its a dirt issue or what).

I had to insert/remove the headphones a few times, then I got it to work again.

I had it once or twice now, not sure whats going on there. Really pissed me off, as I missed an important phone call.

Mike...
pilotError is offline   0 Reply With Quote
Old Sep 27, 2007, 07:14 AM   #25
leonowski
macrumors newbie
 
Join Date: Sep 2007
Quote:
Originally Posted by pilotError View Post
I had the same issue the other day. I don't often use the headphones, but that day I did.

There must be some sort of mechanical switch that gets stuck when you pull the headphones out (not sure if its a dirt issue or what).

I had to insert/remove the headphones a few times, then I got it to work again.

I had it once or twice now, not sure whats going on there. Really pissed me off, as I missed an important phone call.

Mike...
Hi All,

I just experienced this problem and found this forum while doing a Google search.

The problem happened to me when I quickly pulled out my car's tape adapter headphone plug from the iPhone jack. I had it connected using a Belkin iPhone adapter (I hate the darn recessed headphone jack!). I also had music playing at the time. This was the first time that I had pulled the plug while listening to music. That may have caused the problem as I noticed the same symptoms you all listed above while using my iPhone later that night:

- I had no keyboard clicks
- No sounds from itunes, browser, or youtube
- Strangely, my ringtone still worked.
- When I plugged in the mini headphones that came with the iPhone, iTunes would start up. This would happen no matter what application I was in.

I tried a hard and soft re-start. I tried to force close the music player Nothing seemed to work. I then tried a headphone plug that didn't work with the iPhone due to the recessed jack (unless I put some pressure on the plug into jack) while music was playing. That seemed to do the trick as my sound did return.

So, it seems like there is a combination hardware and software problem going on here. There seems to be some sort of headphone plug-in/unplug detection code that disables and re-enables the speakers. Unfortunately, it looks like there is a bug in the code that gets the iphone in a state where it never plays from the speakers again until you mess around with the headphone jack. Ugh
leonowski is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iPhone 5 sound stopped working and now turning itself off Mkz iPhone Tips, Help and Troubleshooting 1 Aug 25, 2014 02:15 AM
Sound Stopped Working On My iPhone 5 mojo pin iPhone 7 Dec 2, 2013 12:14 PM
my sound stopped working? raubrey133 MacBook Pro 0 Apr 14, 2013 12:31 PM
iPhone 5 sound stopped working iceandlime iPhone Tips, Help and Troubleshooting 1 Mar 10, 2013 05:03 PM
Sound Stopped Working? bertie343 MacBook Pro 1 Oct 7, 2012 07:31 PM

Forum Jump

All times are GMT -5. The time now is 06:08 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC