Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone

Reply
 
Thread Tools Search this Thread Display Modes
Old Jul 19, 2007, 01:27 PM   #1
dzoolander
macrumors newbie
 
Join Date: May 2007
*67 problem with iphone

I have also noticed a problem with the iphone. As a physician I receive my pages from the answering service via text message. Hoeverver, on my previous phone I had asked the answering service to add *67 in front of the number so when I called the patient they could not see my number. However, with the iphone the *67 is in front of the patient's number but is not highlighted blue or underlined in the text message. Hence the number is not blocked. Any help would be of assistance. i do not want to block my caller id under settings each time as this is inefficient and time consuming.
dzoolander is offline   0 Reply With Quote
Old Jul 19, 2007, 01:30 PM   #2
Twinkie
macrumors regular
 
Join Date: Feb 2005
Location: Milford, MI
Send a message via AIM to Twinkie Send a message via Yahoo to Twinkie
You can have AT&T add a perpetual Caller ID block to your account, at no charge.
Twinkie is offline   0 Reply With Quote
Old Jul 19, 2007, 02:02 PM   #3
vansouza
macrumors Demi-God
 
vansouza's Avatar
 
Join Date: Mar 2006
Location: West Plains, MO USA Earth
Send a message via Yahoo to vansouza
or go into Settings

I believe you can block the caller ID in settings.
__________________
You don't have a soul. You are a soul. You have a body. C. S. Lewis
2013 iMac & MBPR
vansouza is offline   0 Reply With Quote
Old Jul 19, 2007, 02:17 PM   #4
beate
macrumors regular
 
Join Date: Jun 2007
I've heard that if you block caller ID and call another AT&T cell customer it will not show as M2M calling. Hence, you'd be using "anytime minutes".

Anyone that does a lot of M2M calling and thinking of going the blocking route ahould talk to AT&T first lest you get a big surprise on your bill.
beate is offline   0 Reply With Quote
Old Jul 19, 2007, 02:22 PM   #5
Peace
macrumors P6
 
Join Date: Apr 2005
Location: Space--The ONLY Frontier
Doctors shouldn't block their numbers from patients..

Just my personal pet peeve after dealing with 10-12 specialist over the past 10 years.
Peace is offline   -1 Reply With Quote
Old Jul 19, 2007, 02:30 PM   #6
ivanmc
macrumors newbie
 
Join Date: Jul 2007
Peace, I suppose you'd like people calling your home at all hours of the day, and on your day off? Thank goodness for blocked numbers.

I can't believe how many people call in the middle of the night because they have insomnia

I think you should post your phone number just to see what it is like
ivanmc is offline   0 Reply With Quote
Old Jul 19, 2007, 02:30 PM   #7
dr_lha
macrumors 68000
 
Join Date: Oct 2003
Quote:
Originally Posted by Peace View Post
Doctors shouldn't block their numbers from patients..

Just my personal pet peeve after dealing with 10-12 specialist over the past 10 years.
Doctors need to be able to be free from their hypochondriac patients sometimes you know.
__________________
Me: 1Ghz 12" PB and Mac mini Intel Core Solo 1.5Ghz, The Wife: 1.86Ghz CD MacBook, Me@Work: 2.66Ghz Mac Pro and a 2.33Ghz C2D 15" Mac Book Pro
dr_lha is offline   0 Reply With Quote
Old Jul 19, 2007, 02:41 PM   #8
Peace
macrumors P6
 
Join Date: Apr 2005
Location: Space--The ONLY Frontier
Don't wish to hijack the thread.
Just a personal thing.


carry on !!
Peace is offline   0 Reply With Quote
Old Jul 19, 2007, 02:50 PM   #9
nbs2
macrumors 68030
 
nbs2's Avatar
 
Join Date: Mar 2004
Location: A geographical oddity
Quote:
Originally Posted by dzoolander View Post
I have also noticed a problem with the iphone. As a physician I receive my pages from the answering service via text message. Hoeverver, on my previous phone I had asked the answering service to add *67 in front of the number so when I called the patient they could not see my number. However, with the iphone the *67 is in front of the patient's number but is not highlighted blue or underlined in the text message. Hence the number is not blocked. Any help would be of assistance. i do not want to block my caller id under settings each time as this is inefficient and time consuming.
Quote:
Originally Posted by vansouza View Post
I believe you can block the caller ID in settings.
Great idea.

Quote:
Originally Posted by Twinkie View Post
You can have AT&T add a perpetual Caller ID block to your account, at no charge.
I think that you may want to raise this issue to both Apple and ATT, since I 'm not sure who is running the texting show. In the mean time, twinkie's advice may be the best solution. It'll be irritating for everybody else, but at least you'll keep your sanity...

Continuing the off-topicness - Peace, I agree with you that when you are dealing with a specialist on a regular basis, it would be nice to have them not block their numbers. But, for GPs and for the specialist that you are seeing for a small issue, they should have to risk someone soliciting free advice. In the end I'd hope that the established relationship would, at some point, would involve an exchange of numbers - if you have a long-term relationship, I doubt that mundane calls will be made.
nbs2 is offline   0 Reply With Quote
Old Jul 19, 2007, 03:12 PM   #10
rdowns
macrumors Penryn
 
rdowns's Avatar
 
Join Date: Jul 2003
What's wrong with

Settings ->Phone ->Show My Caller ID ->Off
rdowns is offline   0 Reply With Quote
Old Jul 19, 2007, 03:17 PM   #11
junebug1
macrumors regular
 
Join Date: Jan 2007
You can also use #31# to block your number. Might work.
junebug1 is offline   0 Reply With Quote
Old Jul 19, 2007, 04:31 PM   #12
dzoolander
Thread Starter
macrumors newbie
 
Join Date: May 2007
My whole point was not to block my number in settings, but rather have the *67 preface come before the outgoing number. Somehow the iphone is not recognizing the *67 as part of the number.
As an aside, doctors do block their numbers. If we didn't we would be innundated with calls at all times during the day ( and night)
dzoolander is offline   0 Reply With Quote
Old Jul 19, 2007, 07:07 PM   #13
Krevnik
macrumors 68020
 
Krevnik's Avatar
 
Join Date: Sep 2003
Quote:
Originally Posted by junebug1 View Post
You can also use #31# to block your number. Might work.
Nope, it is a 'bug' of sorts with the iPhone's parser that turns strings into clickable links for phone numbers.
__________________
iMac 2013 27", 13" rMBP, iPad 4, iPhone 5s
Krevnik is offline   0 Reply With Quote
Old Jul 20, 2007, 07:56 PM   #14
NavyWings
macrumors newbie
 
Join Date: Dec 2006
*67 issue

I tried *67 and it worked fine. IPhone was set to show ID. My issue is displaying my ID on a per call basis when iPhone is set to block its ID. If I use *82 in front of the number and the iPhone is set to block ID, my call still goes out as a restricted number. This kind of refutes the claim that it's a character conversion issue in the iPhone. My guess is the general setting overrides the individual call setting.
NavyWings is offline   0 Reply With Quote
Old Jul 20, 2007, 09:48 PM   #15
joejoejoe
macrumors 65816
 
Join Date: Sep 2006
Sounds like the only option you have is to remember the number you read in the text, go to the phone app and manually dial the number, but add *67 to the beginning of the number when you manually enter it in.
joejoejoe is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iPhone 5 Problem krixtian iPhone 1 Jul 7, 2013 10:33 AM
iPhone problem help! lucyp30 iPhone Tips, Help and Troubleshooting 2 May 18, 2013 09:18 PM
iPhone 5 Problem (Please Help) thatguy35 iPhone Tips, Help and Troubleshooting 0 Apr 16, 2013 07:57 PM
iPhone 3GS problems - there is a problem with your iPhone Mat246 iPhone 17 Mar 13, 2013 04:14 AM

Forum Jump

All times are GMT -5. The time now is 01:55 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC