Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Reply
 
Thread Tools Search this Thread Display Modes
Old Aug 5, 2007, 12:36 PM   #1
permie
macrumors newbie
 
Join Date: Jul 2007
Help sending e-mail thru comcast????

Been having problems the last few days sending/forwarding e-mails. Keep getting "connection to the outgoing server smtp.comcast.net failed".

Have reset the phone and tried everything else I can think of and still no success. Anyone have a solution???
permie is offline   0 Reply With Quote
Old Aug 5, 2007, 01:03 PM   #2
Macxor
macrumors newbie
 
Join Date: Jul 2007
If you go into your mail settings and change the outgoing SMTP mail server to cwmx.com your comcast mail will send. Once you attach to your home WIFI you will need to change it back to smtp.comcast.net.

This seems to be the common workaround used by other Comcast subscribers.
Macxor is offline   0 Reply With Quote
Old Aug 5, 2007, 01:09 PM   #3
richsim
macrumors newbie
 
Join Date: Jun 2007
The problem with cwmx.com is that it doesn't work when you're using WiFi.

A better solution is to use a different mail port, one that Comcast will accept. Comcast blocks the standard port 25 when you're sending mail from outside their system. I found that port 465 works for my Comcast account. (Don't know if it matters, but I'm located in Massachusetts. Port 587 is one that people use with other providers, but it didn't work for me.)

To set it up, go to Settings/Mail on your iPhone, select your account, and scroll down to "Outgoing Mail Server (SMTP)". Then enter these settings:

Host Name:
smtp.comcast.net:465

User Name:
Your Comcast mail user name (without the @comcast.net)

Password:
Your Comcast mail password

Under the advanced tab:
Outgoing Uses SSL is ON
Authentication is set to Password
richsim is offline   1 Reply With Quote
Old Aug 8, 2007, 06:28 PM   #4
docpjk
macrumors newbie
 
Join Date: Jun 2007
Talking

Quote:
Originally Posted by richsim View Post
The problem with cwmx.com is that it doesn't work when you're using WiFi.

A better solution is to use a different mail port, one that Comcast will accept. Comcast blocks the standard port 25 when you're sending mail from outside their system. I found that port 465 works for my Comcast account. (Don't know if it matters, but I'm located in Massachusetts. Port 587 is one that people use with other providers, but it didn't work for me.)

To set it up, go to Settings/Mail on your iPhone, select your account, and scroll down to "Outgoing Mail Server (SMTP)". Then enter these settings:

Host Name:
smtp.comcast.net:465

User Name:
Your Comcast mail user name (without the @comcast.net)

Password:
Your Comcast mail password

Under the advanced tab:
Outgoing Uses SSL is ON
Authentication is set to Password

Wow! thanks for solving a big problem for me!!!!!!!!!!!!!!!!!!!!!
docpjk is offline   0 Reply With Quote
Old Feb 27, 2011, 01:30 AM   #5
JamieK
macrumors newbie
 
Join Date: Feb 2011
Smile Oh thank God you guys are brill

I have spent the past two hours trying to fix my parents email ... they use Comcast. After desperation set in, I checked this site and found your collective advice and it worked. I feel like the weight of the world has been lifted off of my shoulders. And I will look like a genius to my 70-year-old parents! Bless you all!
JamieK is offline   0 Reply With Quote
Old Oct 28, 2013, 08:45 PM   #6
pradcliffe
macrumors newbie
 
Join Date: Oct 2013
Smile Thank You!!

Quote:
Originally Posted by richsim View Post
The problem with cwmx.com is that it doesn't work when you're using WiFi.

A better solution is to use a different mail port, one that Comcast will accept. Comcast blocks the standard port 25 when you're sending mail from outside their system. I found that port 465 works for my Comcast account. (Don't know if it matters, but I'm located in Massachusetts. Port 587 is one that people use with other providers, but it didn't work for me.)

To set it up, go to Settings/Mail on your iPhone, select your account, and scroll down to "Outgoing Mail Server (SMTP)". Then enter these settings:

Host Name:
smtp.comcast.net:465

User Name:
Your Comcast mail user name (without the @comcast.net)

Password:
Your Comcast mail password

Under the advanced tab:
Outgoing Uses SSL is ON
Authentication is set to Password
OMG. I was afraid to do this as I'm very technically challenged but I bit the bullet and made the changes you suggested. Worked like a charm. Thank you!
pradcliffe is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Default Mail App - Yahoo! no longer sending mail a.jfred iPhone and iPod touch Apps 2 Dec 17, 2013 10:54 AM
Mail Program Needed: treat Comcast like imap VideoBeagle Mac Applications and Mac App Store 10 May 8, 2013 02:45 AM
Resolved: e Mail Not Sending chattahoochee MacBook 0 Feb 8, 2013 04:42 PM
Mail app sending mail from diff accounts. Please help. SammyDFG Mac Applications and Mac App Store 9 Jan 13, 2013 08:51 PM
Problems sending emails from iPhone 4 via comcast Wellspolypro iPhone Tips, Help and Troubleshooting 0 Aug 21, 2012 08:01 PM

Forum Jump

All times are GMT -5. The time now is 05:26 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC