Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Reply
 
Thread Tools Search this Thread Display Modes
Old Sep 9, 2007, 09:24 PM   #1
Rus Shackleford
macrumors regular
 
Join Date: Oct 2003
Location: NC, US
stopping iPhone from getting old gmail messages?

Hey there...i had this corrected before it had to re-set my iphone today...I have the mail settings on the iphone to show 25 recent messages. When i delete some, it keeps going back to my gmail account and loading the next oldest mails. I'd like to be able to delete messages and then have the iphone only get new ones? What setting am i missing?
Rus Shackleford is offline   0 Reply With Quote
Old Sep 10, 2007, 03:25 PM   #2
martinmartin
macrumors 6502
 
Join Date: Jun 2007
Quote:
Originally Posted by Rus Shackleford View Post
Hey there...i had this corrected before it had to re-set my iphone today...I have the mail settings on the iphone to show 25 recent messages. When i delete some, it keeps going back to my gmail account and loading the next oldest mails. I'd like to be able to delete messages and then have the iphone only get new ones? What setting am i missing?
I would also like to know the answer to this.

Just bought the iphone today and everytime I delete gmail messages on the phone, it just goes and downloads 25 more...
martinmartin is offline   0 Reply With Quote
Old Sep 10, 2007, 03:46 PM   #3
Racktacular
macrumors regular
 
Join Date: Oct 2006
Me too. It constantly searches for e-mails even though I set the option to look for e-mail manually. Whenever I delete them it goes through the archived e-mails and brings them up. Pretty dumb if you ask me. Surely someone knows how to avoid this issue.
Racktacular is offline   0 Reply With Quote
Old Sep 10, 2007, 06:09 PM   #4
Racktacular
macrumors regular
 
Join Date: Oct 2006
:crickets:
Racktacular is offline   0 Reply With Quote
Old Sep 10, 2007, 06:21 PM   #5
Cashmonee
macrumors newbie
 
Join Date: May 2006
In the advanced settings for Gmail, you have to turn the Recent feature off. That worked for me.
Cashmonee is offline   0 Reply With Quote
Old Sep 10, 2007, 08:31 PM   #6
Racktacular
macrumors regular
 
Join Date: Oct 2006
Quote:
Originally Posted by Cashmonee View Post
In the advanced settings for Gmail, you have to turn the Recent feature off. That worked for me.
Hmmm, I tries that but all it seemed to do was bring up older e-mails.
Racktacular is offline   0 Reply With Quote
Old Sep 10, 2007, 10:58 PM   #7
Racktacular
macrumors regular
 
Join Date: Oct 2006
Since no one wants to reply. What I did to see if it would take of the issue (which it does) is set up a new yahoo account. Set GMail to forward all mail to the yahoo account. Set the iPhone to receive new email from the Yahoo account. And bingo, e-mail on your iPhone forwarded from GMail, read off of Yahoo without the iPhone continally searching for old mail.

Not sure why you have to go this route, but seems as though you do.
Racktacular is offline   0 Reply With Quote
Old Sep 11, 2007, 01:31 AM   #8
Ramsos
macrumors regular
 
Join Date: Nov 2002
Location: Oakland, California
I had a similar experience with my webmail form a website and I ha to delete over 500 emails from my iPhone because the server saves everything and I have no sever access.
__________________
Switcher since 2002 -12- Macs so far. 2013 MBPr 2.4 16GB 430GSSD & i5 Quad Thunderbolt iMac 27 + 27 inch TB Display.
Ramsos is offline   0 Reply With Quote
Old Sep 12, 2007, 09:28 AM   #9
breathmint
macrumors newbie
 
Join Date: Sep 2007
Location: thimble island
Solution!

I, too, was having this problem and think I finally found (a strange) solution!! It's sort of annoying but you'll only have to do it once to fix things.

First of all, make sure you have Recent Mode turned on. Now set your mail settings to 200 Most Recent. In your advanced settings make sure you have the "Delete Messages: Remove" setting to anything other than "Never"... I used "After One Day" (BE SURE NOT TO CHANGE THE "DELETE FROM SERVER" setting, though... otherwise you will lose your messages for real!!!).

When your Gmail updates it will only download the first 50 messages. Now delete them all (or at least whichever ones you don't want/need anymore. More than likely this will be enough for it to realize you don't want any more messages, or the recent setting somehow discriminates how old a message cna be to be sent to your iPhone, because once this happened I didn't get any more messages. In fact, there was a "Get 50 More Messages" button in my inbox, but clicking it didn't get me any more messages, it actually just caused that button to go away after a reboot!! If you find that more messages DO come in, just delete those too, you probably just have more "recent" messages than I did !!

I know this is a pain, but I am 90% sure it will work ! Now I only get new messages to my iPhone... In summary:

01)Settings>Mail>Gmail>Advanced>Deleted Messages: Remove After One Day
02)Settings>Mail>Gmail>Advanced>Delete From Server: Never
03)Settings>Mail>Gmail>Advanced>Use Recent Mode: On
04)Settings>Mail>Messages>Show: 200 Recent Messages
05)Mail>Gmail>Inbox... Update and download messages
06)Delete all the messages
07)If/when you see "Get More Messages..." click it
08)If more messages come delete them too
09)That should do it!!!


Please let me know if this works for everyone else too !!

--
breathmint
breathmint is offline   0 Reply With Quote
Old Sep 14, 2007, 12:43 PM   #10
turiya
macrumors newbie
 
Join Date: Sep 2007
I didn't see this thread right away, but I posted a thread that details my setup suggestions to prevent getting old mail.

From http://forums.macrumors.com/showthread.php?t=354934:

On GMail:
1. Log in via a web browser on your PC.
2. At the very top of the page, on the right hand side, click the "Settings" link.
3. Click "Forwarding and POP."
4. Under "POP Download," select "Enable POP only for mail that arrives from now on."
*** Note: If you've set up POP before, you may have an older date listed where it says "Status." If you're using POP with another client (on your PC, perhaps), this may break that functionality. However, if you only use POP on your iPhone, this will prevent the iPhone from downloading older mail.

Your mileage may vary.
turiya is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Geektool: Gmail new messages in inbox yetiboy UI Customization 0 May 14, 2014 11:04 AM
Mail Gmail Reappearing Messages designjohn OS X Mavericks (10.9) 29 Oct 30, 2013 11:12 PM
Using IOS Gmail app offline, old messages sTcA iPhone and iPod touch Apps 2 May 23, 2013 08:20 AM
I'm thinking about stopping paying for text messages... poblack iPhone Tips, Help and Troubleshooting 1 Oct 13, 2012 09:03 AM
GMail: confusion about Delete and Sent Messages Argelius Community Discussion 9 Jul 14, 2012 08:32 AM

Forum Jump

All times are GMT -5. The time now is 03:43 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC