Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Reply
 
Thread Tools Search this Thread Display Modes
Old Sep 21, 2007, 06:44 PM   #1
Kalinatek
macrumors regular
 
Join Date: Aug 2005
iPhone wont connect to home wi-fi anymore?

i have my iPhone for a week now, it used to connect fine to my home wifi connection but now it doesn't... it does connect quickly and all the settings are the same ( i didn't change anything) but when i open up Safari nothing loads and when i type an address it tells me Safari cant open the page because it could not connect to the server?


hope some1 helps me!

thanks in advance guys




PS: although the wireless signal is full in my iPhone, i dont have any IP address when i check the settings of my connection...all the fields are blank.
Kalinatek is offline   0 Reply With Quote
Old Sep 21, 2007, 06:47 PM   #2
D1G1T4L
macrumors 65816
 
D1G1T4L's Avatar
 
Join Date: Jun 2007
Location: Phoenix, AZ
Everything else connecting to the router accessing the net ok?
D1G1T4L is offline   0 Reply With Quote
Old Sep 21, 2007, 06:52 PM   #3
Kalinatek
Thread Starter
macrumors regular
 
Join Date: Aug 2005
yeah , if it helps i have a 2.0 '17' iMac and am using a Thomson Speedtouch modem (1MB DSL connection) & the net is 100% fine.

Kalinatek is offline   0 Reply With Quote
Old Sep 21, 2007, 06:52 PM   #4
alljunks
macrumors regular
 
Join Date: Apr 2007
it happens to me sometimes... click the Forget this Network and re-join the wireless
alljunks is offline   0 Reply With Quote
Old Sep 21, 2007, 06:55 PM   #5
D1G1T4L
macrumors 65816
 
D1G1T4L's Avatar
 
Join Date: Jun 2007
Location: Phoenix, AZ
Quote:
Originally Posted by Kalinatek View Post
yeah , if it helps i have a 2.0 '17' iMac and am using a Thomson Speedtouch modem (1MB DSL connection) & the net is 100% fine.

But that is wireless also? Give the suggestion given first and see how that works.
D1G1T4L is offline   0 Reply With Quote
Old Sep 21, 2007, 06:57 PM   #6
synth3tik
macrumors 68040
 
synth3tik's Avatar
 
Join Date: Oct 2006
Location: Minneapolis, MN
Send a message via AIM to synth3tik
I haven't had issues with the iPhone not connecting, but sometimes the iPhone accesses the wifi really slow.
synth3tik is offline   0 Reply With Quote
Old Sep 21, 2007, 06:57 PM   #7
Kalinatek
Thread Starter
macrumors regular
 
Join Date: Aug 2005
Quote:
Originally Posted by alljunks View Post
it happens to me sometimes... click the Forget this Network and re-join the wireless
did that , same thing... is it normal that the DHCP,BOOTP & STATIC are blank in my iPhone?
Kalinatek is offline   0 Reply With Quote
Old Sep 21, 2007, 06:58 PM   #8
Kalinatek
Thread Starter
macrumors regular
 
Join Date: Aug 2005
i entered the password again for my network and although that there is a tick next to its name , the edge sign is still up and hasn't been replaced with the blue wifi sign for some reason...
Kalinatek is offline   0 Reply With Quote
Old Sep 21, 2007, 07:02 PM   #9
lmcintyre
macrumors regular
 
Join Date: Jun 2006
I have the same problem only its only at my work. Wi-fi works great everywhere else just not at work. I figured I could just do a restore but i've been waiting for the new firmware to come out. I know as soon as I restore and put all of my suff on it an update will be released.
lmcintyre is offline   0 Reply With Quote
Old Sep 21, 2007, 07:03 PM   #10
Kalinatek
Thread Starter
macrumors regular
 
Join Date: Aug 2005
it's the other way round for me , its working fine in work.. but at home even if i sit an inch away from my wireless modem it will still not connect ...


Kalinatek is offline   0 Reply With Quote
Old Sep 21, 2007, 07:14 PM   #11
Gonzlobo
macrumors 6502
 
Join Date: May 2007
Location: Albuquerque
Mine does the same. I have to enter 'airplane mode', then exit. After that, it works fine.
__________________
GUN STORE GUY: 'There's a five day waiting period on the handgun.'
HOMER: 'Five days?' But I'm angry NOW!!!'
Gonzlobo is offline   0 Reply With Quote
Old Sep 21, 2007, 07:21 PM   #12
Avatar74
macrumors 65816
 
Avatar74's Avatar
 
Join Date: Feb 2007
Quote:
Originally Posted by Kalinatek View Post
i have my iPhone for a week now, it used to connect fine to my home wifi connection but now it doesn't... it does connect quickly and all the settings are the same ( i didn't change anything) but when i open up Safari nothing loads and when i type an address it tells me Safari cant open the page because it could not connect to the server?


hope some1 helps me!

thanks in advance guys




PS: although the wireless signal is full in my iPhone, i dont have any IP address when i check the settings of my connection...all the fields are blank.
If you're not pulling an IP, I would check to see if you have any security settings such as MAC (Machine Access Control) address authentication or WEP/WPA encryption. You can get a signal lock without actually authenticating and the inability to pull an IP address from the wireless router is a strong indication of this.
Avatar74 is offline   0 Reply With Quote
Old Sep 21, 2007, 08:07 PM   #13
jasonsmith
macrumors member
 
Join Date: Jul 2007
Reboot your router, and or modem.
jasonsmith is offline   0 Reply With Quote
Old Sep 22, 2007, 01:01 AM   #14
Kalinatek
Thread Starter
macrumors regular
 
Join Date: Aug 2005
Thx guys, i am just using a wireless modem i dont have a router, another thing i have a normal WEP password (10 digits - only numbers) if that helps. I have also just restarted the modem, went into Airplane modem than back to normal mode..same problem it doesn't connect

I even also did a Renew Lease on the iPhone and my iMac..
Kalinatek is offline   0 Reply With Quote
Old Sep 22, 2007, 07:48 AM   #15
Kalinatek
Thread Starter
macrumors regular
 
Join Date: Aug 2005
PROBLEM SOLVED!

i just went into settings then i restarted the network settings.everything went back to normal..i think this is a bug or maybe a firmware issue in the iPhone hmm...



Kalinatek is offline   0 Reply With Quote
Old Sep 23, 2007, 09:36 PM   #16
norton13
macrumors newbie
 
Join Date: Sep 2007
Quote:
Originally Posted by Kalinatek View Post
PROBLEM SOLVED!

i just went into settings then i restarted the network settings.everything went back to normal..i think this is a bug or maybe a firmware issue in the iPhone hmm...



Kalinatek , what exactly did you restart? I am having the exact same problem you are. Really Annoying. Can you help me?
norton13 is offline   0 Reply With Quote
Old Mar 19, 2008, 02:05 PM   #17
IphoneinElk
macrumors newbie
 
Join Date: Mar 2008
I know this is a very old thread, but...

Quote:
Originally Posted by norton13 View Post
Kalinatek , what exactly did you restart? I am having the exact same problem you are. Really Annoying. Can you help me?
If you searched on Google and this is what you came up with, (Like me) here is a step by step:

(iPhone main menu) Tap "Settings"

then tap "Reset" at the very bottom of the menu.

Then tap "Reset Network Settings" it will confirm then restart.

Praughbleghm Saughlved
IphoneinElk is offline   0 Reply With Quote
Old Jan 18, 2009, 12:41 PM   #18
Bebelier
macrumors newbie
 
Join Date: Oct 2007
Thumbs up Unlocked g3 - wi-fi

Quote:
Originally Posted by IphoneinElk View Post
If you searched on Google and this is what you came up with, (Like me) here is a step by step:

(iPhone main menu) Tap "Settings"

then tap "Reset" at the very bottom of the menu.

Then tap "Reset Network Settings" it will confirm then restart.

Praughbleghm Saughlved
Thanks this was really helpful.
Just if it helps I have an unlocked g3. - 2.2
Bebelier is offline   0 Reply With Quote
Old Sep 29, 2009, 09:32 AM   #19
bignold
macrumors newbie
 
Join Date: Sep 2009
Exclamation i need help

hey everyone i need help urgently!!!
my iphone 3Gs will not connect to my home wifi, about a week ago it just stopped. i can find the wifi account but when i put in the password it say unable to connect
its the right password i have put it in a hundred bloody times but still nothing
can anyone help me???
bignold is offline   0 Reply With Quote
Old Sep 29, 2009, 09:41 AM   #20
IBradMac
macrumors 68000
 
IBradMac's Avatar
 
Join Date: Jun 2008
Location: Ohio
Send a message via AIM to IBradMac
Quote:
Originally Posted by bignold View Post
hey everyone i need help urgently!!!
my iphone 3Gs will not connect to my home wifi, about a week ago it just stopped. i can find the wifi account but when i put in the password it say unable to connect
its the right password i have put it in a hundred bloody times but still nothing
can anyone help me???
3.0, 3.0.1, or 3.1?

3.0 and 3.0.1 is notorious for wifi connectivity issues. I had the same problem as you at one time or another.

A couple of things you can try ..

1.) Settings > Reset > Reset all Settings
2.) Hard reset by holding the both the home and power button down.
IBradMac is offline   0 Reply With Quote
Old Sep 30, 2009, 05:55 AM   #21
bignold
macrumors newbie
 
Join Date: Sep 2009
Quote:
Originally Posted by IBradMac View Post
3.0, 3.0.1, or 3.1?

3.0 and 3.0.1 is notorious for wifi connectivity issues. I had the same problem as you at one time or another.

A couple of things you can try ..

1.) Settings > Reset > Reset all Settings
2.) Hard reset by holding the both the home and power button down.
ok well i think its 3.0.1 and i cant reset all setting because i dont kno the code coz i got the iphone from my cousin
bignold is offline   0 Reply With Quote
Old Sep 30, 2009, 10:39 AM   #22
bignold
macrumors newbie
 
Join Date: Sep 2009
Question

its actually 3.1 and i think my **** head of a brother blocked it from the internet how do i unblock it???
bignold is offline   0 Reply With Quote
Old Nov 6, 2009, 06:36 AM   #23
seethingsclear
macrumors newbie
 
Join Date: Nov 2009
simple solution

Quote:
Originally Posted by Kalinatek View Post
i have my iPhone for a week now, it used to connect fine to my home wifi connection but now it doesn't... it does connect quickly and all the settings are the same ( i didn't change anything) but when i open up Safari nothing loads and when i type an address it tells me Safari cant open the page because it could not connect to the server?


hope some1 helps me!

thanks in advance guys




PS: although the wireless signal is full in my iPhone, i dont have any IP address when i check the settings of my connection...all the fields are blank.
Simply go to Network preferrences on your computer and click advanced and then where it says preferred networks click the little pencil icon and re enter the network your I phone connects where it asks you to add the new prefferred net work - even if you can see the network already in preferred networks add it again- no matter what you do to your iphone it wont help until you do that.
seethingsclear is offline   0 Reply With Quote
Old May 25, 2010, 09:43 PM   #24
Chaseweston
macrumors newbie
 
Join Date: May 2010
Hey guys, I've been having a similar problem.. I have a 3GS jailbroken with blackrain.. ever since i got it, it always auto connected to my home wifi. then about a week or two ago it just stopped.. But when i go near other "remembered" networks it auto-connects just like it used to.. I havent changed any settings on my iphone or wifi it just all the sudden started to not connect.. under "wifi" in my phone it recognizes "linksys" but when I click on it to connect it displays a window saying "unable to join the network "lynksys"" with a dismiss button.. I reset the network settings like stated above. and rebooted my iphone and modem and router multiple times still resulting in the same problem.. any help?

Thanks, Chase weston
Chaseweston is offline   0 Reply With Quote
Old May 25, 2010, 09:52 PM   #25
Chaseweston
macrumors newbie
 
Join Date: May 2010
Quote:
Originally Posted by Chaseweston View Post
Hey guys, I've been having a similar problem.. I have a 3GS jailbroken with blackrain.. ever since i got it, it always auto connected to my home wifi. then about a week or two ago it just stopped.. But when i go near other "remembered" networks it auto-connects just like it used to.. I havent changed any settings on my iphone or wifi it just all the sudden started to not connect.. under "wifi" in my phone it recognizes "linksys" but when I click on it to connect it displays a window saying "unable to join the network "lynksys"" with a dismiss button.. I reset the network settings like stated above. and rebooted my iphone and modem and router multiple times still resulting in the same problem.. any help?

Thanks, Chase weston
nevermind. I got frustrated and ripped the wires out of my modem and router walked off to blow some steam then plugged back in once calmed down let everything re start and now miraculously it connects to my linksys.. thank god. Thanks anyways though
Chaseweston is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Home Sharing and AirParrot wont connect via "internet sharing" from iMac luckstar Apple TV and Home Theater 4 Feb 20, 2014 05:36 AM
iPad Mini won't connect to home Airport WiFi Network anymore txa1265 iPad Tips, Help and Troubleshooting 2 Dec 8, 2012 11:27 AM
iPhone wont connect to WPA2 lingo124 iPhone Tips, Help and Troubleshooting 0 Oct 20, 2012 03:53 AM
iPhone wont automatically connect to wifi II BISTRO II iPhone 1 Sep 27, 2012 11:46 PM
Macbook Pro and iPad 2 won't connect to home wifi anymore daveme214 MacBook Pro 7 Jun 18, 2012 08:50 AM

Forum Jump

All times are GMT -5. The time now is 09:43 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC