Go Back   MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Reply
 
Thread Tools Search this Thread Display Modes
Old Oct 22, 2007, 05:03 PM   #1
Hobbit
macrumors member
 
Join Date: Jun 2005
Challenging printer problem, I need your help!

I am struggling to reinstall my printer Epson DX4850 (same as DX4800).

My printer was working very well with my MacBook. Never had a problem with it. Recently i was playing with a programme called MacPilot and tried all the options there including cleaning, repairing and deleting preferences, etc. and this seems to have uninstalled my printer somehow.

I tried to reinstall my printer since then using the driver from Epson website but I keep getting the following error message when i tried to add the printer using the printer setup utility. The message says:

Client-error-request-value-too-long


I searched the forum and tried the following but i'm still getting the same error.

http://forums.macrumors.com/showthre...ighlight=epson

1. Reset the Printing System via the Printer Setup Utility.
2. Reboot
3. Open Terminal
4. cd /Library/Printers
5. sudo mv EPSON EPSONold
6. ctl-D or exit to close Terminal


Can someone please help.
Thank you.
Hobbit is offline   0 Reply With Quote
Old Oct 22, 2007, 05:16 PM   #2
Makosuke
macrumors 603
 
Join Date: Aug 2001
Location: The Cool Part of CA, USA
A question:

That error seems to be a CUPS error; are you using the CUPS driver? If so, does Epson have a "native" (not sure what the correct term is, actually) for that printer, and does it work?

If it IS a CUPS error, then it sounds rather like you broke the CUPS subsystem, rather than it being an Epson driver-specific problem--this would explain why a reinstall didn't fix it.

Just out of curiosity, enter this in the terminal:

sudo ls /var/spool/cups

...then give sudo your password. It should list the contents of the cups director, which will include a "tmp" directory and a few other things. If it doesn't (or you get no list at all), MAYBE that's the issue. Worth a shot recreating those directories.
Makosuke is offline   0 Reply With Quote
Old Oct 22, 2007, 05:52 PM   #3
Hobbit
Thread Starter
macrumors member
 
Join Date: Jun 2005
Makosuke

Thank you for your quick reply. I'm afraid i'm not a computer expert so i'm not sure what CUPS driver means, but i know that the Epson driver installed fine and my printer was working fine in the past.

I did what you asked me to do in a terminal and here is the reply i got.

ls: /var/spool/cups: No such file or directory


Any idea what i should do next? An explanation as to what the problem is would be highly appreciated.

Thank you.
Hobbit is offline   0 Reply With Quote
Old Oct 22, 2007, 08:27 PM   #4
Makosuke
macrumors 603
 
Join Date: Aug 2001
Location: The Cool Part of CA, USA
First, CUPS ("Common Unix Printing System") is essentially a cross-platform framework for printer drivers, and there are "unofficial" drivers for a LOT of printers available for it. I don't pretend to understand the details, but basically it's an alternate system the MacOS can use to print stuff.

My suggestion actually came from suggestions at a Linux help forum; I've never heard of people breaking CUPS on a Mac before, but it sounds like that at least COULD be your problem.

The message you got means that the /var/spool/cups directory doesn't exist at all. That is (I think) where CUPS stores some of its temporary info. It exists on my Tiger install, so I'm assuming it's necessary, and since the error you are getting appears to be a CUPS error maybe your cleaner tool deleted it.

You can try entering the following two commands in the terminal, which should re-create the cups folder and the temp (tmp) folder that's supposed to be in it.

Code:
sudo mkdir /var/spool/cups
then
Code:
sudo mkdir /var/spool/cups/tmp
The first time you will be asked for your admin password. What those commands are: "sudo" means execute the rest of the command as a superuser, which bypasses the fact that you probably don't normally have permission to write anything to the /var/spool directory. That's what asks you for your password. "mkdir" means "make directory" and then the /var/spool/... is the place to create the directory. Be sure to enter the commands precisely as above, including the initial slash, or it'll create the directory somewhere else.

If that fixes it, then this was the problem. If not, I'm out of guesses.

Oh, and on a related note, you should (probably after doing the above, though I don't know that it'll make any difference) run "Repair Disk Permissions" on your startup disk using Disk Utility. That could, theoretically, also make a difference.
Makosuke is offline   0 Reply With Quote
Old Oct 23, 2007, 02:50 AM   #5
Hobbit
Thread Starter
macrumors member
 
Join Date: Jun 2005
Makosuke

Big thank you to you. The problem is now solved after creating the CUPS/temp folder.
Hobbit is offline   0 Reply With Quote
Old Sep 11, 2008, 06:39 PM   #6
JennyPennyO
macrumors newbie
 
Join Date: Sep 2008
Location: Western PA
Send a message via AIM to JennyPennyO
client-error-request-value-too-long???

i am having the same problem, except my printer is new, and i am installing it onto my macbook for the first time. but every time i try to add the printer, i get that error. i have NO idea how to fix this, and what you guys are talking about reads like german to me (im not very computer smart)

someone please help me, i need my printer for college
JennyPennyO is offline   0 Reply With Quote
Old Sep 11, 2008, 09:08 PM   #7
alphaod
macrumors Core
 
alphaod's Avatar
 
Join Date: Feb 2008
Location: 上海 (Shanghai)
Quote:
Originally Posted by JennyPennyO View Post
i am having the same problem, except my printer is new, and i am installing it onto my macbook for the first time. but every time i try to add the printer, i get that error. i have NO idea how to fix this, and what you guys are talking about reads like german to me (im not very computer smart)

someone please help me, i need my printer for college
If you can't put it into Terminal yourself thentake the command and have a friend or Genius do it.
__________________
Mac Pro | Mac mini | 15" MacBook Pro | iPad Air | iPhone 6
alphaod is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Problem with new MBPr and printer Zeov MacBook Pro 2 May 8, 2014 02:15 PM
Mavericks Printer Problem Raybird Mac Basics and Help 2 Jan 13, 2014 10:29 AM
Printer Problem with OS X 10.8.2 mlsoren OS X 10.8 Mountain Lion 1 Nov 14, 2012 12:28 PM
Printer's problem charlesqh MacBook Pro 0 Jul 11, 2012 06:51 PM

Forum Jump

All times are GMT -5. The time now is 06:18 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC