Go Back   MacRumors Forums > Apple Applications > Mac Applications and Mac App Store

Reply
 
Thread Tools Search this Thread Display Modes
Old Nov 8, 2007, 06:05 PM   #1
Javdogjavdog
macrumors newbie
 
Join Date: Sep 2003
Location: Santa Cruz
My first Leopard Bug: IMAP Mail Error, help!

Error message is as follows:

"The IMAP command “UID COPY” (to Deleted Messages) failed for the mailbox “INBOX” with server error: Error in IMAP command received by server.."

This is my first Leopard bug. The Mail program cannot delete messages using IMAP. Mail worked fine using Tiger, so that is lame. Now I have to use Webmail to actually delete a message. Any thoughts?

Jav
Javdogjavdog is offline   0 Reply With Quote
Old Nov 8, 2007, 06:15 PM   #2
Phil A.
macrumors 68040
 
Phil A.'s Avatar
 
Join Date: Apr 2006
Location: Telford, UK
Quote:
Originally Posted by Javdogjavdog View Post
Error message is as follows:

"The IMAP command “UID COPY” (to Deleted Messages) failed for the mailbox “INBOX” with server error: Error in IMAP command received by server.."

This is my first Leopard bug. The Mail program cannot delete messages using IMAP. Mail worked fine using Tiger, so that is lame. Now I have to use Webmail to actually delete a message. Any thoughts?

Jav
What IMAP server are you using? IMAP delete works fine in Leopard for me with GMail
Phil A. is offline   0 Reply With Quote
Old Nov 8, 2007, 07:46 PM   #3
baummer
macrumors 6502a
 
Join Date: Jan 2005
Location: Southern California
Send a message via AIM to baummer
Quote:
Originally Posted by Javdogjavdog View Post
Error message is as follows:

"The IMAP command “UID COPY” (to Deleted Messages) failed for the mailbox “INBOX” with server error: Error in IMAP command received by server.."

This is my first Leopard bug. The Mail program cannot delete messages using IMAP. Mail worked fine using Tiger, so that is lame. Now I have to use Webmail to actually delete a message. Any thoughts?

Jav
This isn't a Leopard bug. The problem is on the server end. Which service? Or is this your own web site? I have 3 different IMAP accounts, all with different servers and providers and I have zero problems.
baummer is offline   0 Reply With Quote
Old Nov 17, 2007, 01:17 PM   #4
ianpiper
macrumors newbie
 
Join Date: Nov 2007
Solution

This is not a server bug. It is something peculiar that seems to happen to IMAP account settings when upgrading to Leopard. Check out Mail->Preferences...->Accounts->Trash

You should see two checkboxes (if this is an IMAP account), the second of which reads "Store deleted messages on the server". This checkbox should not be checked - if it is checked, you get the error you reported.

Anyway, this happened to me on two of my machines and the above resolved it, so it is probably worth try.


Ian.
--
ianpiper is offline   0 Reply With Quote
Old Nov 17, 2007, 06:24 PM   #5
GSMiller
macrumors 68000
 
GSMiller's Avatar
 
Join Date: Dec 2006
Location: Kentucky
I have this problem too with my AOL Mail account in Leopard. I said screw it and went back to POP3.
__________________
2.16 GHz 20" iMac || 30GB 5G iPod || 1GB 3G Shuffle || 2.16 GHz Blackbook
GSMiller is offline   0 Reply With Quote
Old Nov 26, 2007, 03:50 AM   #6
arnski
macrumors newbie
 
Join Date: Nov 2007
This did the trick for me, thx!

Quote:
Originally Posted by ianpiper View Post
This is not a server bug. It is something peculiar that seems to happen to IMAP account settings when upgrading to Leopard. Check out Mail->Preferences...->Accounts->Trash

You should see two checkboxes (if this is an IMAP account), the second of which reads "Store deleted messages on the server". This checkbox should not be checked - if it is checked, you get the error you reported.

Ian.
--
arnski is offline   0 Reply With Quote
Old Jan 10, 2008, 07:05 PM   #7
sm1tty
macrumors newbie
 
Join Date: Jan 2008
Location: NC
Thanks a lot, that did the trick!!!!

Quote:
Originally Posted by ianpiper View Post
This is not a server bug. It is something peculiar that seems to happen to IMAP account settings when upgrading to Leopard. Check out Mail->Preferences...->Accounts->Trash

You should see two checkboxes (if this is an IMAP account), the second of which reads "Store deleted messages on the server". This checkbox should not be checked - if it is checked, you get the error you reported.

Anyway, this happened to me on two of my machines and the above resolved it, so it is probably worth try.


Ian.
--
sm1tty is offline   0 Reply With Quote
Old Mar 15, 2011, 07:55 PM   #8
Executive
macrumors newbie
 
Join Date: Mar 2011
Location: lonely at the top
Quote:
Originally Posted by ianpiper View Post
this is not a server bug. It is something peculiar that seems to happen to imap account settings when upgrading to leopard. Check out mail->preferences...->accounts->trash

you should see two checkboxes (if this is an imap account), the second of which reads "store deleted messages on the server". This checkbox should not be checked - if it is checked, you get the error you reported.

Anyway, this happened to me on two of my machines and the above resolved it, so it is probably worth try.


Ian.
--
thank you!
Executive is offline   0 Reply With Quote
Old Nov 29, 2012, 10:49 AM   #9
jakn09ab
macrumors newbie
 
Join Date: Apr 2011
Thank you

Quote:
Originally Posted by ianpiper View Post
This is not a server bug. It is something peculiar that seems to happen to IMAP account settings when upgrading to Leopard. Check out Mail->Preferences...->Accounts->Trash

You should see two checkboxes (if this is an IMAP account), the second of which reads "Store deleted messages on the server". This checkbox should not be checked - if it is checked, you get the error you reported.

Anyway, this happened to me on two of my machines and the above resolved it, so it is probably worth try.


Ian.
--
I've had a lot of troubles with this one as I somehow moved these emails from another account to my gmail trash.
I tried removing the account before and it didn't help. Then I followed your advice, and i was still the same problem. I removed the gmail and added it again and voila! Thanks a lot, my hair stopped turning gray for a few minutes!
jakn09ab is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Applications > Mac Applications and Mac App Store

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
"Get mail" on IMAP mail account on Mac won't fetch new mail AZRob Mac Applications and Mac App Store 1 Oct 27, 2014 02:02 AM
"Get mail" on IMAP mail account on Mac won't fetch new mail AZRob OS X 27 Oct 27, 2014 02:01 AM
What's the difference between POP mail and IMAP mail? anonymous4a iOS 7 8 Apr 2, 2014 11:40 AM
iCloud Mail via IMAP in Mail stopped working Taipan Mac Applications and Mac App Store 3 Mar 4, 2013 10:22 AM
Mac Mail IMAP with tons of mail decksnap Mac Applications and Mac App Store 3 Dec 8, 2012 01:38 PM

Forum Jump

All times are GMT -5. The time now is 08:20 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC