Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 13, 2014, 11:19 AM   #1
KeegM480
macrumors 6502a
 
KeegM480's Avatar
 
Join Date: Aug 2013
Location: Orlando
Audio issues with AirPlay & Netflix (ATV3)

So my first issue is with Airplay, this issue and the issue with Netflix both happened on the same day.

AirPlay Issue:
I can't seem to get my music to stream from my iPhone to my Apple TV unless I enable mirroring, not a big issue, but a little frustrating due to the battery life. (The Audio will not play, it shows the song is playing but doesn't send any audio to the speakers)

Netflix Issue:
I am not getting any audio from TV Shows/Movies on Netflix, yes I have audio with iTunes radio, The click noises, all of that stuff, but not Netflix.

So not quite sure why, Apple wants to blame my sound bar and/or Optical cable, even though everything was working for a while... I have tried 16bit audio, no dolby, any ideas?
__________________
 15" MacBook Pro (2.2GHz i7, 16GB RAM, 240 SSD, 500 HDD) | PowerMac G5 (2GHz, 2GB RAM, 460GB) 
iMac G3 (400MHz, 512MB RAM, 40GB) | iPad Mini (16GB, White) | iPhone 5S (16GB, Gold)
KeegM480 is offline   0 Reply With Quote
Old Jan 13, 2014, 11:38 AM   #2
blueroom
macrumors 603
 
blueroom's Avatar
 
Join Date: Feb 2009
Location: Toronto, Canada
iPhone, probably a wonky WiFi router or the jailbreak.

Netflix on the AppleTV is it jailbroken? Old firmware, DNS redirector? Is it wired or WiFi (always run wired Ethernet if you can). Most likely your stereo can't decode it, try changing the Dolby settings on the ATV.
__________________
My iOS devices are not jailbroken.
Bill
My Blog
blueroom is offline   0 Reply With Quote
Old Jan 13, 2014, 11:42 AM   #3
KeegM480
Thread Starter
macrumors 6502a
 
KeegM480's Avatar
 
Join Date: Aug 2013
Location: Orlando
Quote:
Originally Posted by blueroom View Post
iPhone, probably a wonky WiFi router or the jailbreak.

Netflix on the AppleTV is it jailbroken? Old firmware, DNS redirector? Is it wired or WiFi (always run wired Ethernet if you can). Most likely your stereo can't decode it, try changing the Dolby settings on the ATV.
Running Ethernet, Haven't installed anything on the iPhone to make it not work (it has always worked jailbroken and randomly stopped), the Apple TV is not jailbroken
__________________
 15" MacBook Pro (2.2GHz i7, 16GB RAM, 240 SSD, 500 HDD) | PowerMac G5 (2GHz, 2GB RAM, 460GB) 
iMac G3 (400MHz, 512MB RAM, 40GB) | iPad Mini (16GB, White) | iPhone 5S (16GB, Gold)
KeegM480 is offline   0 Reply With Quote
Old Jan 13, 2014, 11:49 AM   #4
blueroom
macrumors 603
 
blueroom's Avatar
 
Join Date: Feb 2009
Location: Toronto, Canada
Jailbreaks can and often do break something in the OS. Easy enough to do a DFU restore and see if the problem resolves itself. Then apply the jailbreak see if the problem re-appears.

As for the ATV play with the Dolby settings. It's also possible your sound bar is having problems.

What make model is your router, anything from an ISP in the UK seems to be utter crap.
__________________
My iOS devices are not jailbroken.
Bill
My Blog
blueroom is offline   0 Reply With Quote
Old Jan 13, 2014, 03:28 PM   #5
KeegM480
Thread Starter
macrumors 6502a
 
KeegM480's Avatar
 
Join Date: Aug 2013
Location: Orlando
Quote:
Originally Posted by blueroom View Post
Jailbreaks can and often do break something in the OS. Easy enough to do a DFU restore and see if the problem resolves itself. Then apply the jailbreak see if the problem re-appears.

As for the ATV play with the Dolby settings. It's also possible your sound bar is having problems.

What make model is your router, anything from an ISP in the UK seems to be utter crap.
Netgear something, extremely high end router, I'm confused simply because one day everything was working the next it wasn't
__________________
 15" MacBook Pro (2.2GHz i7, 16GB RAM, 240 SSD, 500 HDD) | PowerMac G5 (2GHz, 2GB RAM, 460GB) 
iMac G3 (400MHz, 512MB RAM, 40GB) | iPad Mini (16GB, White) | iPhone 5S (16GB, Gold)
KeegM480 is offline   0 Reply With Quote
Old Jan 13, 2014, 03:47 PM   #6
MFL2012
macrumors member
 
Join Date: Jul 2012
Quote:
Originally Posted by KeegM480 View Post
Netgear something, extremely high end router, I'm confused simply because one day everything was working the next it wasn't
Since everything was working before, have you tried something as simple as unplugging the ATV for a minute and then plugging it back in. This solves a lot of problems.
MFL2012 is offline   0 Reply With Quote
Old Jan 13, 2014, 07:36 PM   #7
KeegM480
Thread Starter
macrumors 6502a
 
KeegM480's Avatar
 
Join Date: Aug 2013
Location: Orlando
Quote:
Originally Posted by MFL2012 View Post
Since everything was working before, have you tried something as simple as unplugging the ATV for a minute and then plugging it back in. This solves a lot of problems.
nope, ill try that
__________________
 15" MacBook Pro (2.2GHz i7, 16GB RAM, 240 SSD, 500 HDD) | PowerMac G5 (2GHz, 2GB RAM, 460GB) 
iMac G3 (400MHz, 512MB RAM, 40GB) | iPad Mini (16GB, White) | iPhone 5S (16GB, Gold)
KeegM480 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Can't Airplay Audio from MBA to ATV3. Ideas? JustGretchen Apple TV and Home Theater 1 Dec 24, 2013 12:54 PM
Netflix on ATV3 CaptTCS Apple TV and Home Theater 8 Feb 19, 2013 09:51 AM
Airplay connection issue with iTunes & ATV3 belarocks Mac Applications and Mac App Store 2 Dec 14, 2012 06:27 AM
ATV3 AirPlay Mirroring - Video, no audio sdilley14 Apple TV and Home Theater 8 Sep 24, 2012 05:55 PM

Forum Jump

All times are GMT -5. The time now is 08:58 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC