Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Reply
 
Thread Tools Search this Thread Display Modes
Old Jun 25, 2010, 07:14 AM   #51
czieka
macrumors newbie
 
Join Date: Jun 2010
Location: Philippines
Send a message via Yahoo to czieka Send a message via Skype™ to czieka
still no sound

i tried everything.. and nothing works...
czieka is offline   0 Reply With Quote
Old Jan 17, 2011, 01:59 PM   #52
kidofdoomz
macrumors newbie
 
Join Date: Jan 2011
iPhone 3G very rare no sound fix

Hey guys, first time post. I was having intermittent complete blackouts of sound [no ringtones, no unlock/lock sounds, no speaker phone, etc.] and couldn't figure it out.

Come to find out, when I squeeze that corner of the phone (the same corner on the 4 that has the antenna problem, ironically) my sound miraculously comes back on. I'm sure this is a problem in VERY FEW iPhones, but for those few of you out there that may be having this problem, try just squeezing that corner of your phone while playing a song or something and see if it works.

I assume there are plenty of iPhone cases out there that could keep the phone squeezed enough for the speaker to keep functioning, or plenty of other fixes.

Hope this helps! Good luck
kidofdoomz is offline   1 Reply With Quote
Old Jul 23, 2011, 12:40 AM   #53
BabaJing
macrumors newbie
 
Join Date: Jul 2011
Unhappy No sound whatsoever

Hi everyone. This is my first time here and I have tried to follow everyones advice and still no luck with my iphone4. There is just no sound at all. even with the headset on, nothing! Any idea what else i can do??? please help!!!
BabaJing is offline   0 Reply With Quote
Old Jul 23, 2011, 02:46 PM   #54
blaster_boy
macrumors regular
 
Join Date: Jan 2004
Location: Belgium
I had this problem with my first iphone first generation, but with my iphone 4, after updating to the latest version 4.3.4, the problem has appeared. Putting in headphones did not resolve the problem....

For now I've done a reset, reset all settings, nothing helped. Tomorrow I'll try do to a restore...

A
blaster_boy is offline   0 Reply With Quote
Old Oct 27, 2011, 05:15 PM   #55
Christo954
macrumors newbie
 
Join Date: Oct 2011
iPhone 4 - Squeezing speaker corner worked

Ironically, doing what kidofdoomz said earlier worked perfectly for me too. The sound on my iPhone 4 was constantly going on and off to where you would here no text, phone rings, alerts, etc. Then I tried the trick I just read and now my phone seems to be working fine.

Just try this if your iPhone isn't making any sounds... Turn on a song from your music library (so you can have constant streaming sound)... Squeeze the bottom right corner (both glass sides) where the speaker is located repeatedly, and listen for your iPhone to start making sound again.

This worked for me... Hopefully something as simple as this will for you too.
Christo954 is offline   0 Reply With Quote
Old Dec 7, 2011, 07:54 AM   #56
Notary Mike
macrumors newbie
 
Join Date: Dec 2011
iPhone lost sounds

One morning I noticed my phone would ring but notifications were silent. It would only vibrate an alert. I recently hooked up a Bluetooth device to my home stereo so I could play my tunes. Here's the problem with this: If you leave the Bluetooth on the iPhone "on" and switch the input on the stereo to another source, the phone is still sending notification sounds to the Bluetooth receiver, but you can't hear them because they have been silenced on the phone AND the receiver! The fix here is to remember to turn off the Bluetooth setting on the phone or the external device that receives the signal. Then all comes back to normal. Think of it this way, when you are using a BT headset, the notifications come through that device, right? If you don't turn it off but take it off your head the sounds will still come through the device and not the phone as long as it is in range of the phone. To restore sounds through the phone, disconnect the BT device.
Notary Mike is offline   0 Reply With Quote
Old Dec 7, 2011, 02:50 PM   #57
Van Smack
macrumors newbie
 
Join Date: Dec 2011
Okay, I'm having a similar problem. I've tried a lot of the remedies in this thread such as resetting the phone or resetting the settings, but that hasn't helped.

I get sound if I preview a ring tone, however, if I want to play music through the speakers, it doesn't play. The volume bar doesn't even show up either.

Anyone have any ideas that they could help me with? Thank you.
Van Smack is offline   0 Reply With Quote
Old Jan 1, 2012, 03:34 PM   #58
nepzsmiler
macrumors newbie
 
Join Date: Jan 2012
Arrow iphone 4s sound solved if you are having any problem

Hi there, after reading all comments above please keep one thing on your mind that the sound problem in iphone usually occurs when you have exceeded the maximum memory of your iphone , there is no cause of hardware .

I have an iphone 4s , i had the problem of the sound since this morning ,the problem was sound was disappearing constantly ,plays and stops in every apps and media including call.

So , after reading all the comments and suggestion i tried everything , nothing worked , I was in 5.0 version of iphone 4s and i updated it to 5.0.1 and everything worked perfectly now the problem is cleared .

This is for those future users if they found any glitch or any issues about audio problem of iphone .

Thank you .
nepzsmiler is offline   0 Reply With Quote
Old Jan 22, 2012, 12:12 PM   #59
vpr
macrumors newbie
 
Join Date: Mar 2008
Don't want to necro a thread but, I just got an iPhone 4s that I activated on my AT&T account on Friday... We also got the insurance which was offered when we activated it even though we didn't buy the iPhone from at&t. The problem is that the sound has been cutting out from time to time... I started researching and did a few of the steps... I restarted the phone, held both home and power buttons, upgraded to iOS 5.0.1 and the sound (keyboard clicks, ring tones, lock and unlock sound, etc) will sometimes work other times it will cut out... Headphones will play the sounds just fine. I discovered that plugging the power cord and unplugging it would bring the sound back sometimes. Then I found that squeezing the bottom right corner would work as described in this post.

My question is that is this behavior what we have to deal with in a phone valued over $700 (32gb black) or is there a resolution to this? I don't feel like having to handle the phone in an extremely dainty wY is acceptable... Of course you need to be careful, but trying not to touch the bottom right corner of the phone is something I don't want to have to do. Would doing an insurance exchange work? Would it be a refurbished phone? We have a hard plastic case coming, is that going to make a difference?

Thank you,

Ttl;dr - intermittent no sound issue, squeezing right corner brings it back, don't want to worry about not touching bottom right of the phone, will a hard case fix it or should I just do an insurance exchange? If exchange will it be a refurbished model?

Vpr
vpr is offline   0 Reply With Quote
Old Apr 2, 2012, 04:16 PM   #60
mooreke
macrumors newbie
 
Join Date: Apr 2012
Head rush

OK, had the same problem with the internal speaker. Just stopped working one day after being in my pocket while coaching baseball practice. At first, I thought it was because I had been using the headphone jack in the car and (having had the same problem with a Palm Pre 2) I figured the headphone jack was in la la land.

Tried the blowing and I tried cleaning the jack with a q-tip and a dab of alcohol. Nada. What had me thinking was that if you adjusted the volume, it showed the speaker icon. If you have a headphone plugged in and adjusted the volume, it would show the speaker icon with "headphones" above it. That led me to believe it wasn't an erroneous headphone jack problem. I did try removing/inserting the jack 20 times and it didn't work.

I left the phone in the car holder the next day for a few hours while at a site and decided to drive to the Apple Store which was down the road. Right before I got there I tested the internal speaker and it was now working. I figured the sight of the Apple Store scared the iPhone into submission.

Well, went to baseball practice again a few days later, phone in pocket and guess what? Yup, stopped working again. Didn't work after a few days so I was concerned. Started reading more posts about this. Tried the "reset all" and that didn't work. Thought about an errant app but really hadn't installed anything around the time it stopped working. Then thought about it again logically. What was the same both times it stopped working? Baseball and long, legged training pants (it's been cold) with semi-fuzzy pockets!

I took the protective cover off and gave it 5 really, really hard blows into the headphone jack and, voila, it started working again. Seriously, I tried this the first time but they were wimpy blows. This time it was head rush, dizzying blows. I hope this helps someone. Now I am going to look around the house for an old phone that has the headphone jack plug and insert it into the iPhone.
mooreke is offline   0 Reply With Quote
Old Apr 3, 2012, 02:27 PM   #61
Fried Chicken
macrumors regular
 
Join Date: Jun 2011
Quote:
Originally Posted by Van Smack View Post
Okay, I'm having a similar problem. I've tried a lot of the remedies in this thread such as resetting the phone or resetting the settings, but that hasn't helped.

I get sound if I preview a ring tone, however, if I want to play music through the speakers, it doesn't play. The volume bar doesn't even show up either.

Anyone have any ideas that they could help me with? Thank you.

I have probably the same issue.
I think the phone acts like it's connected to a dock, so some stuff plays through the speaker, other stuff doesn't play at all.

I don't want to reset everything, I have a jailbroken phone.
It's a bit ********. I already restored, but the problem persisted.


I described the issue in this thread:
http://forums.macrumors.com/showthread.php?t=1352311
Fried Chicken is offline   0 Reply With Quote
Old May 4, 2012, 11:48 PM   #62
Loredelgado
macrumors newbie
 
Join Date: May 2012
Quote:
Originally Posted by Van Smack View Post
Okay, I'm having a similar problem. I've tried a lot of the remedies in this thread such as resetting the phone or resetting the settings, but that hasn't helped.

I get sound if I preview a ring tone, however, if I want to play music through the speakers, it doesn't play. The volume bar doesn't even show up either.

Anyone have any ideas that they could help me with? Thank you.
I have the exact same problem , my iphone 4S plays ringtones and preview of them but it wont play at loud anything else! I already restore it and it didnt work , and the weirdest thing is that when i try to turn up the volume it doesnt do anything is like the speakers are off or something please HELP
Loredelgado is offline   0 Reply With Quote
Old May 11, 2012, 01:57 AM   #63
Fried Chicken
macrumors regular
 
Join Date: Jun 2011
Quote:
Originally Posted by Loredelgado View Post
I have the exact same problem , my iphone 4S plays ringtones and preview of them but it wont play at loud anything else! I already restore it and it didnt work , and the weirdest thing is that when i try to turn up the volume it doesnt do anything is like the speakers are off or something please HELP
Apparently it's a physical problem with the dock connector.
You're going to have to send it in to apple.
Fried Chicken is offline   0 Reply With Quote
Old May 12, 2012, 05:39 PM   #64
Techniq82
macrumors newbie
 
Join Date: Jan 2012
iphone 4 gsm headphone jack just not working?!?!

some how my iphone4 headphone jack stopped putting out sound, i plugged it into my home amplifier like any other amp...( i usualy do that and it worked fine b 4 but weeks ago it stopped working as well as the physical volume up and down buttons.. i could control the play and volume from my headphone buttons but not on the physical iphone.... i thought that some kind of static shock happened that messed it up im not sure. i never dropped it nor does it have water damage...i replaced the headphone jack flex cable an all and still nothing and i also lost the controls from the actually headphone buttons now.... i dont know if i should just buy another replacement flex cable to fix it. all other audio output work like the airplay and the iphones physical speaker just not the headphones...i need to know if i have really ruined the logic board or just the flex cable...


id love if someone could help me soon i ben without my music for a long time now and dying for my dubstep back ( ( heeeeelp
Techniq82 is offline   1 Reply With Quote
Old Sep 25, 2012, 01:17 PM   #65
keith777
macrumors newbie
 
Join Date: Sep 2012
No sound... was restored finally thanks God!

i've been trying plugging and unplugging my ear phones several times and go to settings and everything but still doesn't work. it came into my mind, i inserted a piece of stick on that hole.... don't push it to deep. and finally the sound came back!

----------

Quote:
Originally Posted by Techniq82 View Post
some how my iphone4 headphone jack stopped putting out sound, i plugged it into my home amplifier like any other amp...( i usualy do that and it worked fine b 4 but weeks ago it stopped working as well as the physical volume up and down buttons.. i could control the play and volume from my headphone buttons but not on the physical iphone.... i thought that some kind of static shock happened that messed it up im not sure. i never dropped it nor does it have water damage...i replaced the headphone jack flex cable an all and still nothing and i also lost the controls from the actually headphone buttons now.... i dont know if i should just buy another replacement flex cable to fix it. all other audio output work like the airplay and the iphones physical speaker just not the headphones...i need to know if i have really ruined the logic board or just the flex cable...


id love if someone could help me soon i ben without my music for a long time now and dying for my dubstep back ( ( heeeeelp


i inserted a piece of stick on that hole.... don't push it too deep & hard. and finally the sound came back!
keith777 is offline   0 Reply With Quote
Old Sep 25, 2012, 01:29 PM   #66
keith777
macrumors newbie
 
Join Date: Sep 2012
Quote:
Originally Posted by Van Smack View Post
Okay, I'm having a similar problem. I've tried a lot of the remedies in this thread such as resetting the phone or resetting the settings, but that hasn't helped.

I get sound if I preview a ring tone, however, if I want to play music through the speakers, it doesn't play. The volume bar doesn't even show up either.

Anyone have any ideas that they could help me with? Thank you.




my problem was no sound, it's like connected to a dock. i tried to insert a piece of stick on that hole.... don't push it to deep. and finally the sound came back! seriously it came back... hope ur problem is just like mine... really everything is been restore. I thank God for that wisdom He gave..hope this can help others..

----------

Quote:
Originally Posted by czieka View Post
i tried everything.. and nothing works...
my problem was no sound it's like connected to a dock. i tried to insert a piece of stick on that hole.... don't push it to deep. and finally the sound came back! seriously it came back... hope ur problem is just like mine... really everything is been restore. I thank God for that wisdom He gave..hope this can help you & others..
keith777 is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
odd behavior with sound, have to unplug headphones, then plug to get sound Sossity Mac Basics and Help 1 Dec 2, 2013 01:13 AM
iPhone 4S sound Ferrermi iPhone Tips, Help and Troubleshooting 1 Feb 10, 2013 01:28 PM
iPhone 4 no sound Aglaia6 iPhone Tips, Help and Troubleshooting 0 Jan 8, 2013 01:43 PM
iPhone 4 - No Sound slapbang12 iPhone Tips, Help and Troubleshooting 6 Aug 29, 2012 10:45 PM
Mountain Lion installed but no sound, system preferences or sound related apps. rickmusik OS X 10.8 Mountain Lion 3 Aug 2, 2012 01:55 PM

Forum Jump

All times are GMT -5. The time now is 06:49 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC