Go Back   MacRumors Forums > News and Article Discussion > iOS Blog Discussion

Reply
 
Thread Tools Search this Thread Display Modes
Old Nov 22, 2007, 09:39 PM   #1
MacRumors
macrumors bot
 
Join Date: Apr 2001
iFuntastic 4.7,1 with iTunes 7.5 (and iPhone 1.1.2) Support



The latest version of iFuntastic 4.7.1 has been released. The iPhone customization/jailbreaking software is now shareware for many of the advanced features. Release notes:

- support for iTunes 7.5
- fixed text display for Leopard
- improved email procedure
- fixed alignment bug for Home Screen backgrounds (thank you Szymon)
- a 'Small Icons' choice for the (advanced) Home Screen
- fixed 'vanishing iPod icon' bug
- a 'News' page for up-to-date info about updates bugs and more
- a 'Make Executable' function in the File Manager item popup menu (thank you Avi and Alberto)
additional tweaks and simplifications based on your valuable feedback - keep it coming!

The latest version of iFuntastic allows users to jailbreak their 1.0.2, 1.1.1, and 1.1.2 iPhones, and also provide other customization options. There are directions on how to Jailbreak a 1.1.2 iPhone, but some may find this solution more convenient.

Article Link
MacRumors is offline   0 Reply With Quote
Old Nov 22, 2007, 09:42 PM   #2
kbrain2929
macrumors regular
 
Join Date: Jun 2007
Location: The Ville', KY
Send a message via AIM to kbrain2929
Quote:
Originally Posted by Macrumors View Post


The latest version of iFuntastic 4.7.1 has been released. The iPhone customization/jailbreaking software is now shareware for many of the advanced features. Release notes:

- support for iTunes 7.5
- fixed text display for Leopard
- improved email procedure
- fixed alignment bug for Home Screen backgrounds (thank you Szymon)
- a 'Small Icons' choice for the (advanced) Home Screen
- fixed 'vanishing iPod icon' bug
- a 'News' page for up-to-date info about updates bugs and more
- a 'Make Executable' function in the File Manager item popup menu (thank you Avi and Alberto)
additional tweaks and simplifications based on your valuable feedback - keep it coming!

The latest version of iFuntastic allows users to jailbreak their 1.0.2, 1.1.1, and 1.1.2 iPhones, and also provide other customization options. There are directions on how to Jailbreak a 1.1.2 iPhone, but some may find this solution more convenient.

Article Link
Wow! I'm thinking of hacking my iPhone now. Hmmmm.....
__________________
MacPro 3.0ghz Xeon/24" iMac 2.8ghz 2GB/17" MacBookPro 2.4ghz/8GB iPhone/160GB TV/80GB Video iPod/160GB iPod Classic/Leopard Accross the Board!
kbrain2929 is offline   0 Reply With Quote
Old Nov 22, 2007, 10:07 PM   #3
IDANNY
macrumors 6502a
 
IDANNY's Avatar
 
Join Date: Dec 2003
Location: Las vegas
looks good where can I get version 1.0.1 to unshackle my phone : )
__________________
Display Samsung ln46a850.
17" Macbook Pro 2.66ghz i7 256 ssd 8gb ram
15" Macbook Pro Retina 2.77ghz i7 768GB ssd 16gb ram
My Time Clock ! Website
IDANNY is offline   0 Reply With Quote
Old Nov 23, 2007, 04:54 AM   #4
onemilkid
macrumors newbie
 
Join Date: Apr 2003
Location: Oslo/Norway & Wiesbaden/Germany
Send a message via AIM to onemilkid
Can i buy an iPhone at Fifth Avenue today?

Or is there still a problem with the current bootloader version? I heard that the firmware is not the problem, but that Apple did something to the boatloader that prevents all hacks from working.

Dies anybody has news about this?
onemilkid is offline   0 Reply With Quote
Old Nov 23, 2007, 05:31 AM   #5
michaelsviews
macrumors 6502a
 
Join Date: Sep 2007
Quote:
Originally Posted by IDANNY View Post
looks good where can I get version 1.0.1 to unshackle my phone : )
If you goto this site and scroll down you'll see all the versions listed from apple

http://iphone.unlock.no/
__________________
Apple always playing catchup
Bring back the down vote for post's
Never a boring moment here on MR. It's amazing
michaelsviews is offline   0 Reply With Quote
Old Nov 23, 2007, 06:23 PM   #6
moonaust
macrumors newbie
 
Join Date: Feb 2005
Work with ipod touch

Will this work with the ipod touch as well??
moonaust is offline   0 Reply With Quote
Old Nov 23, 2007, 07:18 PM   #7
badtzmaru
macrumors 6502
 
Join Date: Jul 2007
has anyone received "decompression failed" messages when you try to download the ifuntastic zip file? I tried it on Safari on my mac.
badtzmaru is offline   0 Reply With Quote
Old Nov 23, 2007, 07:48 PM   #8
SRSound
macrumors 6502
 
Join Date: Jun 2005
Does this allow us to intall 3rd party apps on our 1.1.2 phones [without having to downgrade to 1.1.1 and such]????
__________________
STUFF

Last edited by SRSound; Nov 24, 2007 at 09:30 AM.
SRSound is offline   0 Reply With Quote
Old Nov 24, 2007, 02:47 AM   #9
SeVeN
macrumors 6502a
 
Join Date: Aug 2006
Location: SL,UT
yeah before i upgrade to 1.1.2, i want to know for sure that this works for that firmware.
__________________
MBP * G4 Cube * iPhone 5 * PS3 120G *
SeVeN is offline   0 Reply With Quote
Old Nov 24, 2007, 08:35 AM   #10
-M7-
macrumors member
 
Join Date: Feb 2006
If you have a 1.1.1 firmware or lower then unlock is no problem.

If you have a 1.1.2 phone out of the box, you can not SIM unlock at the moment.

Jailbreaking 1.1.2 (this means intall native apps etc) is no problem with out of the box 1.1.2 or updated iphones.
-M7- is offline   0 Reply With Quote
Old Nov 24, 2007, 10:10 AM   #11
MIXMAN3113
macrumors newbie
 
Join Date: Jun 2003
Quote:
Originally Posted by -M7- View Post
If you have a 1.1.1 firmware or lower then unlock is no problem.

If you have a 1.1.2 phone out of the box, you can not SIM unlock at the moment.

Jailbreaking 1.1.2 (this means intall native apps etc) is no problem with out of the box 1.1.2 or updated iphones.
Have you tried, or just going off the specs? I'm looking to get and iphone in a few days and wanna install 3rd party apps on a 1.1.2 out of the box on AT&T.
MIXMAN3113 is offline   0 Reply With Quote
Old Nov 24, 2007, 10:47 AM   #12
-M7-
macrumors member
 
Join Date: Feb 2006
Quote:
Originally Posted by MIXMAN3113 View Post
Have you tried, or just going off the specs? I'm looking to get and iphone in a few days and wanna install 3rd party apps on a 1.1.2 out of the box on AT&T.
I'm waiting for my 1.1.2 phone to arrive. But I'm 100% sure you can Jailbreak it.

See hacking status:http://docs.google.com/View?docid=dgzw9xs_0gfhxns
-M7- is offline   0 Reply With Quote
Old Nov 24, 2007, 12:24 PM   #13
partyvega
macrumors newbie
 
Join Date: Oct 2007
Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU like Mac OS X; en) AppleWebKit/420.1 (KHTML, like Gecko) Version/3.0 Mobile/3A109a Safari/419.3)

if anyone has jailbroken their 1.1.2 iPhone please let us know. I'd like to upgrade mine but want to be sure I won't loose my third party apps. Also how much does the new firmware cost?
partyvega is offline   0 Reply With Quote
Old Nov 24, 2007, 12:37 PM   #14
MIXMAN3113
macrumors newbie
 
Join Date: Jun 2003
Quote:
Originally Posted by -M7- View Post
I'm waiting for my 1.1.2 phone to arrive. But I'm 100% sure you can Jailbreak it.

See hacking status:http://docs.google.com/View?docid=dgzw9xs_0gfhxns
Sweet!!!Thanks for the link, I didn't know of that site.. Anyway, looks good for us, I'm gonna pull the trigger on Tuesday, after I see if any 8GB iphones show up on the refurb site, if not I'll buy new. I'm guessing your staying with AT&T?
MIXMAN3113 is offline   0 Reply With Quote
Old Nov 25, 2007, 01:48 AM   #15
SeVeN
macrumors 6502a
 
Join Date: Aug 2006
Location: SL,UT
i just updated to 1.1.2 and that iFuntastic says. Your MobileDevice version (2.0.0) is NOT supported !

anyone know what that means?
__________________
MBP * G4 Cube * iPhone 5 * PS3 120G *
SeVeN is offline   0 Reply With Quote
Old Nov 25, 2007, 02:08 AM   #16
Bravo
macrumors newbie
 
Join Date: Nov 2007
iFuntastic 4.7.1 didn't work for me. I'm running OS X 10.5, iTunes 7.5, and I had 1.1.2 (updated by accident, long story) installed on my iPhone. I downgraded to 1.1.1 with iFuntastic no problem, but OktoPrep just would not install with InstallerApp. I tried it probably half a dozen times, but it kept crashing and returning to the home screen. So, without OktoPrep, it seems that iFuntastic is worthless regarding a 1.1.2 jailbrake. Bummer too because I've used iFuntastic since its release and it's always worked for me. So, I figured I'd throw them a few bucks this time, and of course this time the program doesn't work. I was able to downgrade all the way back to jailbroken 1.0.2 however. I'd rather run that until a dependable jailbrake turns up for 1.1.2.

Come on hackers, I want all my third party apps back!!

BTW, I've also tried Conceited's jailbrake utility without success. My problem there is that AppSnap won't install from the jailbreakme.com website. I also tried a combination of iFuntastic and Conceited techniques and none were successful.

I probably won't update my iPhone again after I get it back to jailbroken 1.1.2 unless something is released making it really worthwhile, like maybe horizontal texting.
Bravo is offline   0 Reply With Quote
Old Nov 25, 2007, 05:56 PM   #17
FetalSage
macrumors regular
 
Join Date: Jul 2007
Quote:
Originally Posted by SeVeN View Post
i just updated to 1.1.2 and that iFuntastic says. Your MobileDevice version (2.0.0) is NOT supported !

anyone know what that means?
I got this too, very strange.
FetalSage is offline   0 Reply With Quote
Old Nov 25, 2007, 09:44 PM   #18
thingamajigidid
macrumors member
 
Join Date: Nov 2007
Quote:
Originally Posted by Bravo View Post

Come on hackers, I want all my third party apps back!!
have you guys thanked the "hackers". some of us take them for granted....


from now on.. macrumors members new saying should be.. in iphone hackers we trust...
__________________
12" ibook g3 & g4 15" macbook pro intel core duo ; 4gen 20gig ipod ; 8g iphone Airport Extreme ; 2 Airport Express
thingamajigidid is offline   0 Reply With Quote
Old Nov 26, 2007, 08:32 AM   #19
AnotherMortal
macrumors regular
 
Join Date: Jan 2003
Location: Baltimore
Send a message via AIM to AnotherMortal
Quote:
Originally Posted by partyvega View Post
Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU like Mac OS X; en) AppleWebKit/420.1 (KHTML, like Gecko) Version/3.0 Mobile/3A109a Safari/419.3)

if anyone has jailbroken their 1.1.2 iPhone please let us know. I'd like to upgrade mine but want to be sure I won't loose my third party apps. Also how much does the new firmware cost?
I have jailbroken my 1.1.2 OOB iPhone (US) loosely following this guide: http://hackint0sh.org/forum/showthread.php?t=15849

There were issues with oktoprep but this seems to have been resolved.
AnotherMortal is offline   0 Reply With Quote
Old Nov 28, 2007, 03:38 AM   #20
Plumbstone
macrumors regular
 
Join Date: Feb 2007
Hacked UK 1.1.2 iphone last night with iFuntastic. Works pretty much perfectly. You do need to pay $5 to get the 1.1.2 support from it but it is definitely worth it.

Whole process took about 30 mins as I needed to download all updates etc but would have been a lot quick had I had them already.
Plumbstone is offline   0 Reply With Quote
Old Nov 28, 2007, 07:03 AM   #21
onemilkid
macrumors newbie
 
Join Date: Apr 2003
Location: Oslo/Norway & Wiesbaden/Germany
Send a message via AIM to onemilkid
Does that mean the current US iPhones are hackable?

I am leaving New York in 5 hours and i need to know if I can buy an iPhone or not :-)

My current info tells me, that the current bootloader is not hackable.
onemilkid is offline   0 Reply With Quote

Reply
MacRumors Forums > News and Article Discussion > iOS Blog Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Can iTunes support iPad & iPhone FHayek Mac Applications and Mac App Store 1 Apr 17, 2013 04:07 PM
U.S. Carriers Unlikely to Support iPhone 5's Wideband Audio, European Support More Likely MacRumors MacRumors.com News Discussion 127 Jan 9, 2013 09:22 PM
iTunes: Please contact iTunes Support to Complete Purchase CraigM26 iCloud and Apple Services 5 Dec 24, 2012 01:56 AM
Thank you iTunes Support Bozley0621 Apple TV and Home Theater 0 Nov 28, 2012 02:39 PM
Need phone # for itunes support keepingup Mac Applications and Mac App Store 1 Sep 4, 2012 03:55 PM

Forum Jump

All times are GMT -5. The time now is 06:59 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC