Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > OS X

Reply
 
Thread Tools Search this Thread Display Modes
Old Dec 31, 2007, 08:25 PM   #1
legaleye3000
macrumors 6502a
 
Join Date: Jul 2007
How to Access Shared Folders Over Network?

Hi- I have a home wifi network. A Macbook and Macbook Pro. I selected a folder on each computer to be shared and did not touch any other settings. File sharing is set to "on" and when I click on the other computer in the Finder, it connects, but the only folder I see is "Computer's Public Folder." It will not show the folder I set to share.

Please help. Thank you.
legaleye3000 is offline   0 Reply With Quote
Old Dec 31, 2007, 09:01 PM   #2
NAG
macrumors 68030
 
NAG's Avatar
 
Join Date: Aug 2003
Location: /usr/local/apps/nag
What OS are you using?
NAG is offline   0 Reply With Quote
Old Dec 31, 2007, 09:02 PM   #3
legaleye3000
Thread Starter
macrumors 6502a
 
Join Date: Jul 2007
Leopard
legaleye3000 is offline   0 Reply With Quote
Old Dec 31, 2007, 09:08 PM   #4
NAG
macrumors 68030
 
NAG's Avatar
 
Join Date: Aug 2003
Location: /usr/local/apps/nag
Did you hit the connect button when you have the computer selected?
NAG is offline   0 Reply With Quote
Old Dec 31, 2007, 10:46 PM   #5
legaleye3000
Thread Starter
macrumors 6502a
 
Join Date: Jul 2007
In Finder, the computer shows up and it automatically connects as guest when I select it and the only folder that it shows being shared is the public folder which contains the drop box.

It will not show a folder on the other computer that I set to share.
legaleye3000 is offline   0 Reply With Quote
Old Dec 31, 2007, 10:49 PM   #6
WildPalms
macrumors 65816
 
WildPalms's Avatar
 
Join Date: Jan 2006
Location: Honolulu, HI
Quote:
Originally Posted by legaleye3000 View Post
In Finder, the computer shows up and it automatically connects as guest when I select it and the only folder that it shows being shared is the public folder which contains the drop box.

It will not show a folder on the other computer that I set to share.
Shared using which protocol? AFP? SMB?
__________________
Shiny !
"Yep!..... that went well."
WildPalms is offline   0 Reply With Quote
Old Dec 31, 2007, 11:21 PM   #7
legaleye3000
Thread Starter
macrumors 6502a
 
Join Date: Jul 2007
whatever is default. Both computers are leopard.

Oh and happy new year!
legaleye3000 is offline   0 Reply With Quote
Old Dec 31, 2007, 11:36 PM   #8
NAG
macrumors 68030
 
NAG's Avatar
 
Join Date: Aug 2003
Location: /usr/local/apps/nag
You should have a connect button when you select it in the up right corner of the window.
NAG is offline   0 Reply With Quote
Old Jan 1, 2008, 06:33 AM   #9
legaleye3000
Thread Starter
macrumors 6502a
 
Join Date: Jul 2007
I do have a connect button... It connects as "guest"
legaleye3000 is offline   0 Reply With Quote
Old Jan 1, 2008, 06:37 AM   #10
johny5
macrumors 6502a
 
johny5's Avatar
 
Join Date: Mar 2007
Location: UK
you have to click "Connect as" and then type in the username and password of the account on the Mac that you are connecting to.
johny5 is offline   0 Reply With Quote
Old Jan 1, 2008, 06:54 AM   #11
legaleye3000
Thread Starter
macrumors 6502a
 
Join Date: Jul 2007
How can you make it share the folder for guests? If I want to share a folder as a one-time thing, I don't want to give my password out, etc.
legaleye3000 is offline   0 Reply With Quote
Old Jan 1, 2008, 06:57 AM   #12
johny5
macrumors 6502a
 
johny5's Avatar
 
Join Date: Mar 2007
Location: UK
on the Mac you want to share, go into SYSTEM PREFS, then SHARING.

Make sure FILE SHARING is ticked and then check the options in there for SHARED FOLDERS.
You can add or remove the shared folders and also change the rights for public access.
johny5 is offline   0 Reply With Quote
Old Jan 1, 2008, 07:04 AM   #13
legaleye3000
Thread Starter
macrumors 6502a
 
Join Date: Jul 2007
I did that and I put "everyone" for this one folder I want to share... Still, its not sharing... The other computer will not see it.

Remember, this is connecting as a guest.
legaleye3000 is offline   0 Reply With Quote
Old Jan 1, 2008, 12:28 PM   #14
numlock
macrumors 65816
 
Join Date: Mar 2006
Quote:
Originally Posted by legaleye3000 View Post
I did that and I put "everyone" for this one folder I want to share... Still, its not sharing... The other computer will not see it.

Remember, this is connecting as a guest.
Im having the same problem.

Everyone=Guest right?


I have an imac i want to share folders from and an ibook that im working on. I have no problem adding a new folder in the sharing preferences but the ibook only sees the public folder. Also when i try connecting as the admin of the imac i get that userīs home folder plus the other folder i wanted to share but when i disconnect and want to connect as a sharing only user and i enter that users username and password it still connects as the admin of the imac.

Now i cant even turn of file sharing. System preference just hangs and slows down the entire computer if i try to change something there
numlock is offline   0 Reply With Quote
Old Jan 2, 2008, 03:27 AM   #15
johny5
macrumors 6502a
 
johny5's Avatar
 
Join Date: Mar 2007
Location: UK
Quote:
Originally Posted by legaleye3000 View Post
I did that and I put "everyone" for this one folder I want to share... Still, its not sharing... The other computer will not see it.

Remember, this is connecting as a guest.
Not sure why that is? I have just checked on my shares and I have "Everyone" and also another account called "Guests". This "Guests" account isnt one that I have added and on the small picture icon it shows a picture of 2 heads. If I try and add another "Guests" account access onto a drive that isnt shared then a picture of only 1 head appears.
To me the "Guests" account is a system account that OSX has added on one of my drives, so not sure how to recreate that (sorry I am no expert).
Maybe someone else can help here?

1 other thing I can suggest is in the interim maybe it would be easier to create another generic account as oppose to the "everyone" or "Guests" account and try that?


*edit: just found some more info, you should look in the "Account Prefs" within "System Prefs" it has some information regarding turning on and off "Guest" accounts.

Last edited by johny5; Jan 2, 2008 at 03:33 AM.
johny5 is offline   0 Reply With Quote
Old Jan 2, 2008, 06:39 AM   #16
legaleye3000
Thread Starter
macrumors 6502a
 
Join Date: Jul 2007
The guest account on the computer shouldn't matter...

In Windows, if make a folder a shared folder, EVERYONE can access it.

In OSX, all you should have to do is enable sharing on that folder and everything should be fine...
legaleye3000 is offline   0 Reply With Quote
Old Jan 4, 2008, 02:26 PM   #17
unconcious
macrumors newbie
 
Join Date: Jun 2007
click on "connect as" then type the name of computer you want to connect and password.

It took me a couple of tries before it actually did it but now the problem i am having is connecting to the hardrive that's connect to my airport. It will connect but if the computer goes to sleep I loose the connection and it doesn't seem to want to connect again unless i go into the airport utility and turn off and then on airport.
unconcious is offline   0 Reply With Quote
Old Jan 4, 2008, 02:29 PM   #18
legaleye3000
Thread Starter
macrumors 6502a
 
Join Date: Jul 2007
I don't think some people that are responding are reading the problem I"m having.....

I shouldn't have to click on "connect as" because I want GUESTS to be able to access the shared folders. So there shouldn't be any passwords...
legaleye3000 is offline   0 Reply With Quote
Old Jan 4, 2008, 02:35 PM   #19
Mal
macrumors 603
 
Mal's Avatar
 
Join Date: Jan 2002
Location: Orlando
Go into your System Preferences, click on Accounts, then click on the Guest account. There will be a checkbox that says "Allow Guests to connect to shared folders." Make sure that is checked. If so, anyone who connects as a guest should be able to see any folders that you have placed in your shared folders section in the Sharing pane. You're right that giving Read or Read and Write access to Everyone means they could see it, but you have to enable Guest access to the computer in general first.

jW
__________________
The Bearded Nerd
13" MacBook Pro; 64GB iPod touch
"It's a real burn, being right so often."
NoiseTrade.com/Walker
Mal is offline   0 Reply With Quote
Old Jan 4, 2008, 02:36 PM   #20
bozs13
macrumors regular
 
Join Date: May 2005
Location: Currently Vejle, Denmark / Usually Chattanooga, TN
Send a message via AIM to bozs13 Send a message via MSN to bozs13 Send a message via Skype™ to bozs13
Quote:
Originally Posted by legaleye3000 View Post
I don't think some people that are responding are reading the problem I"m having.....

I shouldn't have to click on "connect as" because I want GUESTS to be able to access the shared folders. So there shouldn't be any passwords...
I feel your pain man...I'm having the same problem as u are having.
__________________
-Layo
bozs13 is offline   0 Reply With Quote
Old Jan 4, 2008, 02:45 PM   #21
legaleye3000
Thread Starter
macrumors 6502a
 
Join Date: Jul 2007
Mal-

I know I have guest enabled, but I'll check on the sharing preference when I get home. Thanks for bringing that to my attention. I'll let you know the result!
legaleye3000 is offline   0 Reply With Quote
Old Jan 4, 2008, 03:56 PM   #22
johny5
macrumors 6502a
 
johny5's Avatar
 
Join Date: Mar 2007
Location: UK
I thought I said this 7 posts up?
johny5 is offline   0 Reply With Quote
Old Jan 4, 2008, 04:04 PM   #23
legaleye3000
Thread Starter
macrumors 6502a
 
Join Date: Jul 2007
Sorry Johny- Must have skipped over it for some reason... Thanks! I'll know in a couple hours if this solves the problem...

So does that mean if I'm telling someone to share a folder with me, I have to tell them to enable guest accounts and guest account sharing? Seems like a pain... I'll give Windows this one... In Windows, you just enable the folder to be shared to whoever (everyone) and that's it.
legaleye3000 is offline   0 Reply With Quote
Old Jan 4, 2008, 04:20 PM   #24
johny5
macrumors 6502a
 
johny5's Avatar
 
Join Date: Mar 2007
Location: UK
No AFAIK you only have to do it on the host Mac

Hope you get it sorted!
johny5 is offline   0 Reply With Quote
Old Jan 4, 2008, 06:24 PM   #25
bozs13
macrumors regular
 
Join Date: May 2005
Location: Currently Vejle, Denmark / Usually Chattanooga, TN
Send a message via AIM to bozs13 Send a message via MSN to bozs13 Send a message via Skype™ to bozs13
Quote:
Originally Posted by Mal View Post
Go into your System Preferences, click on Accounts, then click on the Guest account. There will be a checkbox that says "Allow Guests to connect to shared folders." Make sure that is checked. If so, anyone who connects as a guest should be able to see any folders that you have placed in your shared folders section in the Sharing pane. You're right that giving Read or Read and Write access to Everyone means they could see it, but you have to enable Guest access to the computer in general first.

jW
thanks! Didn't think to look there...it should be easier (or more out there) but thanks! It works now.
__________________
-Layo
bozs13 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Shared Folders Permissions SPCW! OS X 2 May 27, 2014 04:17 PM
All iPads: Any way to access shared folders in PC on Ipad? srkmish iPad 1 Sep 22, 2013 11:05 PM
Can't Connect To Shared Folders Anymore jlin615 OS X 10.8 Mountain Lion 4 Jul 16, 2013 08:21 AM
Shared PC folders on Mac - not working. Analogman Mac OS X Server, Xserve, and Networking 9 Jan 24, 2013 03:57 PM
How to find shared folders on a network? secretpact Mac OS X 10.7 Lion 3 Nov 15, 2012 05:13 PM

Forum Jump

All times are GMT -5. The time now is 07:38 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC