Go Back   MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 1, 2008, 12:42 PM   #1
jplavoie
macrumors newbie
 
Join Date: Jan 2008
Problem connecting Simpletech external drive to macbook

So I just bought a SimpleTech Simple Drive 60gb to use on my MacBook with Mac OS X 10.4.11. I followed the instructions and plugged the Mini-B part of the USB cable in the hard drive and the other end of the USB plug in my MacBook. The instructions tell me I am supposed to see the drive pop up on my desktop but I see absolutely nothing.
Am I doing something wrong?
jplavoie is offline   0 Reply With Quote
Old Jan 1, 2008, 12:46 PM   #2
CanadaRAM
macrumors G5
 
CanadaRAM's Avatar
 
Join Date: Oct 2004
Location: On the Left Coast - Victoria BC Canada
Either the drive is not formatted yet (open Disk Utility on your Mac. Do you see the external drive in your list of devices? If there is nothing on this drive yet, you can Erase (format) it to Macintosh Extended (HFS+) )

Or the drive is not getting enough power from USB and is not spinning up. Did it come with an AC adaptor?

Or the drive is defective.

More detail needed. Can you hear the drive spinning? Is there a light? What happens if you plug it into a different Mac?
__________________
Expert
Ex = former, no longer. Spurt = a leak, esp. when caused by water pressure. Expert = a has-been drip under pressure.
CanadaRAM is offline   0 Reply With Quote
Old Jan 1, 2008, 01:18 PM   #3
jplavoie
Thread Starter
macrumors newbie
 
Join Date: Jan 2008
I cannot find it in the Disk Utility panel, and it did not come with an AC adaptor. The USB cable came with a second USB plug to use as a power source but that made no difference.

When I plug it in, a light turns on on the external drive and I can hear/feel it spin.

I tried plugging it in my home computer which is a PC and it recognized it.

Maybe I should just bring it back to the store?
jplavoie is offline   0 Reply With Quote
Old Jan 1, 2008, 06:08 PM   #4
DataThief
macrumors member
 
Join Date: Jul 2007
Location: Somewere in Washington State
I just bought the 250gb version today, when I plugged it into the left side usb port on my MBP I get the same response as you, I then plugged it into the right side usb port and it came up no problem, TM is now backing up to it. I think that left side port does not supply enough power to run the drive, it does work with mice and my other powered usb drive however.
__________________
Mac Mini 2.26 4GB , MacBook Pro 15", AppleTV2, iPhone 4 iPad
DataThief is offline   0 Reply With Quote
Old Jan 2, 2008, 05:50 PM   #5
jplavoie
Thread Starter
macrumors newbie
 
Join Date: Jan 2008
Ahh I guess the lack of power might explain why it's not working. The only problem is that I only have a Macbook and there are no USB ports on the right side, only the two on the left side. I will try to use an extra power cable and see what happens.
jplavoie is offline   0 Reply With Quote
Old Feb 21, 2008, 07:15 AM   #6
fhprintmkr
macrumors newbie
 
Join Date: Feb 2008
More power, Scottie!

Bottom line... get an external power adaptor (5 VDC, 1.0 A).

I had same problem with my PowerBook G4 and SimpleTech PininFarina 120GB. I purchased a "Universal AC/DC Adaptor" made by some company called XG for $20. US.

The thing that confused me most was that the MAC saw the device, but not the volume. That is, with both the Data/Power and Power-Only USB plugs connected for more power per the instructions (Quick Start guide, a PDF available from their Tech Support site), the System Profiler saw that there was a storage device attached, but the volume did not load and the system did not see the files and directories on it.

Also, the red power light on the drive comes on, but the blue data-read light never shows. This seems to mean there is not enough power to actually run the drive. You can only tell the drive is actually working by the whirring sound it makes, which you would not know since you have not heard it yet.

I was able to figure this out only because I got a new MacMini, and having forgotten the SimpleTech drive did not work on the PowerBook G4, I hooked it up to the Mini and it accessed with no problem. I had earlier thought it was a drive format issue, but once I got it on the MacMini, I was able to format the drive just as the documentation describes.

The power adaptor I got can be switched for different voltages, and had a range of connectors, which included the right size for the SimpleTech. The connectors are separate pieces and attach to a cable coming from the adaptor. The connectors and cable are poorly marked and reversible, so figuring out polarity without risking the drive was a challenge. I used a USB hub I had handy, which had an LED in it. If the LED lit, I knew I had the power supply connector on the cable correctly. The important thing is the power supply be switchable to 5 VDC. My power supply is rated at 2500mA (2.5 Amp), and the drive only draws 1 Amp of current.

I hope this helps.

/Frank.
fhprintmkr is offline   0 Reply With Quote
Old Dec 30, 2009, 11:20 AM   #7
TofuGirl
macrumors newbie
 
Join Date: Dec 2009
nothing works sigh

Well, the light is on demonstrating it has power, and I've tried a couple different USB cords and slot, and my G5 on OSX just can't see the drive. AAAACK!
TofuGirl is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Connecting external drive Rchawks iPad Tips, Help and Troubleshooting 1 Feb 5, 2014 07:54 PM
Problem when connecting external hard drive jasonjamie Mac Basics and Help 10 Nov 7, 2013 10:05 AM
Problem connecting rMBP to external display (HDTV) Benk3350 MacBook Pro 2 Nov 4, 2013 07:16 PM
Connecting thunderbolt drive and external monitor to macbook pro 2011 jph1973 MacBook Pro 1 Jun 13, 2013 12:32 PM
Simpletech External Hard Drive not working on new Macbook Pro battrcake MacBook Pro 2 Aug 13, 2012 08:30 PM

Forum Jump

All times are GMT -5. The time now is 07:46 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC