Go Back   MacRumors Forums > Apple Systems and Services > OS X > Mac OS X Server, Xserve, and Networking

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 10, 2008, 11:07 AM   #1
apt4534
macrumors newbie
 
Join Date: Jan 2008
HELP!! OS X V10.2 server crashed .. does not boot

I posted this in the trouble shooting section aswell but im posting it here since more people seem to be viewing this and im absolutely out of ideas/ options... so please read and help me save my mac from becoming a rather expensive paperweight...

I have a OS X V10.2 server that was running as a mail server at work. it crashed a while ago and we gave up on it. I am trying to revive it. When I try turn it on it gives me the chime and then the grey screen with the apple logo and the little whirring thing at the bottom. after a minute or two in the top left corner i get the prompt sh-2.05a# with the rest of the screen still grey.

I tried fsck and it finds some errors but it says fsck cannot fix errors with disk mounted with write access. i tried to unmount it, it says device is busy.

I have the Mac OS X V10.2 Server Install Disc. Tried holding the option button to choose boot device but it only shows Macintosh HD. I tried holding Command+Option+Shift+Del to force it to find external boot devices but i got zip.

I tried to mount the cd from the sh2.05a# prompt using rdisk0 - rdisk1s9 but i get the error saying Block device required.

from the sh-2.05a# prompt I can ls and see stuff on the hard drive so im thinking the physical hdd is not dead.

I tried running Diskutil but it gives me an error saying cannot start DiskArb.(whatever that means! )

I have tried manually starting the daemons and bootstrap using systemstarter .I get some reaction from the machine with a bunch of lines scrolling up (a bit too fast for me to read) but then it says "waiting for application services" and gets stuck in an infinite loop untill i reboot and return to the sh2.05a# prompt.

I have tried accessing the Open firmware screen and forcing it to mount the cd but it wont.


I dont have access to another Mac. this is pretty much the only one. I dont really care about anything on the machine. I just want to get it up and running... somehow! please please please help!!!!

oh btw im currently downloading the Darwin 8.01 powerPC cdr image. (im going to burn the disc in windows xp... i dont have much hope of the mac actually booting using a disc burned in windows but im desparate! ) I will let you know how that goes...sigh
apt4534 is offline   0 Reply With Quote
Old Jan 10, 2008, 11:29 AM   #2
pezza
macrumors member
 
Join Date: Sep 2007
Try this if you are running this on an xserve, as the usual key combinations do not work..

Follow these steps to initiate a command from the front panel.
1 With the power off, hold in the system identifier button while you press the on/standby
button.
2 Continue holding in the system identifier button until the top row of blue lights blinks
sequentially.
3 Release the system identifier button. The rightmost light in the bottom row turns on.
Press the button to light the next light in the bottom row, moving from right to left.
Press the button again to change lights.
The lights in the bottom row indicate (from right to left):
• Light 1 (far right): Start up from a system disc in the optical drive (on a system with
an optical drive). This also ejects any disc already in the optical drive.
• Light 2: Start up from a network server (NetBoot)
• Light 3: Start up from the internal drive (leftmost drive if more than one)
• Light 4: Bypass the current startup disk and start up from any other available startup disk.
• Light 5: Begin target disk mode (all drives, including the optical drive, will show up)
• Light 6: Restore the system’s default settings (reset NVRAM)
• Light 7: Enter Open Firmware (via the serial port if no monitor and keyboard are
connected)
4 When the light for the action you want is on, hold in the system identifier button for at
least 2 seconds, until all lights in the top row are on.
5 Release the button.
pezza is offline   0 Reply With Quote
Old Jan 10, 2008, 11:42 AM   #3
apt4534
Thread Starter
macrumors newbie
 
Join Date: Jan 2008
thank you for your reply ! you'll have to excuse my ignorance ( im a bit of a newbie with macs )

I dont think its an xserve (i'm assuming that xserve is a type of sever ) because i dont see any system identifier button or row of blue lights. ( do i have to open it up to see these? ) I looked on the back of the box and it says its a Power Mac G4. The disc i have with me says Mac os x server version 10.2 Install Disc
apt4534 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > Mac OS X Server, Xserve, and Networking

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
10.5 Server - Average boot time? nimraynn PowerPC Macs 2 Dec 19, 2013 04:01 PM
Mac OS X Server v10.5.8 / Promise Vtrak E-Class Server jah6719 Mac OS X Server, Xserve, and Networking 18 Apr 30, 2013 02:18 PM
Configuring ical Server (Mac OS X V10.6.8) nwachi OS X 0 Sep 27, 2012 09:26 AM
Mountain Lion Install Process Crashed my rMBP - Now it won't boot... jlevi OS X 10.8 Mountain Lion 17 Jul 31, 2012 02:52 PM
Can't launch glassfish server at boot Leslie.Hon Mac OS X Server, Xserve, and Networking 2 Jul 23, 2012 06:16 AM

Forum Jump

All times are GMT -5. The time now is 12:14 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC