Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Applications > Mac Applications and Mac App Store

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 21, 2008, 09:36 AM   #1
prasenberg
macrumors newbie
 
Join Date: Jan 2008
Safari not loading some pages

I have a weird problem with Safari that has been bugging me. At seemingly random times it doesn't load a page. Usually it is the second page of a website I visit. This means that the homepage (www.cnn.com for example) loads fine. But when I click on a link on the page (to go to sports or politics), it starts loading and then does nothing. Like this:



The New York Times often doesn't load at all. I have no problems at all with some other sites, like wikipedia or Macrumors. Firefox and Camino do not have these problems.

The problem started when I was still running Tiger and Safari 2 on my MacBook. I since started using a MacBook Pro and moved all my data and settings with the Migration Assistant. The MacBook Pro runs Leopard, but Safari 3.0 has exactly the same problem as Safari 2 had on my Macbook. I tried the following:

- repair permissions
- removed all cookies and set my preferences to accept all cookies
- cleared cache
- manually removed the .plist-files for Safari from the Library

All to no avail. When I log in using the built-in Guest Account on my MacBook Pro, Safari runs fine.

Any suggestions are very welcome, as I really like Safari. I prefer it over both Firefox and Camino.
prasenberg is offline   0 Reply With Quote
Old Jan 21, 2008, 09:42 AM   #2
clevin
macrumors G3
 
clevin's Avatar
 
Join Date: Aug 2006
does "reset" help?

just to be sure, firefox has no such problem for you?
clevin is offline   0 Reply With Quote
Old Jan 21, 2008, 09:45 AM   #3
prasenberg
Thread Starter
macrumors newbie
 
Join Date: Jan 2008
I tried reset, but the problem persists. Yes, Firefox runs fine, as do all other browsers. Safari also runs fine when logged in with the Guest Account.
prasenberg is offline   0 Reply With Quote
Old Jan 22, 2009, 12:52 PM   #4
clarkt
macrumors newbie
 
Join Date: Jan 2009
Confirmed!

I'm seeing the same issue. I've swapped out firewall/router, reset switches, changed DNS, etc.

All with the same results.

Firefox works fine.
clarkt is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Applications > Mac Applications and Mac App Store

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Loading individual images in stopped Safari pages? The Phazer Mac Basics and Help 0 May 9, 2014 12:52 PM
Safari not loading medavidcook iMac 4 Mar 22, 2013 07:52 AM
iPhone not loading web pages over wifi Xaximus iPhone Tips, Help and Troubleshooting 1 Oct 29, 2012 08:53 AM
Airport Extreme pausing while loading pages jjk454ss Mac Peripherals 4 Aug 12, 2012 02:31 PM

Forum Jump

All times are GMT -5. The time now is 04:39 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC