Go Back   MacRumors Forums > Apple Hardware > Notebooks > MacBook

Reply
 
Thread Tools Search this Thread Display Modes
Old Mar 11, 2008, 07:26 PM   #1
mikepow2001
macrumors newbie
 
Join Date: Mar 2008
How do I make my wireless router the default network?

Tried googling this with no luck. I'm new to the mac/laptop world. My new mac keeps picking my neighbor's network over mine. It (obviously) fails to connect to the neighbors router coz password is required. I then have to scroll down a list of networks and instruct my computer to connect to my router. Is there a way to simplify my life...Guys I need your HELP!!!!!
mikepow2001 is offline   0 Reply With Quote
Old Mar 11, 2008, 07:28 PM   #2
flopticalcube
macrumors G4
 
flopticalcube's Avatar
 
Join Date: Sep 2006
Location: In the velcro closure of America's Hat
On the Airport icon in the menu bar select Open Network Preferences... then click on Advanced in the lower right hand corner. Remove your neighbors network from there.
flopticalcube is offline   1 Reply With Quote
Old Mar 11, 2008, 07:33 PM   #3
TEG
macrumors 604
 
TEG's Avatar
 
Join Date: Jan 2002
Location: Langley, Washington
Send a message via ICQ to TEG Send a message via AIM to TEG Send a message via MSN to TEG Send a message via Yahoo to TEG Send a message via Skype™ to TEG
Open the Network Preference Pannel, select Airport. Change the network connection setting to preferred networks, then make sure your network is at the top of the list, by just dragging it.

TEG
__________________
Apple and Dell are the only ones in this industry making money. They make it by being Wal-Mart. We make it by innovation, - Steve Jobs
The Tegian Zone-Glass Onion Radio
TEG is offline   1 Reply With Quote
Old Mar 17, 2008, 02:07 PM   #4
Killerbob
macrumors 6502a
 
Join Date: Jan 2008
I am having similar problems on my Mac Air.

I have two WiFi networks in the house, plus the countless others from neighbors. I have done as prescribed: set up my two WiFi networks, they are the only two on the "preferred networks" list, and I only have the Airport turned on, and it all works when I select my primary network. It has all the passwords etc. memorized. However, when I put the Air to sleep, and eventually wake it up again, it asks what network I want to join? Every time!

How do I configure it to remember the primary network, and always log into it?

TIA

KB
__________________
nMP 3.5GHz 6C/64GB/1TB/D700s - Echo Express 1TB Accelsior/2x500GB Sonnet Tempo - MBP 13"/3GHz i7/16GB/512GB - MBA 13"/2GHz i7/8GB/250GB - MMI 2.3HGz/8GB/500GB - TC 3TB - ReadyNAS Pro 6x3TB
Killerbob is offline   0 Reply With Quote
Old Mar 18, 2008, 10:47 AM   #5
mikepow2001
Thread Starter
macrumors newbie
 
Join Date: Mar 2008
Thanks guys. I knew there had to be an easier way...LOL. What a relief!!!
mikepow2001 is offline   0 Reply With Quote
Old Sep 1, 2009, 04:05 PM   #6
jpvand1
macrumors newbie
 
Join Date: Sep 2009
Same problem.
The solutions given so far aren't doing the trick. I'm in a college apartment complex and everyone has wifi, so each time I open the macbook it lands on a different network. I've tried to remove them from the list of "preferred" but to no avail.

Anyone got an idea?

Thanks!
jpvand1 is offline   0 Reply With Quote
Old Sep 2, 2009, 01:56 PM   #7
capps
macrumors member
 
Join Date: Feb 2008
Location: 127.0.0.1
In the network preferences there is an option to not connect to "open" networks, this will prevent it from finding the first "linksys" or "netgear" and connecting to it. Next, go into your list of preferred networks and clear it out. Now, select your network and type in your password. Tell it to remember that network.
capps is offline   0 Reply With Quote
Old Jun 14, 2011, 05:44 AM   #8
duanemsmith
macrumors newbie
 
Join Date: Jun 2011
Ask to join new networks

I tried all of the good suggestions here, however I still had the same problem as jpvand1. That is because even though I have setup my list of preferred networks and even established my order of preference, Airport will still seek out other new networks within range thinking that I may want to connect to another stronger network, which is not what I want to do. I want to connect to my preferred home WiFi network whilst still being able to connect to other preferred WiFi networks or other public WiFi networks. I finally figured out how to do this and it was quite simple as I missed something basic because the option was not completely clear to me. I have my Network Name set to my home network called 'NETGEAR' and 'Ask to join new networks' ticked or selected. I did not unselect this as I thought I would not be able to browse other WiFi or wireless networks. However, with this option un-checked (un-selected) I now can see all networks close by and my MacBook knows to connect to my Network Name and will also connect to my other preferred networks in order of preference. Finally, if I do want to connect to another unknown WiFi connection I can manually select it an provide the appropriate credentials. Thanks all
duanemsmith is offline   0 Reply With Quote
Old Jun 14, 2011, 05:48 AM   #9
ratzzo
macrumors 6502a
 
ratzzo's Avatar
 
Join Date: Apr 2011
Location: Madrid
For future configuration, remember that the list works as a queue system. The computer will try connecting to the first one first, else the second, and so on.
__________________
15" MBP | Nexus 4 | iPad 4
ratzzo is offline   0 Reply With Quote
Old Sep 3, 2011, 02:08 PM   #10
emorrisiv
macrumors newbie
 
Join Date: Sep 2011
wireless default

You can go into the advanced area of the wireless tab, you should see a list of all you previous wireless networks. Drag your favorite to the top. This should make it the default.
emorrisiv is offline   0 Reply With Quote
Old Oct 21, 2012, 06:22 PM   #11
Wabuf
macrumors newbie
 
Join Date: Oct 2012
Location: Northeast Ohio
Send a message via Skype™ to Wabuf
Lightbulb Possible Wifi Solution

Hey guise,

This is my first post here at MacRumors. I registered just to let you all know of what solved my problem. Also, the problem is surrounding my very first piece of Apple hardware: MacBook Pro Retina 15".

Symptom:
Upon every wake, prompted with preferred networks screen (had to manually select my 'linksys' connection every time).

Solution:
What fixed it for me? After going into [Apple Logo Menu] > System Preferences > Network > Advanced..., I realized that the 'linksys' network on that list was not secured (i.e. Security: Open). However, my router requires a WPA key. So I removed that 'linksys' Open connection and manually added it again with the Plus [+] button. I dragged it up to the top, clicked OK and Apply. Finally, I tested it out by putting the laptop to sleep and waking it back up. To my great satisfaction, I was automatically connected with no sign of that prompt!


Really hope this solves others' issues. It may not fix everyone's automatic network detection problems, but it should do the trick .. had your Mac learned your network without a key or possibly a key has been changed.
Wabuf is offline   0 Reply With Quote
Old Jul 29, 2013, 05:34 PM   #12
Keinding
macrumors newbie
 
Join Date: Jul 2012
Hey hey!

Got the same problem, all the solutions here didn't seem to fix it.. then I just tried all the option in the Network preferences and ended up fixing it..

so If nothing here helped you, give it a try:

erase your network from the preferred networks list
in the Network Preferences at the bottom is an "assist me" button. go through it, in the end it asks something like "do you wanna remember this network" or something like that...

and that's that!

Cheers!
Y
Keinding is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Notebooks > MacBook

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Can I make HD default on YouTube? dewjack Digital Video 4 Apr 24, 2014 04:51 PM
Slow 5ghz network via extended wireless network groovyf Mac Peripherals 1 Feb 25, 2014 07:45 PM
Is there a way to save a network as a default Weerez935 OS X 10.8 Mountain Lion 2 Mar 1, 2013 08:50 AM
Airport extreme: Wireless network within a wireless network brsboarder Mac Peripherals 0 Jun 27, 2012 06:49 PM
Time Capsule in addition to wireless router already on the network keviig Mac Basics and Help 2 Jun 11, 2012 07:10 AM

Forum Jump

All times are GMT -5. The time now is 07:08 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC