Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Notebooks > MacBook

Reply
 
Thread Tools Search this Thread Display Modes
Old Aug 1, 2008, 10:32 AM   #51
JML42691
macrumors 68020
 
JML42691's Avatar
 
Join Date: Oct 2007
I have this problem to, but it also is an issue with all other wifi devices in the house (Macs and PCs). For me for the longest time the only way to fix it is by restarting the router, so I do not feel that this is related to the MacBook specifically. One thing I ended up realizing is that enabling MAC address filtering on my router solved the problem, and made access to my router more secure on top of the WPA password.
JML42691 is offline   0 Reply With Quote
Old Aug 5, 2008, 11:30 PM   #52
me_94501
macrumors 65816
 
me_94501's Avatar
 
Join Date: Jan 2003
Quote:
Originally Posted by me_94501 View Post
IK noticed yesterday that mmy connection issues started after my MacBook was unplugged when it had previously been powered by the AC adapter. Here's what happened to me today:

I connected to the office wireless network while on battery. I then plugged my MacBook in. Later in the day, I unplugged it and walked around with it. At this point, the MacBook dropped the connection and had connection timeout issues. So I unplugged it, shut it down, and started it up again while unplugged. It reconnected and behaved the rest of the day regardless of whether it was plugged in or not.

I'll have to see if this was just a coincidence or whether I'm actually on to something, though.
Yup, it was just coincidence as far as I can tell. The problem occasionally strikes at home, but it amounts to a fairly minor annoyance. At work, though, it's constant, and a major impediment to productivity.
__________________
Let's Go A's!
me_94501 is offline   0 Reply With Quote
Old Aug 7, 2008, 04:23 AM   #53
Slz
macrumors newbie
 
Join Date: May 2008
I realize this issue is symptomatic to a large number of different problems. It's pretty hard to diagnose.

But once again, if you've done all the above tips and tests and that your mac is behaving similarly with any kind of access point. You'll save yourself a lot of time and send it to apple. Or buy a new airport card and install it yourself if you prefer.
(I bought mine in Ebay for 19 USD)
Slz is offline   0 Reply With Quote
Old Aug 7, 2008, 11:12 PM   #54
me_94501
macrumors 65816
 
me_94501's Avatar
 
Join Date: Jan 2003
Quote:
Originally Posted by Slz View Post
I realize this issue is symptomatic to a large number of different problems. It's pretty hard to diagnose.

But once again, if you've done all the above tips and tests and that your mac is behaving similarly with any kind of access point. You'll save yourself a lot of time and send it to apple. Or buy a new airport card and install it yourself if you prefer.
(I bought mine in Ebay for 19 USD)
Considering how much I rely on my laptop, I will only send it in to Apple as a last resort. I do have another hard drive laying around with a Tiger install, though. I'm pretty certain this is a software issue I'm experiencing, not a hardware issue, but I'd like to use another OS to confirm.

Oddly enough, my WiFi connection at work has been behaving the last couple days...
__________________
Let's Go A's!
me_94501 is offline   0 Reply With Quote
Old Dec 7, 2008, 05:07 PM   #55
radii
macrumors newbie
 
Join Date: Dec 2008
Smile Solution is to restrict wireless access to known clients

Hi

I have a MBP 17" 2.5 running 10.5.5 OS X. My router is a WAG354G and I too have had this maddening Connection timeout problem.

I noted it seemed to occur every couple of days or so. My first attempted solution was to change DHCP lease and other similar items to 0 (ie unlimited I assume) or 9999. This did not work.

I saw a suggestion in my search to restrict wireless access to the Macs/PCs required only. Go to the Wireless tab ---> Access and look for a list of clients. Choose "restrict" access only to a list of clients and copy and paste the MAC addresses of all iPhones/PCs/Macs etc. to the list.

I have had no connection timeouts since bar once when it was the DSL connection that was down and even in this instance I could still surf wirelessly to the router and see that the DSL status was "down".

Problem solved I believe.

Comments welcome.
radii is offline   0 Reply With Quote
Old Dec 7, 2008, 06:03 PM   #56
Solemony
macrumors 6502
 
Join Date: Nov 2008
Location: Wonderland
Quote:
Originally Posted by Bobioden View Post
Really? This is the first I have heard of this problem. Mine in connected to a network 24 hours a day, it is very rarely shutdown, it just goes to sleep, and I wake it when I need to use it. I have never encountered this problem.
I never have this problem before and my first time hearing about this...hmm strange
Solemony is offline   0 Reply With Quote
Old Dec 8, 2008, 04:34 AM   #57
VagabondMuse
macrumors newbie
 
Join Date: Dec 2008
See also discussion here.

I got some improvement by changing the channel the router was using and by switching security to WPA only (instead of WEP and WPA). I couldn't switch to WEP only because a Vista computer on the network doesn't seem to be able to use WEP.

Hope this helps.
VagabondMuse is offline   0 Reply With Quote
Old Dec 12, 2008, 11:28 PM   #58
Mike Teezie
macrumors 68020
 
Mike Teezie's Avatar
 
Join Date: Nov 2002
I'm having this problem with my Macbook Pro (Penryn) now, and it's driving me insane.
Mike Teezie is offline   0 Reply With Quote
Old Dec 18, 2008, 01:15 AM   #59
me_94501
macrumors 65816
 
me_94501's Avatar
 
Join Date: Jan 2003
What's strange is that this problem has mostly cleared itself up for me. I run into it once in a blue moon still, but it's nowhere near as frequent as it used to be (where it would crop up several times a day).
__________________
Let's Go A's!
me_94501 is offline   0 Reply With Quote
Old Dec 20, 2008, 09:24 AM   #60
EricLeamen
macrumors member
 
Join Date: Dec 2008
Location: Toronto, ON
Wink The fix is here!

I had this same problem, and I found the fix!

Problem: Your MacBook connects to wireless internet for a while, then you receive a "connection timeout" error. Rebooting your modem seems to help for a while, but connection times out again a few minutes later.

Solution:
-Configure your access point to allow both WPA and WPA2, WPA-PSK, or WPA only.
-Configure your access point to use AES encryption only instead of TKIP.
-Configure your Mac(Book) to use WPA instead of WPA2.

To Configure Your Mac:
-System Preferences
-Click Airport
-Select the access point you want to configure and click Advanced
-On the Airport tab, once again select the network you want to configure and click the "Edit" (pencil) icon.
-Change security from WPA2 Personal to WPA Personal
-Click Add to save changes (network name should now display WPA Personal beside it)
-Click OK
-Click Apply

Let me know if this works for you! It works great for me and I was so pissed before so I feel your pain!
EricLeamen is offline   0 Reply With Quote
Old Jan 13, 2009, 07:51 PM   #61
Xaixis
macrumors newbie
 
Join Date: Jan 2009
I have the same problem, but it seems like no matter what I do nothing ever works!

I have tried to get help with my own thread which has a list of some of my computer stats and what-not. I'm really mad because I really have no clue what happened! Working one minute and then all of a sudden it decided not to work.... Will this go away with time? And has anyone recieved any kind of help from Apple?

(My post with my router info and computer)
Quote:
Originally Posted by Xaixis View Post
Hey guys, this is my first post here so I'm sorry if this is in the wrong place or something.

Anyways, I've had my macbook for a good month or two without any problems. I have a refurbished macbook white (got it for around 850$) and so far I've been happy as a clam. It has a 2.1Ghz intel core 2 duo processor and I am currently running 10.6.

My router is Linksys (v2.02.2) and I am on a WEB 1828-bit encryption 26 hex digits

So now would be the first problem and I'm kinda scared because I'm not sure if it's the hardware's fault, program, w/e.

For awhile my internet was great, I got iterally full connection around the whole house. But then suddenly when I was downloading a movie (no not pirating, it was a free documentary) it suddendly crapped out and then disconnected. (I have downloaded quite larger files before with no problem... this is the first time I've had this problem. When ever I try connecting to the internet it gives me the "connection timeout"
IMAGE --> http://bb.xieke.com/files/screen-capture.png

So I do everything I can but no avail so I look around online with pretty much no help. So I'm kinda worried now because I'm not sure if this is temporary or what. I really don't have a whole lot of money to dish out on repairs and I literally just bought this thing about 2 months ago so I will be really mad if the airport died or something (which I don't think it has because I get 1 or 2 bars every now and then... won't connect to internet though)


PLEASE help guys! I'm really getting worried for my new mac!
Xaixis is offline   0 Reply With Quote
Old Jan 23, 2009, 03:59 AM   #62
lupark
macrumors newbie
 
Join Date: Jan 2009
what worked for me...

This was a mac filtering issue for me. My router (2wire 2700HGV) stored my mac address as the hostname of my machine. I triple boot my machine and have gone through lots of different operating systems on it so I think the router had stored dozens of different hostnames associated to the same mac address. I hard reset my router, removed any security and turned the mac filtering back on and all seems fine.
lupark is offline   0 Reply With Quote
Old Mar 19, 2009, 12:35 AM   #63
metasailor
macrumors newbie
 
Join Date: Mar 2009
I don't know how or why, but this fixed it for me.

I was going nuts trying to figure out the problem. Macbook pro 2.6, 10.5.6, just had an update, wifi connection stopped working. I could see the wireless network, and try to join it - but connection would just timeout. Same password that was working previously, and nothing else was changed either.

Reinstalled the circa 2007 drivers for my Linksys WRT150N - nothing.

All this time I was scratching my head, and trying to log into the wireless network via the "Airport" icon in the top right of the Macbook's menu bar.

Finally I just happened to try to configure Airport from within the preferences panel instead. I turned off Ethernet (not using it), Firewire for networking (not using that), and selected the *exact same* password as I had via the upper right menu bar - and suddenly it connected, no problem.

Was it turning off the ethernet stuff? Was it something else? No idea. It's working now, so that's good enough for me.
metasailor is offline   0 Reply With Quote
Old Mar 21, 2009, 07:22 AM   #64
savvas
macrumors newbie
 
Join Date: Feb 2009
Emm yeah?

look i had the same prob last night... i was with a friend and i was on my macbook pro and it was tottaly ok today i had a project to do i searched in the internet for information and was totally fine... but about 10 min ago my mac after sleeping could connect to my network it searched for networks and it was there but when i put the password said connection timeout and i was what???
i was tottaly in range and the password was correct

after reading this forum i decided to check again and i entered my password and vouala there it is!!!

Can you tell me why now is ok?
Thank you for the luck:P
savvas is offline   0 Reply With Quote
Old Mar 21, 2009, 12:39 PM   #65
radii
macrumors newbie
 
Join Date: Dec 2008
Quote:
Originally Posted by radii View Post
Hi

I have a MBP 17" 2.5 running 10.5.5 OS X. My router is a WAG354G and I too have had this maddening Connection timeout problem.

I noted it seemed to occur every couple of days or so. My first attempted solution was to change DHCP lease and other similar items to 0 (ie unlimited I assume) or 9999. This did not work.

I saw a suggestion in my search to restrict wireless access to the Macs/PCs required only. Go to the Wireless tab ---> Access and look for a list of clients. Choose "restrict" access only to a list of clients and copy and paste the MAC addresses of all iPhones/PCs/Macs etc. to the list.

I have had no connection timeouts since bar once when it was the DSL connection that was down and even in this instance I could still surf wirelessly to the router and see that the DSL status was "down".

Problem solved I believe.

Comments welcome.
Update: Absolutely no problems since my previous post above. I have since upgraded the WAG354g firmware twice whilst keeping the MAC filtering intact (now using Neptune firmware) which has, to my surprise, improved sustained sync speeds but, more importantly, not resulted in any return to the wireless conection timeouts.
radii is offline   0 Reply With Quote
Old May 1, 2009, 01:34 AM   #66
tj macs
macrumors newbie
 
Join Date: May 2009
I faced the 'connection timeout' issue on my intel core 2 duo macbook pro recently, using an airport extreme base station. In addition to my mbp, I also had a mac mini and a windows pc connecting to the base station. Everything worked fine for months, and then, seemingly out of the blue, the mbp couldn't find the base station, or if it could, it gave me the 'connection timeout' error and couldn't connect (and yet both the mini and the pc could!)....I tried everything -- hard resetting the AEBS, changing WPA to WEP, changing the password, renaming the network....I even goofed around with the network kernel files on my mbp until I sufficiently buggered things up and decided to completely reinstall OSX on the macbook pro (which also didn't work, btw)! Finally I found a solution which seems to work swimmingly, so I hope this fix will save some people out there a lot of precious time and frustration:

1) Open Airport Utility

2) Click on 'Manual Setup'

3) select the 'wireless' tab (at the top where you can choose from 'summary', 'base station', 'wireless', and 'access control')

4) On this screen, it allows you to select the channel. By default, the option here is set to 'automatic'. From the drop-down, I randomly selected a specific channel (in my particular case, I chose channel 7).

5) In the bottom right, click 'update'

6) Now try to get your maccy to find and connect to your network once more. TA-DA! Everything now appears to connect to the base station. You may have to play around with different channels, but so far, all 3 of my computers are able to communicate with the AEBS with no apparent problems. Hope this works for you!
tj macs is offline   0 Reply With Quote
Old May 3, 2009, 06:08 PM   #67
AnEnderFan
macrumors newbie
 
Join Date: May 2009
Location: Greensboro, NC
I have the connection time out problem, too, but it's doesn't affect my eMac. My eMac (not a notebook, obviously) has a wireless card but I connect though the Linksys via a cable for my clearwire to work better. So, when there is a time out, it doesn't matter there; I'm connected with the cable. The problem lies with my non-Mac wireless notebook that relies on the connection thru my eMac that I play WoW on (got it cheap). I thought the issue was with Clearwire. Guess not. Seems as though it's either Mac or Linksys related. It is becoming a real issue. One second I am playing, the next second I'm off line. Very frustrating. Doesn't pick the best time to go off. I'm sure my fellow WoWers can relate to that. I am not very computer savvy to fix this problem, but it seems that the people that are, can't fix it either. It seems like Mac, being the company that it is, should step up and find a solution!
AnEnderFan is offline   0 Reply With Quote
Old May 3, 2009, 06:39 PM   #68
AnEnderFan
macrumors newbie
 
Join Date: May 2009
Location: Greensboro, NC
There are two suggestions I would love to try but can't find where to go.

tj macs: you say, "open Airport Utility". Where might that be?

radii: you say "go to wireless tab". Where might that be?

Again, I am not computer savvy.



NOTE: My computer is also not a laptop.

Last edited by AnEnderFan; May 3, 2009 at 06:52 PM.
AnEnderFan is offline   0 Reply With Quote
Old Jul 1, 2009, 05:30 PM   #69
bjcnz
macrumors newbie
 
Join Date: Jul 2009
AnEnderFan I know this is a late reply but aah well. AirPort Utility TJ talked about is the program on a mac used to set up Apples Wireless Express or Extreme... So its only a program you have if you use Apples Wireless Network. I have this same problem and its pisssssssing me off sooo much! Grrr! And I can tell you all its not a problem with the router, I believe its a bug in the software that WAS supposed to be fixed with 10.5.5 but 10.5.7..... and to avail, still getting the same issues, I've sworn so much at my mac today lol uh ooh
bjcnz is offline   0 Reply With Quote
Old Jul 26, 2009, 08:58 AM   #70
nick79
macrumors newbie
 
Join Date: Jul 2009
Solution that worked for me

Greetings,

This solution worked for me. I rang apple they gave no help. Just kept saying: Cordless phones give interference, even though my 4 year old laptop worked fine with wireless as well as my ps3. I searched everywhere on the internet, a few things fixed it

1. I made sure my router was set to DHCP so that it sent ip addresses to any device trying to connect to it.

2. I went to network>airport>advanced then clicked tcp/ip settings tab and selected DHCP under the drop down under config ipv4. Clicked ok apply settings and what not.

3. I Went to my router and set the dhcp to send ip addresses from 10.1.1.2 to 10.1.1.8 or something like that. Before that it was set to send only ip addresses between 10.1.1.2 and 10.1.1.254.

This fixed it anyway. I Also deleted the keychain values like others suggested. But so far no one has suggested to change the dhcp address settings on the router which is what i think fixed it.

Even though i spoke to apple and told them that it must be a setting or something, i am getting signal just not an ip address, they still thought it was my cordless phone. How stupid. Obviously theres a problem with leopard not doing this automatically,like my ps3 does..???.. I just bought this too after having a pc...

Anyway, I hope this fixes it for some people, i tried everything else but only this worked.
good luck.
nick79 is offline   0 Reply With Quote
Old Aug 1, 2009, 12:32 PM   #71
slippage
macrumors newbie
 
Join Date: Aug 2009
The fix for me

Quote:
Originally Posted by skye12 View Post
Make sure the automatic connect option is unchecked on ethernet
connection. Simple, but it was what was disconnecting me from the internet
after switching to wireless.
This worked (though it wasn't a check it was a drop down menu option at the top of the network preferences page). I was receiving lots of timeout errors when trying to connect to the router that my other mac book was successfully using (the problem was with my gf's comp). I was even getting crazy responses like "incompatible security". Occasionally I would be able to connect and would show up in the dhcp client list on my router but it would be so slow it couldn't even log me in to gmail. I guess I switched the connection to automatic while troubleshooting something else and when I set it to a static one that I added it fixed everything immediately. Why would the automatic option be such a huge failure?
slippage is offline   0 Reply With Quote
Old Aug 1, 2009, 12:50 PM   #72
teckwiz
macrumors newbie
 
Join Date: Mar 2008
Me Too

I Also had this problem the solution for me was very simple, put a dollar sign in front of the wep key for instance
Wep key:
$fsfsgff8e7847745hiurhgdhg
teckwiz is offline   0 Reply With Quote
Old Aug 1, 2009, 05:33 PM   #73
akamyster
macrumors newbie
 
Join Date: Aug 2009
Talking

hey just as an fyi i had the exact same problem not to long ago and all i did was reset my d-link router. then everything worked perfectly fine again. hope this helps
akamyster is offline   0 Reply With Quote
Old Nov 10, 2009, 07:05 PM   #74
le sacre
macrumors regular
 
Join Date: Apr 2004
Location: sf, ca, usa
faulty airport card?

i'm having the same kind of issue on my MBP. the timing seemed to correspond precisely with upgrading to snow leopard, but i'm beginning to suspect that was coincidence and it's really just that my airport card has become faulty (the whole machine has really been kind of a lemon).

ping keeps losing packets, and the most recent behavior has been that the ping times increase dramatically before timing out entirely--i remain connected to the network but no traffic goes through. sometimes it comes back after a long while, but usually not. i can always fix it (for a while) by restarting, and usually by turning airport on and off a few times. but increasingly, when i start airport, it connects, manages to send a few packets, and then fails, and then sometimes loses the connection to the router entirely. after that happens, it often can't see any networks for several moments (0 networks in the menu down from like 20). on several occasions at this point System Preferences crashes (that can't be good, right?), and a couple of times the whole system has crashed.

representative messages from console (not necessarily in order):

ntpd[30] sendto(17.151.16.20) (fd-24): No route to host
airportd[1413] Apple80211Associate() failed -3905 (Timeout)
kernel apple80211Request[7097] Unsupported ioctl 87
named[78] /etc/com.apple.named.conf.proxy:21: no forwarders seen; disabling forwarding
mDNSResponder[19] setsockopt - IP_MULTICAST_IF error 169.254.29.152 -1 errno 49 (Can't assign requested address)
Apple90211 framework[1389] airportd MIG failed (Associate Event) = -3905 (Timeout) (port = 18703)

this happens with at least two different routers, and does not affect my old powerbook or my ipod touch, so i'm sure it's my MBP. i have not found anyone anywhere mentioning a "apple80211Request[7097] Unsupported ioctl" message. can anyone explain its relevance?

i've tried all the above suggestions except that i can't change settings on the two routers, since i don't have those access privileges. problem has persisted through the latest system update (to 10.6.2). i think i may simply need to replace my airport card (AirPort Extreme (0x168C, 0x87), firmware Atheros 5416: 2.0.19.4).

anyone still watching this thread?
__________________
15" 2.4GHz SR MBP ('07)/ 4GB / 160GB 7200rpm
le sacre is offline   0 Reply With Quote
Old Jan 5, 2010, 12:25 AM   #75
rutia
macrumors newbie
 
Join Date: Jan 2010
I had kind of this problem and in my case,

System Preferences -> Network -> AirMac -> TCP/IP
then Configure IPv6 to Auto or Off.

'cause, these cats are always request to AAAA(IPv6) first, I think. and If your router does not support IPv6 or disabled it, she'll be confused.

I hope it will help you.
rutia is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Notebooks > MacBook

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Airport Connection Timeout jdsunshine Mac Basics and Help 1 Jul 28, 2013 12:34 AM
Connection timeout ecvaughn MacBook Pro 1 Jun 13, 2013 05:39 PM
MacBook Air: Connection Timeout Help. ZeroForce Mac Basics and Help 0 Nov 29, 2012 07:58 PM
Connection Timeout? maccingout MacBook Pro 0 Sep 21, 2012 02:19 PM
Wifi connection Timeout ReservedName Mac Basics and Help 0 Jun 29, 2012 05:29 PM

Forum Jump

All times are GMT -5. The time now is 06:35 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC