Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > OS X

Reply
 
Thread Tools Search this Thread Display Modes
Old May 17, 2008, 01:37 PM   #1
Eric Lewis
Banned
 
Join Date: Feb 2007
Location: CANADA? eh?
Copy/ Paste...Not working?

I try command + c or v and it doesnt want to copy or paste anything

also right click in itunes doesnt work?

What can i do to fix this?
Eric Lewis is offline   0 Reply With Quote
Old May 17, 2008, 01:48 PM   #2
andrewm
macrumors regular
 
Join Date: Apr 2004
Quote:
Originally Posted by Eric Lewis View Post
I try command + c or v and it doesnt want to copy or paste anything

also right click in itunes doesnt work?

What can i do to fix this?
Hi, there, Eric. Can you give us a little more information about your setup? For instance, and very importantly, what version of Mac OS X are you using, and what sort of computer (processor and configuration) do you have? Also, importantly, are you using *any* haxies of any sort? Application Enhancer? Pith Helmet? Logitech Control Center?

Did you set up your system with an erase-and-install, an archive-and-install, or did you simply install over an earlier system? Or did your computer come with the system that you are currently using?

Cheers,
Andrew
andrewm is offline   0 Reply With Quote
Old May 17, 2008, 02:04 PM   #3
Eric Lewis
Thread Starter
Banned
 
Join Date: Feb 2007
Location: CANADA? eh?
Quote:
Originally Posted by andrewm View Post
Hi, there, Eric. Can you give us a little more information about your setup? For instance, and very importantly, what version of Mac OS X are you using, and what sort of computer (processor and configuration) do you have? Also, importantly, are you using *any* haxies of any sort? Application Enhancer? Pith Helmet? Logitech Control Center?

Did you set up your system with an erase-and-install, an archive-and-install, or did you simply install over an earlier system? Or did your computer come with the system that you are currently using?

Cheers,
Andrew
Its a 2.0ghz iMac 2gb ram, aluminum

running 10.5.2..did upgrade back in november

suddendly this morning it stopped working

no enhancers or anything like that
Eric Lewis is offline   0 Reply With Quote
Old May 17, 2008, 04:59 PM   #4
andrewm
macrumors regular
 
Join Date: Apr 2004
Quote:
Originally Posted by Eric Lewis View Post
Its a 2.0ghz iMac 2gb ram, aluminum

running 10.5.2..did upgrade back in november

suddendly this morning it stopped working

no enhancers or anything like that
Hi, Eric,

Someone else posted a similar issue without a solution here. Also, I have seen reports of Apple's Mighty Mouse suddenly stop working -- but (a) you might not have a Mighty Mouse, and (b) that doesn't explain the probably-not-coincidental timing.

Someone also posted a video on YouTube reporting the same problem. I may be missing something obvious, but I have no good suggestion here; your best bet may be to (gulp) reinstall the system. Be sure to do an "archive and install" or (if you're daring) an erase-and-install. Installing over an older system without archiving first is likely to make your life miserable, from the reports that I've seen.

Cheers,
Andrew
andrewm is offline   0 Reply With Quote
Old May 17, 2008, 05:20 PM   #5
Eric Lewis
Thread Starter
Banned
 
Join Date: Feb 2007
Location: CANADA? eh?
yes im using a mighty mouse
Eric Lewis is offline   0 Reply With Quote
Old May 17, 2008, 06:25 PM   #6
haiggy
macrumors 65816
 
Join Date: Aug 2003
Location: Ontario, Canada
I've had this issue before as well... and I don't have a mighty mouse. I wasn't able to copy and paste and Safari and my right clicks were acting all weird. I restarted to fix the problem if I remember correctly. Only reoccurred one other time.
__________________
15.4" MacBook Pro 2.6GHz Core 2 Duo; 4GB RAM; 160 GB HDD; NVIDIA 8600GT 256MB; Red iPod Nano, 16GB iPod touch
haiggy is offline   0 Reply With Quote
Old May 17, 2008, 09:06 PM   #7
andrewm
macrumors regular
 
Join Date: Apr 2004
This page has a post that may be of use to everyone afflicted with a copy/paste bug. It appears that some Logitech software (in this case for one of their computer remote controls) can cause issues.

The fix for the fellow who posted that article was to repair permissions from the Disk Utility.app program under /Applications/Utilities/.

Cheers,
Andrew

ETA: Logitech's software and drivers from other companies are not the only thing, however, that can cause issues with permissions. Some people say that repairing permissions is useless, too. I'd give it a go, however, as it won't hurt your system or your files -- sometimes seemingly-innocuous things can mess up permissions.

Last edited by andrewm; May 17, 2008 at 09:13 PM. Reason: Added some further information
andrewm is offline   0 Reply With Quote
Old Oct 3, 2009, 05:16 PM   #8
waiataMoana
macrumors newbie
 
Join Date: Oct 2009
command-c, command-v, alt-arrow not working in dreamweaver

running 10.5.6 i had a similar problem to the one described above.
I tried to repair permissions as suggested to no avail.
The problem item was simple to isolate though, after reading this post it was clear...i removed a recently installed printer driver (Lexmark z12) and I'm now back in business. hope this helps other dreamweaver users out there.
waiataMoana is offline   0 Reply With Quote
Old Nov 4, 2009, 10:23 AM   #9
drdunga
macrumors newbie
 
Join Date: Nov 2009
Repairing permissions did not help me. But removing a recent printer (which wasn't working anyway) did help copy/paste functionality.
Cheers,
Dave
drdunga is offline   0 Reply With Quote
Old May 20, 2012, 04:32 PM   #10
Techathome
macrumors newbie
 
Join Date: May 2012
Copy Paste not working in hotmail on a mac

One day, my keyboard shortcuts stopped working. I could no longer highlight any text or URLs within my MSN hotmail email and copy them to another location. I found this information on another blog within MacRumors.

From your hotmail account:

1. Select Options > More Options > Keyboard shortcuts
2. Turn off keyboard shortcuts.

This worked for me.
Techathome is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
HELP! Copy and Paste menriqu8 MacBook Pro 2 Apr 20, 2014 04:55 AM
Is copy / paste working in Dictionary? steveOooo OS X Mavericks (10.9) 0 Oct 29, 2013 07:44 AM
Apple Script -> Copy and Paste HTML content - Not working gguerini Mac Programming 2 Apr 10, 2013 04:49 PM
Resolved: Copy 21 files, only Paste 20. Help please MatiCarne Mac Basics and Help 2 Apr 1, 2013 11:26 PM
Copy & Paste, Google Chrome, and Trash all not working properly. Alaskanese OS X 8 Jun 28, 2012 01:58 PM

Forum Jump

All times are GMT -5. The time now is 08:28 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC