Go Back   MacRumors Forums > Apple Systems and Services > OS X > Mac OS X Server, Xserve, and Networking

Reply
 
Thread Tools Search this Thread Display Modes
Old May 20, 2008, 09:35 PM   #1
keplenk
macrumors newbie
 
Join Date: May 2008
How do share ANY folder in Mac (Leopard) to my WinXP PC

Hi all,

I know that this topic has been tackled so many times but I'm really having difficulties, so please forgive me for reposting.

I have 4 computers (1 macbook + 3 PC) in my network and they are all connected using ethernet cable (no wireless). My sister has a new macbook (with Leopard) and we are trying to share one folder placed on her Desktop named "Pictures".

Ok, so basically everything is networked fine. AUTO DHCP gave the correct IPs for my computers (including the mac) and they can see each other in the Network. When browsing my sisters Mac .. I see the "Public Folder" and I tried to put some files from my XP to the "Drop Box" folder and it worked fine. This only means that it is Networked correctly.

But here is the problem:

I don't want to use that "Public Folder" .. I want to make my own shared folder (e.g. named "Pictures") when I browse Network Places in XP. For some reason, I just can't do it with Leopard.

Troubleshooting / Suggestions done:

1) I went to System Preferences > Sharing > Enabled "File Sharing"

2) Under Shared Folders, I added (+) the Folder from my sisters macbook named "Pictures". Now there are two shared folders listed ... The Public Folder and the Pictures Folder.

3) In the Right pane named Users, I made sure that "Read & Write" are all enabled with Everyone, Users, My name.

4) In my First try, under Options, I just checked all AFP, FTP, SMB (put a password).

Now, I go to my Windows XP PC, went to Network places ... But I can't see the folder named "Pictures" in there. Just the Public Folder.

Now, I went back to the macbook, unchecked FTP and AFP .. I just left SMB checked. Tried it again, but still I only see "Public Folder"

Do I have to install something in my XP to recognize SMB?

Did I forget to check something in Macbook's Sharing Option?

Please help.

Thank you very much.
keplenk is offline   0 Reply With Quote
Old May 21, 2008, 04:51 PM   #2
monkeydo_jb
macrumors 6502
 
Join Date: Apr 2002
Location: Columbia, MO
Have you tried typing the exact path of the share in Windows Explorer?

IE - \\nameofyourmac\Users\username\Pictures

\\ipofyourmac\Users\username\Pictures will work, too.

It should prompt you for a username/password.
__________________
Just cause I rock, doesn't mean I'm made of stone.
monkeydo_jb is offline   0 Reply With Quote
Old May 24, 2008, 12:00 AM   #3
keplenk
Thread Starter
macrumors newbie
 
Join Date: May 2008
Quote:
Originally Posted by monkeydo_jb View Post
Have you tried typing the exact path of the share in Windows Explorer?

IE - \\nameofyourmac\Users\username\Pictures

\\ipofyourmac\Users\username\Pictures will work, too.

It should prompt you for a username/password.
Hi monkeydo ..

THanks for your reply. Yes, I've tried that too. I just can't see it! I'm really wondering why.

Any other suggestions? Thanks man
keplenk is offline   0 Reply With Quote
Old Jan 3, 2009, 07:51 AM   #4
rustusaron
macrumors newbie
 
Join Date: Jan 2009
Same problem, did you work it out?

Hi Keplenk,

I am having the same problem. Did you work out how to do it?

Cheers
rustusaron is offline   0 Reply With Quote
Old Jan 3, 2009, 03:19 PM   #5
windels
macrumors regular
 
Join Date: Oct 2008
Location: Belgium
hy,

ass you can see , i'm a newbie here so sorry if what I say sounds stupid, but here's my idea:

i think it might be impossible to directly share something from mac to pc because the way the os X partition on your hardrive is formatted is unknown en thus onreadable for Microsoft windows. but I think if you partitioned your harddrive and created a part in FAT , that it is possible to share everything on that partition; this is because FAT is recognised by both windows and mac. maybe there is another solution, but as I said before, I'm new to macintosh.

* note: ntfs won't work because macintosh can only read ntfs harddrives, not write

hope I helped you out,

Sam
windels is offline   0 Reply With Quote
Old Jan 3, 2009, 04:32 PM   #6
curmi
macrumors regular
 
Join Date: Jun 2000
Location: Melbourne, Australia
No, it has nothing to do with FAT. You do not need to reformat your drive.

Check this out, it should get you going:

http://macs.about.com/od/macwindows/...macfilesxp.htm
curmi is offline   0 Reply With Quote
Old Jan 3, 2009, 05:28 PM   #7
avkills
macrumors 6502
 
Join Date: Jun 2002
Under Sharing Preferences, click on the Options; then turn on SMB sharing; then click on the username for which you want to share. It will ask for a password and bingo, should be good to go. Your windows box will have to have the same username/password if you want it to work "easy". Otherwise you will have to tell the windows box the username and password; which I think you can do by right clicking in the explorer window and choosing "login as".

*edit* Of course you will need file sharing turned on also!

-mark
avkills is offline   0 Reply With Quote
Old Jan 5, 2009, 08:40 PM   #8
Mac_Max
macrumors 6502
 
Join Date: Mar 2004
I've found that two things really help with smoothing out OS X -> Windows connectivity issues. First, set the workgroup of the Mac to whatever the PC is using, usually WORKGROUP or MSHOME. Go to the Network system preference pane and click Advanced... button. Click the WINS tab and set your netbios name and domain. I usually stick to WORKGROUP since I have XP Pro on my PCs.

Second, run the file sharing wizard in the PC and setup file sharing even if it's already working from PC to PC. For whatever stupid reason, 9 times out of 10 this makes my Macs reappear when I try to add them as a network place (using the Add a Network Place wizard, if you haven't done this yet, try it too).

I hope this helps.
Mac_Max is offline   0 Reply With Quote
Old Jan 6, 2009, 06:27 PM   #9
Supa_Fly
macrumors 68030
 
Supa_Fly's Avatar
 
Join Date: May 2002
Location: Toronto, Ontario, Canada
Send a message via MSN to Supa_Fly
Quote:
Originally Posted by monkeydo_jb View Post
Have you tried typing the exact path of the share in Windows Explorer?

IE - \\nameofyourmac\Users\username\Pictures

\\ipofyourmac\Users\username\Pictures will work, too.

It should prompt you for a username/password.
If you type "\\" into IE it must be in a web protocol such as http/https/ftp etc.
and nameofyourmac might need to be in a server.

How about trying it the other way around; uncheck SMB as I don't think XP can see that natively.
__________________
2008 Al_MB 2.4Ghz C2D 4GB/256GB HDD/256MB Nvidia 9400M| Panther Dog Tags | Z10 | 2010 Mac Switcher
Supa_Fly is offline   0 Reply With Quote
Old Jan 7, 2009, 06:20 AM   #10
dampfdruck
macrumors member
 
Join Date: Oct 2008
Don't enable/disable services at random. If you want to give Windows users access to a folder, then enable SMB, not AFP, FTP or whatever.

Make sure that you allow SMB services though the Mac firewall, or, turn the firewall off (on the Mac).

Once you have done this, the other computers on the network can see and access your shares.

You can test this from a remote computer by enterpring \\Ip.addr.of.mac or directly on your mac using "smbclient", e.g.: smbclient -L \\127.0.0.1 which will dump a list of shares (provide that you don't require a password).
dampfdruck is offline   0 Reply With Quote
Old Jan 7, 2009, 08:41 AM   #11
freiheit
macrumors 6502a
 
Join Date: Jul 2004
Location: California
If only that would work

Oh if only that were true. Unfortunately what worked perfectly under Tiger (sharing to a Windows PC) has failed consistently for me under Leopard. Originally I was able to see my Leopard shares, and even begin transfers of files, however they would always fail part way through with an error about the remote system being unavailable or something. In later Leopard builds (ie. 10.5.4, .5 and .6) I just can't see my Leopard shares at all from Windows.

But networking the other way (accessing Windows shares from Leopard) works just fine.

On a related note, I'm almost never able to connect to Leopard's Screen Sharing or Remote Management with a VNC client on Windows, and again this worked fine when I was running Tiger on the Mac.

Leopard is horribly broken in many ways wrt networking with Windows PCs. After 6 updates, it's still not getting any better.
__________________
Without doubt the best OS X versions were 10.3 and 10.6. It's still too soon to tell about 10.9 but so far so good.
freiheit is offline   0 Reply With Quote
Old Jan 7, 2009, 10:51 AM   #12
Consultant
macrumors G5
 
Consultant's Avatar
 
Join Date: Jun 2007
Enable WINDOWS SHARING
Consultant is offline   0 Reply With Quote
Old Jan 12, 2009, 04:45 PM   #13
DenysB
macrumors newbie
 
Join Date: Jan 2009
I remember having the same trouble when I upgraded from Tiger. I had also set file sharing on both mac and XP, and had enabled smb on the mac. I had also set up the same user names and workgroups on both machines so that I could log in with the right username and password.

As I recall it, the problem finally went away after I used the mac Finder menu item Go->Connect to Server... You may first need to log into the hub to establish the current IP address of the Windows machine. Enter that in the Connect to Server dialog as follows: smb://192.168.0.2 (or whatever IP shows up). That might be worth trying.
DenysB is offline   0 Reply With Quote
Old Jan 12, 2009, 07:13 PM   #14
assembled
macrumors regular
 
Join Date: Jan 2009
Location: London
I'm amazed

windels, doesn't know the difference between a local disk mount, and a network file system

prom1 thinks that xp can't do SMB, the native windows network file access protocol...

smb sharing on leopard is crippled, but there are plenty of guides out there on how to set it up, on the XP side, you might also have to disable NTLM V2 auth
assembled is offline   0 Reply With Quote
Old Oct 25, 2009, 03:55 PM   #15
Supa_Fly
macrumors 68030
 
Supa_Fly's Avatar
 
Join Date: May 2002
Location: Toronto, Ontario, Canada
Send a message via MSN to Supa_Fly
Quote:
Originally Posted by assembled View Post
windels, doesn't know the difference between a local disk mount, and a network file system

prom1 thinks that xp can't do SMB, the native windows network file access protocol...

smb sharing on leopard is crippled, but there are plenty of guides out there on how to set it up, on the XP side, you might also have to disable NTLM V2 auth
Sorry for the old thread bump, but I'm trying to figure otu was there ever a solution to this issue regarding Leopard??

I finally get the chance to use OS X Tiger and although I've been able to get the WinXP Pro machine to see ALL folders under my home profile on the Mac (different user ID/pw on Mac than on PC), I'm not able to traverse into the WinXP SP3 Pro machine from the Mac using Tiger?

My Domain is: D3LL
(PS it may just be better for me to start a new thread).
__________________
2008 Al_MB 2.4Ghz C2D 4GB/256GB HDD/256MB Nvidia 9400M| Panther Dog Tags | Z10 | 2010 Mac Switcher
Supa_Fly is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > Mac OS X Server, Xserve, and Networking

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Share Home Folder Between Users abcdefg12345 OS X Mavericks (10.9) 5 Mar 31, 2014 09:16 AM
Not able to share the Public folder only dastinger OS X 10.8 Mountain Lion 0 Apr 25, 2013 02:18 PM
Mac Mini, PC, iTunes, share media folder? The-Pro Buying Tips and Advice 4 Feb 16, 2013 10:42 AM
Share Pictures folder between 2 users EvilHomer484 Mac Basics and Help 0 Dec 6, 2012 08:12 AM
Can't rename folder smb share Jiggy1965 OS X 0 Jun 6, 2012 09:48 AM

Forum Jump

All times are GMT -5. The time now is 04:44 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC