Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Reply
 
Thread Tools Search this Thread Display Modes
Old Jun 3, 2008, 11:47 AM   #1
BoulderBum
macrumors 6502a
 
Join Date: Feb 2008
YouTube Laggy

Does anyone ever have trouble playing YouTube on the Apple TV (and their computer for that matter)?

All the bandwidth tests say I have ample bandwidth (up to 22 Mbps) at the time I experience the lag issues, but for some reason it seems like the Apple TV is always pausing and playing catch-up.
BoulderBum is offline   0 Reply With Quote
Old Jun 3, 2008, 01:12 PM   #2
Kilamite
macrumors G3
 
Kilamite's Avatar
 
Join Date: Mar 2007
Location: Scotland
Does your Apple TV buffer the YouTube video or does it play right away?
__________________
15" MacBook Pro 2GHz i7 8GB 750GB Hybrid | Mac mini 2.3GHz i7 16GB 1TB Fusion | OS X 10.10
iPhone 5 64GB | Apple TV 3 1080p | iOS 7.1.2
Home Theatre Hackintosh i3 3.5GHz 4GB 3TB | OS X 10.9
Kilamite is offline   0 Reply With Quote
Old Jun 3, 2008, 01:24 PM   #3
gkarris
macrumors 604
 
gkarris's Avatar
 
Join Date: Dec 2004
Location: "No escape from Reality..."
Make sure you're on the latest software release and that, if it is cable, you are really sharing the bandwidth with others. If on wireless, make sure you are getting the max signal.
__________________
"This gate's plastic." Captain Carter, Stargate SG-1, "Touchstone"
gkarris is offline   0 Reply With Quote
Old Jun 3, 2008, 05:14 PM   #4
BoulderBum
Thread Starter
macrumors 6502a
 
Join Date: Feb 2008
Quote:
Originally Posted by Kilamite View Post
Does your Apple TV buffer the YouTube video or does it play right away?
It buffers, takes a long time to do so, and ends up lagging/pausing anyway.

Quote:
Originally Posted by gkarris View Post
Make sure you're on the latest software release and that, if it is cable, you are really sharing the bandwidth with others. If on wireless, make sure you are getting the max signal.
Software is updated as of only a month ago (2.1 is it?), and I'm connecting wireless N at 130 Mbps, 100% signal strength. Interestingly, HD podcasts streamed from the internet tend to play instantly as do movie rentals. It seems like it's not a bandwidth issue!
BoulderBum is offline   0 Reply With Quote
Old Jun 3, 2008, 06:15 PM   #5
Kilamite
macrumors G3
 
Kilamite's Avatar
 
Join Date: Mar 2007
Location: Scotland
Quote:
Originally Posted by BoulderBum View Post
Software is updated as of only a month ago (2.1 is it?), and I'm connecting wireless N at 130 Mbps, 100% signal strength. Interestingly, HD podcasts streamed from the internet tend to play instantly as do movie rentals. It seems like it's not a bandwidth issue!
2.0.2 is the latest - came out just over a month ago so you'll be up to date.

I did have YouTube problems with some videos, but most of that got fixed with 2.0.2. Is it all videos that lag or just some?
__________________
15" MacBook Pro 2GHz i7 8GB 750GB Hybrid | Mac mini 2.3GHz i7 16GB 1TB Fusion | OS X 10.10
iPhone 5 64GB | Apple TV 3 1080p | iOS 7.1.2
Home Theatre Hackintosh i3 3.5GHz 4GB 3TB | OS X 10.9
Kilamite is offline   0 Reply With Quote
Old Jun 4, 2008, 02:38 AM   #6
BoulderBum
Thread Starter
macrumors 6502a
 
Join Date: Feb 2008
Quote:
Originally Posted by Kilamite View Post
2.0.2 is the latest - came out just over a month ago so you'll be up to date.

I did have YouTube problems with some videos, but most of that got fixed with 2.0.2. Is it all videos that lag or just some?

It seems to happen with all videos, though once in a blue moon, it streams as fast as I'd expect. What's weird is that I see the same problem with my PC and YouTube, but no other video sites, even if they use a flash-based player.
BoulderBum is offline   0 Reply With Quote
Old Jun 4, 2008, 07:06 AM   #7
Kilamite
macrumors G3
 
Kilamite's Avatar
 
Join Date: Mar 2007
Location: Scotland
So the problem isn't really down to the Apple TV, same happens to your PC?

What router are you using?
__________________
15" MacBook Pro 2GHz i7 8GB 750GB Hybrid | Mac mini 2.3GHz i7 16GB 1TB Fusion | OS X 10.10
iPhone 5 64GB | Apple TV 3 1080p | iOS 7.1.2
Home Theatre Hackintosh i3 3.5GHz 4GB 3TB | OS X 10.9
Kilamite is offline   0 Reply With Quote
Old Jun 9, 2008, 11:51 AM   #8
BoulderBum
Thread Starter
macrumors 6502a
 
Join Date: Feb 2008
I have a D-Link DIR-655 "Xtreme N" router. I sort of wondered if the QoS might be screwing something up, but it's odd that it happens only with YouTube, not other video sites (and I discovered it doesn't always happen).

Yes, btw, it does seem to happen on my PC, too, though it seems that longer YouTube videos get an error on Apple TV. It's something about "Apple TV can't play this format" or something like that.
BoulderBum is offline   0 Reply With Quote
Old Jun 9, 2008, 07:43 PM   #9
droalex
macrumors member
 
Join Date: Mar 2008
It may be your internet speed.
droalex is offline   0 Reply With Quote
Old Jun 10, 2008, 11:03 AM   #10
BoulderBum
Thread Starter
macrumors 6502a
 
Join Date: Feb 2008
Quote:
Originally Posted by droalex View Post
It may be your internet speed.
I mentioned earlier, but I'm getting bandwidth tests indicating 22 mbps at the same time I'm having YouTube lagginess.

It seems unlikely that the bandwidth is the issue.
BoulderBum is offline   0 Reply With Quote
Old Jun 10, 2008, 11:54 PM   #11
adrianseto
macrumors newbie
 
Join Date: Jun 2008
I have the same buffering issues with Youtube on ATV. And when I try to view the same video on my PB its fine. I think its the delivery to ATV from Youtube that is faulty. Youtube may have to deliver a higher res version to ATV as opposed to what plays directly off their site? Just a thought...
adrianseto is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Late 2013 rMBP - Youtube laggy on Bootcamp SCOLANATOR MacBook Pro 6 Dec 28, 2013 12:42 AM
Easy way to pause or unpause videos in YouTube without tabbing into YouTube? kylera Mac Basics and Help 0 Dec 14, 2013 11:35 PM
laggy Youtube fullscreen iMcLovin iMac 2 Mar 29, 2013 04:17 PM
Is YouTube laggy for you? minisuds7 Apple, Industry and Internet Discussion 4 Nov 28, 2012 01:13 AM
Why does the YouTube app play better quality than the Safari version of YouTube? Big.Mac.Daddy iPhone 16 Aug 20, 2012 09:53 AM

Forum Jump

All times are GMT -5. The time now is 04:35 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC