Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Reply
 
Thread Tools Search this Thread Display Modes
Old Jun 15, 2008, 03:25 AM   #1
hitenders
macrumors newbie
 
Join Date: Jun 2008
iPhone repeatedly disconnects/reconnects

Hello folks,

I have this strange problem when I connect my iPhone to the PC. It seems to repeatedly disconnect/reconnect to the computer sometimes. At first, I thought it was the dock causing the problem, but it happens also when the USB cable is directly plugged into the iPhone.

It started first on another USB hub which is not USB 2.0 supported, I shifted it to another USB port which in fact USB is 2.0 supported, everything was fine for a week then it started doing it on this port too, happened twice for a span of 5 seconds.

I know nothing is wrong with the USB cable as this does not happen when I connect it to the wall dock.

I've reinstalled iTunes but to no avail, I'm guessing it's my crappy PC.

It's stopped happening on both the USB ports now but it concerns me since the last time it happened to me on the first USB port, I got an error which led to all the songs from my iTunes disappear.

Any help or info on this will be greatly appreciated,

Cheers.
hitenders is offline   0 Reply With Quote
Old Jun 16, 2008, 10:42 AM   #2
corygreenwell
macrumors member
 
Join Date: Feb 2008
Same thing is happening to me on my macbook...

I'm on my 4th iPhone.
corygreenwell is offline   0 Reply With Quote
Old Jul 15, 2008, 12:42 PM   #3
budfoot
macrumors regular
 
Join Date: Jul 2008
Location: Boston, MA
Send a message via Skype™ to budfoot
Quote:
Originally Posted by corygreenwell View Post
Same thing is happening to me on my macbook...

I'm on my 4th iPhone.

I don't think it's the phone. I can't use some external drives (aka, Time Machine backups) on the port that the iPhone went funky on now.

Try other USB periphs, i'd bet you're having the same problem.

iPhone seems to have fried at least 1 USB port on my system?
budfoot is offline   0 Reply With Quote
Old Jul 15, 2008, 12:52 PM   #4
budfoot
macrumors regular
 
Join Date: Jul 2008
Location: Boston, MA
Send a message via Skype™ to budfoot
Now that i've searched around some more, seems to have something to do with iPhone crashing the usb2.0 driver? I've a genius bar appt tomorrow night, so we'll see what happens.
budfoot is offline   0 Reply With Quote
Old Jul 19, 2008, 01:10 PM   #5
mrwonkamic
macrumors newbie
 
Join Date: Jul 2008
Any answers?

Did anyone find a solution to this?
mrwonkamic is offline   0 Reply With Quote
Old Jul 20, 2008, 06:36 PM   #6
budfoot
macrumors regular
 
Join Date: Jul 2008
Location: Boston, MA
Send a message via Skype™ to budfoot
Quote:
Originally Posted by mrwonkamic View Post
Did anyone find a solution to this?
Yes yes yes.

It's push/3g. If you disable push, it stops. If you disable 3g, it stops.

I took both my mac and the phone to the apple store on Boylston. Couldn't repro it. I finally realized i had turned off push, turned it back on, and the thing went nuts.

They are wanting to replace the USB port. His reasoning was he plugged my phone into another MBP and it didn't do it (makes sense to me).

So, i couldn't leave my MB, i had to go to Reading England, but when i get back, i'm going to drop it for a pro-care appt.
budfoot is offline   0 Reply With Quote
Old Sep 10, 2008, 10:29 PM   #7
glxyjones
macrumors regular
 
Join Date: Jun 2007
Any news on this? I disabled push, 3g, even went into airplane mode and nothing helped. I know it's not the cable because it worked fine on my old iphone.

I've tried connecting it through my iMac keyboard, my usb hub, and directly into the computer... nothing works.
glxyjones is offline   0 Reply With Quote
Old Sep 11, 2008, 10:11 AM   #8
budfoot
macrumors regular
 
Join Date: Jul 2008
Location: Boston, MA
Send a message via Skype™ to budfoot
Well, of sorts...

I've been using my phone now for a couple months (has it been that long?)... i've noticed a few things..

There are certain APPS that will cancel syncs, don't ask me how or which ones, but i've noticed that when i have restored my iphone to blank, it'll sync music and stuff all day. As soon as i start putting apps on it, it starts disconnecting/reconnecting.

Also, i've been using the right USB port of my MBP, the one furthest away from the power jack. I have yet to have the time to drop my MBP off at the genius bar to have them replace the usb port on the left side.

There is definitely something funky. And it's gotten downright intolerable since 2.0.2... we'll see if 2.1 fixes it.
budfoot is offline   0 Reply With Quote
Old Sep 11, 2008, 04:39 PM   #9
bjobes
macrumors regular
 
Join Date: Jul 2008
My 3g started this after updating to iTunes 8. Device manager shows the iPhone as a imaging device which was fine. I'd drill down and reinstall the device usb driver and it would work.

No longer does that anymore. The driver now says access denied.
bjobes is offline   0 Reply With Quote
Old Jun 21, 2009, 11:26 AM   #10
monstabyte
macrumors newbie
 
Join Date: Jun 2009
Lightbulb

Hi Guys - just stumbled on this thread via Google and thought I would take the time out to offer you my solution:

I had the same problem and thought it was a number of things (USB Port/IPhone/Cable/etc...) - however resetting my iphone didn't help and neither did restarting my PC.

What you need to do is actually POWER DOWN your PC. Not just restart it. Actually switch it off! Then unplug it from the power socket and - whilst unplugged - hit the "on" button of your PC a few times within a good 30 seconds (i.e. give it a few secs or this might not work).
The idea is that all the little bits of "leftover power" on your mainboard need to discharge.

Having done that simply plug the PC back in, boot up, and all should be restored to normal.

This trick OFTEN works when USB devices are playing up and I have no real idea why except for that it obviously has something to do with the wrong kind of electrical charge building up on the USB ports.

I have never experienced it with laptops but with heaps of component-built PCs.

Hope it helps - it worked for me and my iPhone 3G ...

cheers
monstabyte
monstabyte is offline   0 Reply With Quote
Old Jun 21, 2009, 02:18 PM   #11
PNutts
macrumors 601
 
PNutts's Avatar
 
Join Date: Jul 2008
Location: Pacific Northwest, US
This happens whenever I use the same USB port as a slow (1.0) device, i.e., keyboard, keeping in mind it is difficult to know which exernal ports share the same internal hub (they are typically pairs).

I solved the problem by unplugging all the USB devices I could, make sure the issue went away, and then plugged them back in one by one (and moving the iPhone when necessary).
PNutts is offline   0 Reply With Quote
Old Oct 15, 2011, 11:15 AM   #12
MattMorgan105
macrumors newbie
 
Join Date: Oct 2011
This worked for me!!

I have an iPhone 4. This problem drove me nuts. Glad I found this post. Thanks budfoot.

Quote:
Originally Posted by budfoot View Post
Yes yes yes.

It's push/3g. If you disable push, it stops. If you disable 3g, it stops.

I took both my mac and the phone to the apple store on Boylston. Couldn't repro it. I finally realized i had turned off push, turned it back on, and the thing went nuts.

They are wanting to replace the USB port. His reasoning was he plugged my phone into another MBP and it didn't do it (makes sense to me).

So, i couldn't leave my MB, i had to go to Reading England, but when i get back, i'm going to drop it for a pro-care appt.
MattMorgan105 is offline   0 Reply With Quote
Old Dec 25, 2013, 05:35 AM   #13
Omnirai
macrumors member
 
Join Date: Jan 2012
Location: Antwerp
Sorry to be gravedigging.. But bumped on this thread while using google.

I have 2x iPhone 4s, both same model (but way different manufacturing date).

The first iPhone works perfectly fine.

The second iPhone shows this disconnect/connect loop while hooking it up in both USB ports on my rMBP 13" haswell.

Connecting the 'problem' iPhone to another computer doesn't give me this error, so I tried hooking it up to my rMBP again.

Result: left side USB port still reproduces the error, now the right side USB works fine with the iPhone..

Anyone got any idea whats actually going on?
Omnirai is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Mac disconnects (and reconnects) external display when moved or pushed on hyperipod MacBook Pro 5 Jun 1, 2014 07:29 PM
iPhone 4S Repeatedly Dying Around 50% Battery? KieranDotW iPhone Tips, Help and Troubleshooting 4 Dec 8, 2013 12:06 PM
wifi drops - disconnects and reconnects every few seconds iyb OS X Mavericks (10.9) 0 Oct 29, 2013 09:17 AM
My iphone 4s disconnects from wifi Kiddtubbz iPhone 7 Jan 6, 2013 04:01 AM
IPhone 3 Shutting on and off repeatedly on its own Stormy Night iPhone Tips, Help and Troubleshooting 3 Sep 29, 2012 01:17 AM

Forum Jump

All times are GMT -5. The time now is 06:12 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC