Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > OS X

Reply
 
Thread Tools Search this Thread Display Modes
Old Jun 16, 2008, 02:41 PM   #1
marekkurlmann
macrumors member
 
Join Date: Mar 2007
Disk Utility Stuck on "Creating Partition Map"

I've got a problem that's going on as I type this and would like advice on how to proceed.

I am trying to format a brand new 120 GB hard drive via an external USB 2.0 enclosure. About 25 minutes ago, I selected the "erase" option and slected the Mac OS Extended (Journal) Volume format. For the last 25 minutes, disk utility has been saying that it's creating a partition map. It's doing nothing.

I have reason to believe my enclosure may be faulty. (I had a similar problem on an old hard disk and thought that the problem was with the disk; now I know.) I need to know: How do I disconnect/eject the hard disk without damaging it? The eject option in Disk Utility is grayed out. If I attempt to quit Disk Utility I get a warning telling me I could leave my disk inoperable.

What's the safest way to go about this?

Thanks for the advice!
marekkurlmann is offline   0 Reply With Quote
Old Jun 16, 2008, 02:59 PM   #2
pyr0sphere
macrumors regular
 
Join Date: Oct 2007
Location: Toronto, Canada
Wait it out?

I remember when I created a new partition on my external hard drive, it took a while too. I think it stalled at the same message too

Leave the room and just wait. No harm in waiting. I'd let it go for as long as up to two hours. But that's just me
__________________
Late 2007 Macbook, 2.2 GHz, 4 GB RAM, 120 GB HD
pyr0sphere is offline   0 Reply With Quote
Old Jun 16, 2008, 03:03 PM   #3
marekkurlmann
Thread Starter
macrumors member
 
Join Date: Mar 2007
I'll wait it out, but if nothing happens after a few hours, what to do?

I'm worried because I had this same issue with the same enclosure a few weeks ago. I stupidly pulled the USB cable out and the disk broke--clicking noises galore. I thought that the disk was the problem. Now I know that the problem was the enclosure.

So what to do now without harming the disk?
marekkurlmann is offline   0 Reply With Quote
Old Jun 16, 2008, 06:17 PM   #4
jcroeth
macrumors newbie
 
Join Date: Jun 2008
I've had this issue a couple times in the past and, if I recall correctly, I'm pretty sure I just unplugged the drive, plugged it back in, and started the formatting process over again. That was a while back though, so I'm not entirely sure.

However, I do find what you said about damaging that disk interesting.

Feel free to correct me if I'm wrong, but I wasn't aware that you could physically damage a disk (failure, with clicking noises) by disconnecting it (either from USB or power, or both, whichever may apply). The way I understand it is that the danger in disconnecting a drive without properly ejecting it is that you could corrupt your data; especially if the drive was transferring data at that moment. In this case, since you're obviously reformatting the drive, data loss/corruption isn't a problem.

Also, I will say this... There have been many times that a Time Machine backup to my external drive hung up at the "preparing" point. It sat there "preparing" making no progress for quite some time. (I am aware that some backups can "prepare" for a long time and still be behaving normally. But this was extraordinarily long). In those instances I couldn't eject the drive, just like you're describing. I ended up just pulling the firewire cable, turning the drive off, plugging it back and then initiating the backup again and it worked fine. Maybe I was lucky though.

Again, correct me if I'm wrong about the damage possibility.
jcroeth is offline   0 Reply With Quote
Old Aug 30, 2008, 07:58 PM   #5
ploughguy
macrumors newbie
 
Join Date: Aug 2008
I have just had the same problem. I waited a couple of hours and it was still there. I finally got serious and decided that the drive had powered down.
In my case the external drive is a LaCie which has an On-Auto-Off switch which was set out of the box to Auto. I switched it to On and Lo! it started making slightly more noise (against the background of an iMac, a MacBook, 2 Maxtors, a Time Tunnel/Lord/Capsule/Thing and another LaCie with two drives in it, it was a bit hard to tell.)

So, now the disk is actually running, but the formatter is still hung.
I unplugged the disk. Nothing bad happened. I told Disk Utility to quit. It gave a message sayint that the drive may be unusable. Indeed it would be, because it is now unformatted. I believe this message is not as sinister as some people fear.

I restarted time machine, carefully selected the disk again, and repeated the erase. The whole thing was over in 30 seconds and completely successful.

So, fear not:
  • If it hangs, the drive may have taken itself offline. Cycle the power
  • if disk utility tells you the drive may be unusable, then it doesn't mean unusable forever, just until you format it again
  • If the disk has a three position power switch, set it to ON
  • Fearlessly repeat the formatting operation
  • and if the drive makes nasty clattering noises, then it is not your fault. It was already a Dead Disk Walking

<< Ploughguy, and by extension Ploughguy Industries, its affilliates and suppliers are in no way responsible for any detonations in your neighbourhood if you take this advice. Always seek authorative dogma from licensed, highly trained and expensive professionals, not some guy who drags a plough round a paddock all day. And good luck.>>
ploughguy is offline   0 Reply With Quote
Old Feb 3, 2009, 02:17 PM   #6
inextirpable
macrumors newbie
 
Join Date: Feb 2009
I had the same problem...

Just put a new 500GB seagate drive in the MacBook Pro 17" and had a devil of a time to get the drive to format ("erase") / partition using the "disk utility" application (booting from the start-up DVD disk). It kept hanging on the "creating partition map." I took it to the apple store to have a mac "genius" look at it and he was of no help - said that the drive was probably bad! I came home and tried again - this time I booted from an external drive (which was the old drive) and then ran the "disk utility" from that and then used the "erase" function and it formatted the drive in 10 seconds. Now i'm restoring the old disk image to the new drive - says it has 7 hours left.
inextirpable is offline   0 Reply With Quote
Old Jun 30, 2010, 09:34 AM   #7
apple.pseudofan
macrumors regular
 
Join Date: Apr 2010
Resurrection!

Thank you Mroogle!

I'm hoping I just have to cycle power on mine. I actually quit it and attempted starting it again to an error each and every time. Hopefully I can unplug/plug in and try again to success.

I'll keep you posted.
__________________
2.4Ghz i5 15" MBP, standard configuration; AEBS; 2TB WD wireless storage; 32 GB New iPad (white); 32 GB iPhone 5 (white)
apple.pseudofan is offline   0 Reply With Quote
Old Jul 27, 2011, 01:25 PM   #8
FuNGi
macrumors 6502a
 
FuNGi's Avatar
 
Join Date: Feb 2010
Location: Sweden & California
I'm having the same problem here. Disk Utility is just stuck "partitioning" but the progress bar doesn't change. I've tried Firewire 800 and USB but it cannot advance further. The Partition Map Scheme says "unformatted".

Any ideas out there?
__________________
4", 13", 15", 24"
FuNGi is offline   0 Reply With Quote
Old Jul 27, 2011, 01:26 PM   #9
simsaladimbamba
Guest
 
Join Date: Nov 2010
Location: located
Quote:
Originally Posted by FuNGi View Post
I'm having the same problem here. Disk Utility is just stuck "partitioning" but the progress bar doesn't change. I've tried Firewire 800 and USB but it cannot advance further. The Partition Map Scheme says "unformatted".

Any ideas out there?
What partition map scheme have you selected?
from
How to format a new HDD/SSD to install Mac OS X or make a bootable copy onto
simsaladimbamba is offline   0 Reply With Quote
Old Jul 27, 2011, 01:28 PM   #10
FuNGi
macrumors 6502a
 
FuNGi's Avatar
 
Join Date: Feb 2010
Location: Sweden & California
I am just trying to erase so I didn't get that option. It is an external G-Tech.
__________________
4", 13", 15", 24"
FuNGi is offline   0 Reply With Quote
Old Jul 27, 2011, 01:31 PM   #11
simsaladimbamba
Guest
 
Join Date: Nov 2010
Location: located
Quote:
Originally Posted by FuNGi View Post
I am just trying to erase so I didn't get that option. It is an external G-Tech.
Maybe try it the way I linked to in my reply to see, if that helps.
It doesn't need to be GUID, only if you want to.
simsaladimbamba is offline   0 Reply With Quote
Old Jul 27, 2011, 01:40 PM   #12
FuNGi
macrumors 6502a
 
FuNGi's Avatar
 
Join Date: Feb 2010
Location: Sweden & California
Tried you method and the progress bar jumps to the exact same place and then just hangs...it literally cannot make a partition map.
__________________
4", 13", 15", 24"
FuNGi is offline   0 Reply With Quote
Old Jul 27, 2011, 01:59 PM   #13
simsaladimbamba
Guest
 
Join Date: Nov 2010
Location: located
Quote:
Originally Posted by FuNGi View Post
Tried you method and the progress bar jumps to the exact same place and then just hangs...it literally cannot make a partition map.
Have you got any other Mac or even Windows PC to try that external HDD with?
simsaladimbamba is offline   0 Reply With Quote
Old Jul 27, 2011, 02:00 PM   #14
FuNGi
macrumors 6502a
 
FuNGi's Avatar
 
Join Date: Feb 2010
Location: Sweden & California
Quote:
Originally Posted by simsaladimbamba View Post
Have you got any other Mac or even Windows PC to try that external HDD with?
My roomate's got a PC and I've got an AIR - I'll try to reformat it on those later tonight. Thanks for you help.
__________________
4", 13", 15", 24"
FuNGi is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Disk Utility stuck on "skipping" pagan11460 Mac Pro 5 Mar 17, 2014 07:35 PM
"sticky" How to use disk utility properly without install discs Cox Orange PowerPC Macs 0 Jan 1, 2014 04:12 PM
"Windows failed to start..." after creating partition. juanderi Windows, Linux & Others on the Mac 0 Oct 16, 2012 05:17 PM
Installed 10.8 by creating a partition, Disk Utility wont give me back free space yogarcia OS X 10.8 Mountain Lion 3 Aug 8, 2012 10:10 PM
No Disk Utility in "Utilities" menu in Mac OS X Snow Leopard Installer nosuchthing Mac Basics and Help 0 Jul 24, 2012 01:11 AM

Forum Jump

All times are GMT -5. The time now is 12:49 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC