Go Back   MacRumors Forums > Apple Systems and Services > Programming > iPhone/iPad Programming

Reply
 
Thread Tools Search this Thread Display Modes
Old Jun 29, 2008, 07:20 PM   #1
bahamallama
macrumors member
 
Join Date: Jun 2008
XCode 3.1? What is the current version?

I currently have 3.0 and software upgrade says there are no new versions, Apple.com says so as well but I just downloaded the source code from Apple's site for the Moveme application for the iphone and it says that it was created with a newer version of xcode and some feature may not work correctly.

I'm trying to follow with the tutorial on the apple dev site and sure enough something is not correct. The Project > Set Active SDK > Simulator is not there, under project set active SDK is not there at all.

Also when I try to build and run it as the tutorial says I get an errror.

Any ideas? Is there a newer version somewhere and how do I get it? I had a similar problem yesterday where updates weren't detected and then later they were and I was able to install the version 8 of the sdk for the iphone, I'm wondering if it's a similar thing or am I overlooking something?

http://developer.apple.com/iphone/ge...oneapps.action

Thanks in advance!

D
bahamallama is offline   0 Reply With Quote
Old Jun 29, 2008, 07:25 PM   #2
Eraserhead
macrumors G4
 
Eraserhead's Avatar
 
Join Date: Nov 2005
Location: UK
If its an iPhone app, download the iPhone SDK which includes Xcode 3.1.
__________________
Actually it does make sense. Man created god, so if we exist, He exists. - obeygiant
Eraserhead is offline   0 Reply With Quote
Old Jun 29, 2008, 07:50 PM   #3
bahamallama
Thread Starter
macrumors member
 
Join Date: Jun 2008
Nevermind.

A month ago while trying to set mysql for some rails work, I wound up doing an archive and install of the OS which fixed the problem that I was having getting mysql to run and it turns out the shortcut for xcode from the menu bar was pointing to the previous systems folder > developer > xcode.app not the new developer > xcode.app.

I'm slowly getting the hang of this Mac thing!

Actually after 6 months I don't plan on ever going back to Windoze but I just lack the years of knowledge of working with the Apple OS and troubleshooting it and stuff that I have on Windoze.

Thanks for the quick reply and starting the spark of enlightenment to fix it!

D
bahamallama is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Programming > iPhone/iPad Programming

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
What's the oldest version of OS X you still run Xcode 4 on? ArtOfWarfare Mac Programming 8 Jun 17, 2013 07:15 PM
Current Unlock/Jailbreak for iPhone 5 version? MacOSXuser iPhone 2 Apr 12, 2013 12:43 AM
App works only with current version but not later HeresPeter Mac Applications and Mac App Store 3 Mar 29, 2013 08:45 AM
General: Backup the current version of an app? Redjericho Jailbreaks and iOS Hacks 0 Sep 25, 2012 03:47 PM

Forum Jump

All times are GMT -5. The time now is 01:01 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC