Go Back   MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Reply
 
Thread Tools Search this Thread Display Modes
Old Jul 8, 2008, 06:46 PM   #1
rogersmj
macrumors 68020
 
rogersmj's Avatar
 
Join Date: Sep 2006
Location: Indianapolis, IN
ATV suddenly locking up while playing videos

My hacked ATV has been humming along find for about 9 months now. I use it to play various video files that are stored on my main Mac via a mounted Samba share.

Just today, it started freezing up while playing videos. It doesn't matter what file it is...at some point, typically within 1 to 3 minutes of playing, it just stutters for a second and then completely freezes. I reboot, go back to the video I was watching, FF to where I was, and then it will happen again 1 to 3 minutes down the line. This has happened on MPG, DiVX, and XviD files that have always played 100% fine before.

It seems symptomatic of either a hard drive failure in the ATV or a network problem. But since it's hardwired into a gigabit network, and none of my other equipment seems to be having network issues, I'm leaning toward hard drive failure in the ATV. I put my ear next to it while it was running (and freezing) to see if I could hear anything, but since the ATV drive is so quiet and I'd never listened to it before it was hard to tell if what I heard was normal seek operations or the clicking of a dying drive.

Does anyone have any ideas on how to diagnose this? I can't live without my ATV.
rogersmj is offline   0 Reply With Quote
Old Jul 8, 2008, 07:01 PM   #2
tom1971
macrumors 6502a
 
Join Date: May 2007
which version is your ATV on?
To me it looks more liek an access problem of your share
tom1971 is offline   0 Reply With Quote
Old Jul 8, 2008, 07:10 PM   #3
rogersmj
Thread Starter
macrumors 68020
 
rogersmj's Avatar
 
Join Date: Sep 2006
Location: Indianapolis, IN
2.0

Ok I just confirmed it has something to do with the network share. I copied a Raymond episode to the ATV's hard drive via SFTP and was able to watch the whole thing without any trouble. Fired it up over the network...and it locked up again. This is really weird. I haven't changed any network configurations or run any software updates on either the ATV or my Mac that hosts the files.
rogersmj is offline   0 Reply With Quote
Old Jul 10, 2008, 06:46 AM   #4
rogersmj
Thread Starter
macrumors 68020
 
rogersmj's Avatar
 
Join Date: Sep 2006
Location: Indianapolis, IN
Well I rebooted everything (Mac and ATV) and for awhile everything seemed fine. My wife and I watched a couple TV episodes without a problem. Then we started up a movie, and got 75% of the way through it and suddenly the problem started up again.

I am at a loss. I guess the next thing to do will be to setup a share on a different Mac, connect the ATV to that, and see if the problem persists. It's hard to replicate consistently though.
rogersmj is offline   0 Reply With Quote
Old Jul 10, 2008, 04:07 PM   #5
macleod199
macrumors 6502
 
Join Date: Mar 2007
It could be a heat problem, too, if it's summer where you are. Most modern processors downclock themselves rather than melt.
macleod199 is offline   0 Reply With Quote
Old Jul 13, 2008, 12:14 AM   #6
msantoso
macrumors member
 
Join Date: Apr 2008
i'm also experience lock up in videos, but i realised that network performance in 10.5.4 decreases bandwidth. Previously i get 700Kb/s-1,2Mb/s. Now it's only around 100-200kb/s so it's stuttering the playback. Even for tv shows.

I upgraded to 2.1 yesterday, but sometimes it still exist. Maybe i need to upgrade my router to AE 802.11n and hopefully everything is going to be fine.
msantoso is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Suddenly, captured videos have no picture!!! JBullProduction Digital Video 3 Oct 28, 2013 03:39 PM
ATV Not Playing Video Content from iTunes Library u1stafterme Apple TV and Home Theater 8 Mar 6, 2013 09:34 PM
Playing M4V without ATV jjk454ss Apple TV and Home Theater 9 Jan 15, 2013 09:50 AM
Playing iTunes videos on other video playing software LordMoe Mac Applications and Mac App Store 0 Aug 21, 2012 08:06 PM

Forum Jump

All times are GMT -5. The time now is 02:23 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC