Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Accessories

Reply
 
Thread Tools Search this Thread Display Modes
Old Jul 15, 2008, 11:12 AM   #1
mechasquid
macrumors newbie
 
Join Date: Mar 2008
iPhone 3G + AV Cable = no video?

Am I doing something wrong here?

I have a third party AV Cable plugged from my iphone (headphone jack) and the three other parts of the cable into the TV (red/yellow/white).

Audio comes through fine, but no picture, the cable i am using is "For iPod" so i am wondering if the iPhone formats the image differently and I need a new cable?

Any advice? and does anyone think this cable will work on an iPod Nano? If so i shall pass it on to my girlfriend
mechasquid is offline   0 Reply With Quote
Old Jul 15, 2008, 11:24 AM   #2
sadfaceman
macrumors newbie
 
Join Date: Jul 2008
The new iPhone is probably like most newer iPods - requiring a proprietary A/V cable from apple that has a specific chip in it to authenticate. Only these Apple cables will work. sorry
sadfaceman is offline   0 Reply With Quote
Old Jul 15, 2008, 11:39 AM   #3
mechasquid
Thread Starter
macrumors newbie
 
Join Date: Mar 2008
damn!
no worries, was a cheapo one from Amazon anyway!
mechasquid is offline   0 Reply With Quote
Old Jul 15, 2008, 11:44 AM   #4
iPhoneUser-No-X
macrumors newbie
 
Join Date: Jul 2008
Version 2.0 seems to be the Problem!!!

I do haven an old iPhone > Updated now to Software Version 2.0!

NEITHER Universal Dock works, nor composite Cable, that have been working prior to the upgrade. The same issue: Audio works, NO VIDEO!!!! I do have original APPLE Cables.

Furhermore iPhone tells me, when connecting to either, "This Equipment is not made for iPhone - do you want to switch to Flight mode"! (has also not been the case before).

The Software seems to be the problem!
Can somebody help?

Last edited by iPhoneUser-No-X; Jul 15, 2008 at 11:57 AM.
iPhoneUser-No-X is offline   0 Reply With Quote
Old Jul 15, 2008, 01:03 PM   #5
DeuceDeuce
macrumors 6502a
 
DeuceDeuce's Avatar
 
Join Date: Aug 2007
Location: San Dimas, CA
Under settings you have to turn on TV support.
DeuceDeuce is offline   0 Reply With Quote
Old Jul 16, 2008, 02:43 AM   #6
iPhoneUser-No-X
macrumors newbie
 
Join Date: Jul 2008
Quote:
Originally Posted by DeuceDeuce View Post
Under settings you have to turn on TV support.
Sorry, there is NO Option TV-SUPPORT, where should this be?
I hobe you do not mean under "Settings > iPOD > Widesreen/PAL!"
because this is what I am already using - and it does not work!

Last edited by iPhoneUser-No-X; Jul 16, 2008 at 02:49 AM.
iPhoneUser-No-X is offline   0 Reply With Quote
Old Jul 16, 2008, 05:22 PM   #7
jaydoc05
macrumors newbie
 
Join Date: Jul 2008
I think the setting needs to be NTSC, as the other setting is for Europe
jaydoc05 is offline   0 Reply With Quote
Old Jul 17, 2008, 02:29 AM   #8
iPhoneUser-No-X
macrumors newbie
 
Join Date: Jul 2008
Quote:
Originally Posted by jaydoc05 View Post
I think the setting needs to be NTSC, as the other setting is for Europe
I am from Europe - this is why Im usinīPAL > but it does not work!
Anybody some suggestion?
iPhoneUser-No-X is offline   0 Reply With Quote
Old Jul 17, 2008, 04:29 AM   #9
page3
macrumors regular
 
Join Date: Feb 2003
Location: England, UK
Quote:
Originally Posted by iPhoneUser-No-X View Post
I do haven an old iPhone > Updated now to Software Version 2.0!

NEITHER Universal Dock works, nor composite Cable, that have been working prior to the upgrade. The same issue: Audio works, NO VIDEO!!!! I do have original APPLE Cables.
After reading this, I have just goes and tried the Apple composite cable on an original iPhone (V2 software) and all seems to be working fine.
page3 is offline   0 Reply With Quote
Old Jul 22, 2008, 12:17 AM   #10
dgalvan123
macrumors 6502a
 
Join Date: Feb 2008
I am having the same problem. I purchased this cable on ebay:
http://cgi.ebay.com/ws/eBayISAPI.dll...m=250268585597
and it arrived today.

It said it would be compatible with "iPod Classic, Nano (video), touch, and iPhone".

But it sure as heck doesn't work with my iPhone 3G. Audio gets through but no video.

What's more, the iPhone 3G actually pops up a message telling me: "This accessory is not compatible with iPhone. Do you want to turn on airplane mode to reduce interference?" And then I can choose yes or no. Choosing either doesn't get me video.

Is apple really being so jerky that they install a chip that FORCES you to only buy their over-priced $50 cables from the apple store? Unbelievable. What are they, run by a bunch of Ferenghi?

UPDATE:

I tried it again a little later, and was surprised to see that video was working! Great, I thought. But after about 2 minutes of flawless playback on the TV, the iPhone just quit playing that video and went back to the video selection screen where I had chosen the video. That is, the iPod app did not crash because iPhone didn't go back to the homescreen. It's just the video stopped playing. And then I couldn't get the video to play on the TV again. After unplugging and replugging the cable several times, I got another video to start playing on the TV, and again after just a minute or so it stopped.

Also, several times I got a message on the iPhone 3G: "This accessory not made to work with iPhone." but it's supposedly compatible with iPhone!

I wonder if this is a problem with this particular cable, or if it's a bug in the iPhone 3G, or if Apple has somehow made it so that we can only use their particular AV cable?

Seeing as how I only paid $16 including shipping for this cable, it's not a huge deal, but I want to make sure that the iPhone 3G should be able to output TV properly before I fork over $50 for the apple-blessed cable. When the video connection WAS working, the video and audio were great. No flaws, no interference (I had the iphone in Airplane mode for some of the time, but the first time I got the video to play on the TV, it was NOT in Airplane mode).

My hunch is that there's an iPhone 3G bug. But if someone is able to output video to a TV from the iPhone 3G without problems, I'd love to be proven wrong.

Last edited by dgalvan123; Jul 22, 2008 at 02:26 AM.
dgalvan123 is offline   0 Reply With Quote
Old Jul 22, 2008, 02:50 AM   #11
mrparis
macrumors newbie
 
Join Date: Jul 2008
I purchased the Apple Component Cable from Tesco a lot of months back when they where selling them for £17

http://direct.tesco.com/q/R.202-1321.aspx

When connected into the Iphone 3g I can play videos direct to my Samsung LCD without problems. In fact just after watching 'Vantage Point'. However not experiencing any issues that you guys seem to have, but wondering is that because I'm using the Component Cables, not composite.

One error I do seem to get however is that when attempting to play music I get no audio. However if I go into photo's and play a slideshow the photo's display and the music plays. All very odd. Here's another link from Apple support forums with similar issues.

http://discussions.apple.com/thread....97478&tstart=0

Hope you get is resolved guys. Mine ain't as bad, but I'm still miffed that I can't play tunes through the TV
mrparis is offline   0 Reply With Quote
Old Jul 23, 2008, 02:36 AM   #12
iPhoneUser-No-X
macrumors newbie
 
Join Date: Jul 2008
Hi again,

I do have following equipment iPhone Version 1, Firmware 2.0.
Before I updated to 2.0
- Video + Audio > worked fine with the latest Apple AV-cable
- Video + Audio > worked the latest Docking Station (with the IR eye like a line)
!!! did NOT work with the old DOCK (with S-Video Out) !!!

Now after Update
- Old DOCK >> WORKS with S-Video Out >>> NO Sound does work
(same with Apple AV Cable)
- New DOCK >> NO Video works >>> but Audio works

iPHONE says " Equipment not built for iPhone"
- with the NEW DOCK!!!???Chaos!

Sombody has an idea how to solve?
iPhoneUser-No-X is offline   0 Reply With Quote
Old Jul 23, 2008, 08:53 AM   #13
sengoku
macrumors newbie
 
Join Date: Jul 2008
same problem

I have the same problem since upgrading to 2.0 from 1.1.4. I purchase an av cable from hong kong.

http://cgi.ebay.co.uk/ws/eBayISAPI.d...m=380042030092

After upgrading to 2.0 with my cable plugged in i no longer recieve a message display on tv "yes/no" when playing a video. I can occasionally get audio and if i swap it from pal to ntsc and then back again it seems to play video for about 30 seconds. or recieve a message that this accessorie is not compatible would i like to change to airplane mode to cut background interference, well this is complete tosh it solves nothing. Now if this was a microsoft operating system it would give u a relevant error message and a complete stack trace to where the error is occurring. Coccoa Mobile is a great advance but still very imature and more technical people struggle to gain control over a OS built for nothing but user friendlyness. We want confusing options, we the ability to tinker its in our nature were human.

After many hrs downgrading my iphone to 1.1.4 video plays first time no issues, which really isnt an easy task, I'm a developer god knows what less technical people will do.

Id love to hear some has a solution or workarround/hack for unofficial apples cables. After doing many test i do not believe this issue is related to pwnage tool in any way. But firmware 1.2.0. I have tried it on both my 1st gen iphone running 2.0 unlocked and jailbroken, and my shiny new 3g same result both refuse to play video using a 3rd party cable.
sengoku is offline   0 Reply With Quote
Old Jul 23, 2008, 01:46 PM   #14
dgalvan123
macrumors 6502a
 
Join Date: Feb 2008
As far as I can tell, there are currently no third-party AV cables that will work with the iPhone 3G.

The one I bought from Hong Kong had the problems I mentioned above.

This morning I searched on ebay specifically for "iPhone 3G AV cable" and found one that claimed to work with the new iPhone 3G:
http://cgi.ebay.com/Composite-AV-TV-...QQcmdZViewItem

It even says it will work in the title.

But I e-mailed the seller and asked if they'd actually tested it with the iPhone 3G to see if it worked. This is the reply I got back via e-mail:
"Dear Buyer,

It was an error on our post. It will not work with the new iPhone 3g.

Thank you."

If it is something in the iPhone 2.0 software that is causing these cables not to work, I hope they release an update soon. I do not want to pay $50 to Apple for a cable that should cost $10.
dgalvan123 is offline   0 Reply With Quote
Old Aug 25, 2008, 07:41 AM   #15
Dr. Cabrera
Banned
 
Join Date: Aug 2008
Location: Los Angeles
Send a message via AIM to Dr. Cabrera
same here, no luck even with the new 50 dollar cables i have 2.02
Dr. Cabrera is offline   0 Reply With Quote
Old Sep 4, 2008, 12:36 PM   #16
nkapur
macrumors newbie
 
Join Date: Sep 2008
Here's one that seems to work

I had the same experience with a previous AV cable from eBay - video would stop after a few seconds. I just got one of these and it works fine. No warning message and video played flawlessly for about 5 minutes before I put it off.
http://cgi.ebay.com/Composite-AV-TV-...QQcmdZViewItem

This cable is one which also has a USB connector so you can charge while using the cable. One minor problem that I do see is interference when plugged into the car's power connector. I plan to use a different connector with a USB extension to see if that fixes the problem.
nkapur is offline   0 Reply With Quote
Old Feb 5, 2009, 09:40 AM   #17
Habakuk
macrumors 6502a
 
Join Date: Jul 2007
Location: Vienna Austria Europe
Bought an Apple AV composite cable (part number MB129ZA/B) at Apple Store. Tried it with an iPhone 3G and iPod touch (latest generations, firmware 2.2.1) and two television sets (Loewe Concept digital 2 years old, hd ready, Sony analogue/tubes 6 years old).

With the iPhone I am getting the "device not made for iPhone 3G - turn on airplane mode" warning on the iPhone display (although the cable is defenitely specified for iPhone 3G according to Apple Store). With all combinations I'll get only audio but no video (movies, pictures of the camera roll). The TV screen stays black, the Loewe brings up a message "No signal".

Spoke with Apple Support and they will change the cable just to be sure that it is not a manufacturer's defect.

My question: Has anyone got the Apple composite cable to work?

Additional info: http://discussions.apple.com/thread....sageID=8539648
__________________
Hurry up! Selected & time-limited iOS App Store FREEbies and sales
(German-language blog; but you'll find all links, pics and videos)
Habakuk is offline   0 Reply With Quote
Old Feb 9, 2009, 05:25 AM   #18
Habakuk
macrumors 6502a
 
Join Date: Jul 2007
Location: Vienna Austria Europe
Quote:
Originally Posted by Habakuk View Post
Bought an Apple AV composite cable (part number MB129ZA/B) at Apple Store...
I've got an exchange cable (BTW - incredible how fast the Apple Store and the delivery is). And - it works!

Audio AND VIDEO. Both on iPhone and iPod touch (latest generations, latest OS) with all TV sets. Obviously it was a manufacturer's (made in China) defect with the first cable. The new cable and all components inclusive packaging and numbers on several stickers look exactly the same like the first one.
__________________
Hurry up! Selected & time-limited iOS App Store FREEbies and sales
(German-language blog; but you'll find all links, pics and videos)
Habakuk is offline   0 Reply With Quote
Old Feb 11, 2009, 04:56 AM   #19
dnnny
macrumors newbie
 
Join Date: Feb 2009
solution

Hi there.

Plugging the AV cable into the TV Youíre probably thinking that you donít need help doing this one. Well let me tell you, you do. Since Apple wants you to buy their proprietary cable, they decided to be sneaky. They send the video over the Red RCA cable (usually yellow). Therefore, they send the audio over the white and yellow cables. Oh youíre so tricky Apple, whatever will we do? In easier words, do the following: Red RCA plug -> TVís yellow RCA jack Yellow RCA plug -> TVís white RCA jack White RCA plug -> TVís red RCA jack
If you can believe it, thatís all you have to do. Pretty much the only tricky thing was switching the Red and Yellow RCA cables. Enjoy.

UPDATE: Weíve been informed this method works for the iPhone as well. Just plug the RCA cable into your old school iPod dock, set your iPhone in the dock, and you should be golden.
dnnny is offline   0 Reply With Quote
Old Feb 20, 2009, 03:44 PM   #20
Amaj10
macrumors newbie
 
Join Date: Jan 2005
When hooked up correctly does the iPhone only output video from the iPod app, or will the tv mirror anything that's on the iPhone screen??
Amaj10 is offline   0 Reply With Quote
Old Feb 20, 2009, 10:26 PM   #21
Habakuk
macrumors 6502a
 
Join Date: Jul 2007
Location: Vienna Austria Europe
Quote:
Originally Posted by Amaj10 View Post
When hooked up correctly does the iPhone only output video from the iPod app, or will the tv mirror anything that's on the iPhone screen??
From http://forums.macrumors.com/showthread.php?t=597640

Quote:
Video output is currently only supported by three programs

Youtube
Ipod Video
Ipod Photos

No other programs, events, messages, screens, etc will display video
__________________
Hurry up! Selected & time-limited iOS App Store FREEbies and sales
(German-language blog; but you'll find all links, pics and videos)
Habakuk is offline   0 Reply With Quote
Old Mar 18, 2009, 03:49 PM   #22
georgehp
macrumors newbie
 
Join Date: Mar 2009
Now there are 3e party cables availible that will work.

I got my cable for just under $12 (incl. shipping)

and it works great with my iPhone 3g and my old Nano (3e gen).
I first tried some different cables that all didn't work but the one i found now works like it should and it even has a USB connector so that i can charge when i am watching a movie.

You can see the cable I got at http://www.coolusbtoys.com/silver-av...for-iphone-3g/
georgehp is offline   0 Reply With Quote
Old Mar 19, 2009, 05:03 AM   #23
Dr. Cabrera
Banned
 
Join Date: Aug 2008
Location: Los Angeles
Send a message via AIM to Dr. Cabrera
Quote:
Originally Posted by georgehp View Post
Now there are 3e party cables availible that will work.

I got my cable for just under $12 (incl. shipping)

and it works great with my iPhone 3g and my old Nano (3e gen).
I first tried some different cables that all didn't work but the one i found now works like it should and it even has a USB connector so that i can charge when i am watching a movie.

You can see the cable I got at http://www.coolusbtoys.com/silver-av...for-iphone-3g/

My iPhone got stolen, but once I can afford a new one, I'll purchase this cable and add it to my A/V cable thread
Dr. Cabrera is offline   0 Reply With Quote
Old Jul 25, 2009, 06:48 PM   #24
ccandas
macrumors newbie
 
Join Date: Jun 2009
Quote:
Originally Posted by georgehp View Post
Now there are 3e party cables availible that will work.

I got my cable for just under $12 (incl. shipping)

and it works great with my iPhone 3g and my old Nano (3e gen).
I first tried some different cables that all didn't work but the one i found now works like it should and it even has a USB connector so that i can charge when i am watching a movie.

You can see the cable I got at http://www.coolusbtoys.com/silver-av...for-iphone-3g/
Went to this website and it mention that this cable DOESN'T WORK ANYMORE with the 3.0 software realease... To bad!
ccandas is offline   0 Reply With Quote
Old Aug 22, 2009, 09:27 AM   #25
madman604
macrumors newbie
 
Join Date: Aug 2009
try this if you have 3rd party cables and are running firmware 3.0 or lower

http://www.youtube.com/watch?v=gwVfO9mCG_Q
madman604 is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Accessories

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Help Needed: What cable for 5S video to TV? bking1000 iPhone Accessories 5 Oct 9, 2013 11:42 AM
looking for iphone video cable (video only, no sound) zwodubber iPhone Accessories 4 Nov 26, 2012 10:16 PM
lightning cable vs old iphone cable cpnotebook80 iPhone 3 Sep 30, 2012 09:22 AM

Forum Jump

All times are GMT -5. The time now is 02:45 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC