Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone

Reply
 
Thread Tools Search this Thread Display Modes
Old Aug 8, 2008, 10:18 AM   #1
lego8
macrumors regular
 
Join Date: Mar 2008
Question iPhone adding country code?

Hi,

My iPhone is adding the US country code (+1) to all the phone numbers on it, and also on Google Maps.

In iTunes, my phone number appears as 1 (xxx) xxx-xxxx

How do I remove this? I don't want to see the country code, and I don't know why it's appearing. Does anyone know how to resolve this?
lego8 is offline   0 Reply With Quote
Old Aug 8, 2008, 12:03 PM   #2
Ntombi
macrumors 68020
 
Ntombi's Avatar
 
Join Date: Jul 2008
Location: Bostonian exiled in SoCal
Quote:
Originally Posted by lego8 View Post
Hi,

My iPhone is adding the US country code (+1) to all the phone numbers on it, and also on Google Maps.

In iTunes, my phone number appears as 1 (xxx) xxx-xxxx

How do I remove this? I don't want to see the country code, and I don't know why it's appearing. Does anyone know how to resolve this?
Settings>Phone>International Assist OFF.

It thinks you're abroad, for some reason. I don't know where you are, but it thinks you have an American phone, and are now outside the country. Anyway, turn off International Assist, and it will no longer be an issue.
__________________
2.53 GHz 13" MacBook Pro iPod Classic 64GB Black iPhone 5
Switching to AT&T? PM me for a $25 gift card!
Ntombi is offline   0 Reply With Quote
Old Aug 8, 2008, 05:40 PM   #3
lego8
Thread Starter
macrumors regular
 
Join Date: Mar 2008
Lightbulb

I turned off International Assist and "1"-- the country code-- still remains.
Here are some screen shots. Please help me fix this.






Last edited by lego8; Aug 8, 2008 at 05:58 PM.
lego8 is offline   0 Reply With Quote
Old Aug 8, 2008, 09:06 PM   #4
lego8
Thread Starter
macrumors regular
 
Join Date: Mar 2008
Anyone?
lego8 is offline   0 Reply With Quote
Old Sep 9, 2008, 01:43 PM   #5
cdefelice
macrumors newbie
 
Join Date: Sep 2008
Did you ever figure out how to fix this? I am having the exact same issue. As far as I can tell, it didn't happen until I synced my contacts with Microsoft Outlook 2007. I really want to get rid of the stupid 1 in front of all my numbers. It is incredibly irritating...
cdefelice is offline   0 Reply With Quote
Old Sep 17, 2009, 11:10 AM   #6
todd.scallions
macrumors newbie
 
Join Date: Sep 2009
Sorry to resurrect an such an old thread, but I am having the same issue. It's not related to the phone or the SIM card. It's something on AT&T's side that is causing this to happen and they are not going to do anything about it because they say it is a non-issue (which it is). I do find it extremely annoying and wish they would look into it a little further than what they did. At this point, the only way I can resolve it is to get a new phone number which I am not going to do. When I spoke to Tier 3 tech support, I told them that my wife's iPhone, my mom's, and five of my friends iphone do not do this so why mine. Their response: they have two iphone's there in the office that are doing it so it must be normal. But I do agree, it is SO freaking annoying! Also, something new changed with my Vonage account. When my wife calls me from home it shows up as 11901#######. Vonage is sending out the country code with outgoing caller ID and since whatever "non-issue" AT&T has going on that's adding the +1 country code to all my incoming calls, that explains why I am getting two 1's in front of the incoming call. So if I touch that number in my recent call list, the call doesn't go through because it has two country code's in front of the local number. Man this sucks!
todd.scallions is offline   0 Reply With Quote
Old Nov 16, 2010, 07:44 PM   #7
Resist
macrumors 68030
 
Join Date: Jan 2008
I'm bringing this thread back to life again, as I am having the same issue. All my contacts are in the United States, so I don't need them to listed as such. How can you remove the country out of contacts?
Resist is offline   0 Reply With Quote
Old Nov 23, 2010, 09:57 PM   #8
clayj
macrumors 604
 
clayj's Avatar
 
Join Date: Jan 2005
Location: 1123,6536,5321
Quote:
Originally Posted by Resist View Post
I'm bringing this thread back to life again, as I am having the same issue. All my contacts are in the United States, so I don't need them to listed as such. How can you remove the country out of contacts?
I have the same problem -- none of my US contacts show "United States" or "United States of America" in Outlook or Entourage, but now they are all showing "United States" on both my iPad and my iPhone. This is EXTREMELY annoying. I don't want a country to show unless one is specifically defined in the contact in Outlook/Entourage.
__________________
mac pro 2.8ghz 8-core 24gb ram 16tb hd 30" acd | 2014 macbook pro 2.8ghz 16gb ram 256gb ssd | mac mini 2.4ghz c2d | ipad air at&t 128gb space gray | ipad 2 wifi 16gb black | iphone 5 at&t 64gb black
clayj is offline   0 Reply With Quote
Old Aug 18, 2011, 02:27 PM   #9
jc.sutherland
macrumors newbie
 
Join Date: Aug 2011
Oposite Problem

I actually have the reverse problem. Here in Canada I need the 1 in front of the number to call long distance. However when I uploaded all my contacts from my server, they come up as (XXX)XXX-XXXX. How do I add the 1?
jc.sutherland is offline   0 Reply With Quote
Old Sep 27, 2011, 12:20 AM   #10
monse120186
macrumors newbie
 
Join Date: Sep 2011
I had this issue today. It was very simple to fix, what I did was I used an at&t sim to acces the international assist setting, disabled it, restarted the phone (I'm using a gevey sim, my carrier is iusacell) and that was it. Hope it helps.
monse120186 is offline   0 Reply With Quote
Old Dec 6, 2011, 04:49 PM   #11
Eminent01
macrumors newbie
 
Join Date: Dec 2011
I noted the issue of phone calls, SMS & MMS messages starting to come in with phone numbers only and not resolving to contacts. They began to display +1 in front of the number which was the caller ID, Verizon provide in what seemed to be in a new format. Even thought the contacts already had the number in their profile, they all did not have 1's in front of their number.

I worked with Apple support and my issue seemed to be specific to Verizon. I corrected the issue by call *228 and use option #1 to program your phone again.

The fix was not immediate and after 3-5 minutes my phone numbers in recent calls did indeed resolve to a name versus just displaying the number. I also noted the SMS/MMS messages did not truncate or combine, though new messages did resolve to a name.

Hope this helps you!
Eminent01 is offline   0 Reply With Quote
Old Dec 6, 2011, 11:18 PM   #12
Sunday Shadows
macrumors regular
 
Join Date: Jun 2010
Im having issues with phone calls showing up as +XX XXXX-XXXX

anyone know how to fix this? i've been on the phone with apple and att over 5 hours now.

it only seems to be happening with cricket wireless customers, i've swapped sims, updated/restore/etc, added and deleted contacts, on/off international assist, tried different iphones...you name it i've done it.

it never happened with my 4, just my since i purchased the 4s.

really annoying because anyone that is on my contact list doesn't show up as a contact just a 'international caller'
Sunday Shadows is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iOS7 is letting me block callers by country code alone FreeState iOS 7 12 Sep 6, 2013 07:58 PM
Can Country Code Be Removed From Contacts App on Macbook? zumandrew Mac Programming 1 Mar 3, 2013 02:42 PM
Where is the "wifi country code" information and Can it be fixed or changed? dutkutug OS X 10.8 Mountain Lion 4 Dec 3, 2012 01:58 PM
iPhone can be buy from other country and use in another country? kkrysia iPhone 1 Nov 13, 2012 01:26 PM
Order an iTunes Gift card from any country and shipping to any country? windrider07 iPhone and iPod touch Apps 2 Oct 5, 2012 04:05 AM

Forum Jump

All times are GMT -5. The time now is 05:32 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC