Go Back   MacRumors Forums > iPhone, iPod and iPad > iOS > Jailbreaks and iOS Hacks

Reply
 
Thread Tools Search this Thread Display Modes
Old Aug 20, 2008, 10:40 PM   #1
elfenlied102938
macrumors newbie
 
Join Date: Aug 2008
iPhone won't wake up from standy/sleep unless I press Menu+Power buttons...

Hi,
I recently upgraded my 2G iPhone from FW (Firmware) 1.02 to 2.0.1 using WinPwn2.0.4. Everything installed fine, and I can use ALL the features of iPhone 2.0.1 without any errors. I have Cydia, Installer 4.0beta, BootNeuter pre-installed, and I installed BossPrefs to turn off EDGE.

However, every once in a while (~once a day), when the phone is in standby/sleep (when the screen turns off after it is left alone), it refuses to wake up from that state. It usually wakes up with either power or menu button, but none of the buttons turns it on. In fact, even holding down the power button for ~10seconds won't turn on.

The only way I can turn it back on is through the "DFU button combinaton"; if I press both power and menu buttons at the same time for ~10seconds, it turns on and everything is back to normal (as if nothing bad happened). This is bad for me, because this happens randomly and I can miss calls from people...

Has anyone encountered this problem? Could it be a winpwn2.0.4 / Cydia / installer / BossPrefs issue?
elfenlied102938 is offline   0 Reply With Quote
Old Aug 27, 2008, 01:37 PM   #2
nanoflux
macrumors newbie
 
Join Date: Aug 2008
I'm experiencing this same problem and have been since I updated to 2.0 (and beyond).

I've tried several different combinations to try and figure out what's happening--turning off wifi, playing with different auto-lock settings, etc.

The problem seems to get worse over time--when I do a fresh install of a firmware, it's all good for a few days--then this problem starts occuring.

My configs:
- Jailbroken / Unlocked: Running on T-Mobile US or China Mobile (depends on which country I'm in)

- 1 Gmail Account

- 1 Exchange account which requires password, syncing contacts, cal, and mail
nanoflux is offline   0 Reply With Quote
Old Sep 1, 2008, 04:48 PM   #3
elfenlied102938
Thread Starter
macrumors newbie
 
Join Date: Aug 2008
Yeah, when I do a fresh re-pwn (currently pwned to FW 2.0.2 using WinPwn 2.5, the phone doesn't "die" as often as it does after a few days. It is really annoying since you can't pick up calls and you never know when it died. Pressing MENU + POWER is also annoying everytime you restart.

I think this could me some kind of leakage issue (gets worse over time). Maybe I should have revirginized it before using WinPwn? I used some strange method 10 months ago to jailbreak/unlock it to FW 1.02 (iUnlocker, iBrikr, PayCay) under the title "17 minutes" by username carlosvaldosta in Hackintosh (http://hackint0sh.org/forum/showthread.php?t=6637). I wonder if that has to do with the problem.

Any help would be appreciated. Thanks.
elfenlied102938 is offline   0 Reply With Quote
Old Sep 2, 2008, 09:36 AM   #4
mikkelmeister
macrumors newbie
 
Join Date: Sep 2008
Unhappy Same problem here

Hi
I have the exact same problem.
I also tried different things to pinpoint the issue (turning of push, autolock, pincode etc), but like you, none of it seems to help.
Right now, I running the iPhone with no additional apps from appstore, installer or Cysia, but still it hangs on me every other day.
The only sure thing so far, is that it doesn't hang while I use it.
I have tried all the 2.0.x firmware versions and have had the problem on all 3 versions. I'm really hoping Apple will fix this in later versions.
Along with the much slower performane in 2.0.x I'm tempted to to back to 1.1.4. I wont have push and appstore, but at least my dear iPhone will function and perform like it's supposed to.
mikkelmeister is offline   0 Reply With Quote
Old Sep 6, 2008, 01:52 AM   #5
elfenlied102938
Thread Starter
macrumors newbie
 
Join Date: Aug 2008
Cool

Yeah, if there are more of us having the same issue we should notify the Dev Team for this little bug so that they can fix it in the next Pwnage Tool
elfenlied102938 is offline   0 Reply With Quote
Old Sep 7, 2008, 05:50 AM   #6
nanoflux
macrumors newbie
 
Join Date: Aug 2008
Any idea how one goes about notifying the Dev Team?

Judging from the rather commonplace scenario that this is occurring, I feel that it has something to do with the unlock process--possibly residual from earlier version unlocks. I tried a few things here last night with limited success.

My phone was 1.0.2 OTB and brought forward to each iPhone version. I believe I used iBrickr originally, then anySIM with 1.1, and ZiPhone for later versions.

I spent a bunch of hours last night trying to get a better understand of the early unlock processes. Many of these relied on modifying the seczone in the baseband which controls the radio. Considering that this problem occurs without reproducible user steps or with a set combination of programs installed, it seems likely that it's triggered by some radio communication stuff that's in the background.

It's not clear to me whether subsequent updates have reflashed and renewed the baseband naturally.

Back in 1.0.2 to 1.1.1 there was a process of re-virginizing that would repair the seczone and reflash the baseband. I tried to get my iPhone all the way down to 1.0.2, but old tools, links, and most problematic, getting the right version of iTunes made this impossible. I was able to get down to 1.1.1, but the re-virginizer tools don't work against this version.

I ended up going to 1.1.4 and running the "Erase 3.9 Baseband" option out of ZiPhone, which presumably reflashes the baseband to the original state. This re-locked the phone and un-did Pwnage. However, some of the reading I've done indicates that re-flashing the baseband doesn't renew the seczone, so I'm not sure if I accomplished what I wanted.

I then repwned straight to 2.0.2 and thus far, everything is OK...but sometimes it takes a few days for the problem to re-appear.
nanoflux is offline   0 Reply With Quote
Old Sep 7, 2008, 09:56 AM   #7
nanoflux
macrumors newbie
 
Join Date: Aug 2008
0wned. After all those hours, problem still repros.
nanoflux is offline   0 Reply With Quote
Old Sep 14, 2008, 05:26 PM   #8
mikkelmeister
macrumors newbie
 
Join Date: Sep 2008
Same problem on 2.1

Saturday I updated to 2.1, and the problem still occurs
2.1 seems much faster though...
mikkelmeister is offline   0 Reply With Quote
Old Sep 17, 2008, 10:27 PM   #9
akilucky
macrumors newbie
 
Join Date: Sep 2008
Same problem on new and locked Iphone

I just bought one and having the same problem, yet i didn't try unlocking or jailbreaking it... Tryed 2.0.x and 2.1, same no difference...
Even on genuin Iphones there is the same problem!
Sometimes it is possible to wake it up without restart by connecting it to a pc/mac... But it doesn't always work.
May be it is hardware problem, rather than soft? But if some peaple didn't have this on older software...
Another BIG quastion to Mr. Jobbs i guess...
akilucky is offline   0 Reply With Quote
Old Sep 29, 2008, 11:01 PM   #10
exalted719
macrumors member
 
Join Date: Sep 2008
I also have this issue.
I used quick pwn with 2.1 unlocked.
My phone is a replacement phone from apple.. its 2 days old..

anyone find a solution?
exalted719 is offline   0 Reply With Quote
Old Sep 30, 2008, 02:11 AM   #11
domness
macrumors 6502a
 
domness's Avatar
 
Join Date: Jan 2008
Location: Sheffield, UK
I've had this issue with or without Jailbreaking. It's happened on both of my iPhones.

For me it seems the issue only crops up every few days, nothing major, but it's annoying when someone asks to check out your phone and you have to restart it.
domness is offline   0 Reply With Quote
Old Sep 30, 2008, 04:13 PM   #12
exalted719
macrumors member
 
Join Date: Sep 2008
Quote:
Originally Posted by domness View Post
I've had this issue with or without Jailbreaking. It's happened on both of my iPhones.

For me it seems the issue only crops up every few days, nothing major, but it's annoying when someone asks to check out your phone and you have to restart it.
And you have the iPhone 3G?
Are you unlocked?

Also, you realize that when it happens, all incoming calls will ring on the callers end, but your iPhone will not ring or respond to any buttons.

Has anyone found a solution?
exalted719 is offline   0 Reply With Quote
Old Oct 1, 2008, 07:18 AM   #13
pj rage
macrumors 6502
 
Join Date: Jul 2008
I've had this problem 2 or 3 times. Happens once every 2-3 weeks or so. I have no idea what causes it (seemingly nothing?). It's almost like the phone isn't actually off - it's like the screen itself is off. That's why holding the power button does nothing. The OS probably thinks it's displaying the slide to power off screen when you hold it, but the only way to turn off the phone without the screen input (to my knowledge) is to hard power down /restart (ie, hold the home and power buttons together).

Next time this happens to me, I may run a couple tests where I'll call my phone to see what happens (does it ring?), and also, I'll try holding the home/power buttons long enough to cause the phone to go OFF, but not long enough to have it turn back on (this is possible, I just don't know the exact timing). Then I could try turning the phone on normally with only the power button.

Again, I don't know what causes the issue, but I'm pretty sure the phone isn't ACTUALLY "off" when it's occurring.
pj rage is offline   0 Reply With Quote
Old Oct 1, 2008, 04:01 PM   #14
exalted719
macrumors member
 
Join Date: Sep 2008
Quote:
Originally Posted by pj rage View Post
I've had this problem 2 or 3 times. Happens once every 2-3 weeks or so. I have no idea what causes it (seemingly nothing?). It's almost like the phone isn't actually off - it's like the screen itself is off. That's why holding the power button does nothing. The OS probably thinks it's displaying the slide to power off screen when you hold it, but the only way to turn off the phone without the screen input (to my knowledge) is to hard power down /restart (ie, hold the home and power buttons together).

Next time this happens to me, I may run a couple tests where I'll call my phone to see what happens (does it ring?), and also, I'll try holding the home/power buttons long enough to cause the phone to go OFF, but not long enough to have it turn back on (this is possible, I just don't know the exact timing). Then I could try turning the phone on normally with only the power button.

Again, I don't know what causes the issue, but I'm pretty sure the phone isn't ACTUALLY "off" when it's occurring.
Do you have 2G or 3G iPhone?

If you call it, the phone will recieve the call but will not ring to respond to any buttons. The called will get a ringing tone, eventually going to voicemail because you couldnt answer. Taking out the SIM and putting it back in causes the iPhone to not recieve calls at all.

I spoke to a knowledgable individual and he said that it is caused by a ribbon cable inside the iPhone. This problem occurs if you have dropped the phone or due to a manufacturing defect like me.
exalted719 is offline   0 Reply With Quote
Old Oct 1, 2008, 10:44 PM   #15
EmNat
macrumors newbie
 
Join Date: Oct 2008
The problem can be fixed as below:

1. OpenSSH/WinSCP into Iphone then go to:
\System\Library\SystemConfiguration\PowerManagement.bundle

2. Find the file:
com.apple.SystemPowerProfileDefaults.plist
Then rename it to:
com.apple.SystemPowerProfileDefaults.plist2

3. Reboot your phone
EmNat is offline   0 Reply With Quote
Old Oct 3, 2008, 03:47 AM   #16
elfenlied102938
Thread Starter
macrumors newbie
 
Join Date: Aug 2008
Hi EmNat,
I guess you had this problem too before and now it looks like you have a solution.

I don't have a mac. How do I do the same procedure using a PC?

Thanks.

PS. What's the theory behind this fix? Exalted719 mentioned that it is a hardware issue...
elfenlied102938 is offline   0 Reply With Quote
Old Oct 3, 2008, 05:12 AM   #17
EmNat
macrumors newbie
 
Join Date: Oct 2008
Hi elfenlied102938,

My iPhone had this problem since the iPhone's camera started to crash everytime I opened it. Fortunately, I found this fix from a person who had the same problem.
If you're not familiar with using OpenSSH/WinSCP then this guide may be able help you to change the file name:
http://limitededitioniphone.com/wind...p-with-iphone/
EmNat is offline   0 Reply With Quote
Old Oct 4, 2008, 01:21 AM   #18
nanoflux
macrumors newbie
 
Join Date: Aug 2008
I don't believe that my particular case is a hardware issue (though some might be).

My phone works perfectly well on 1.1.4 and this problem had manifested itself as early as the leaked-2.0 builds for me. Reverting to 1.1.4 had resolved the problem.

I've been trying to correlate the problem without much success, though I feel like it happens more often when the battery is less than fully charged and when I leave a notification up on the screen (e.g. SMS or Calendar reminder).

I'm pretty sure that the problem is in software and the power management plist hack sounds like a good course to follow. I'll give it shot today.
nanoflux is offline   0 Reply With Quote
Old Oct 4, 2008, 09:48 PM   #19
jonasmae
macrumors newbie
 
Join Date: Oct 2008
Does anyone here fix your problem with that setup? please let me know so i can try. Thanks
jonasmae is offline   0 Reply With Quote
Old Oct 5, 2008, 12:40 AM   #20
nanoflux
macrumors newbie
 
Join Date: Aug 2008
So far, so good. Smarter minds will have to tell you what exactly disabling the power management prefs actually do (maybe forces some set of defaults?) but everything is working well so far.

I'll post an update in a few days, the repro of the problem isn't daily.
nanoflux is offline   0 Reply With Quote
Old Oct 5, 2008, 03:02 AM   #21
Wolfmore
macrumors member
 
Join Date: Sep 2008
I've got this problem too. Has happened about 3 times since I pwned with 2.1. I don't think it happened pre-jailbreak. For the record it is totally worth it to Jailbreak...Thanks to the DevTeam. Last time I was able to wake my phone by holding the top button about 5 sec and then sliding my finger across the top portion of the screen pretending that the slide to turn off was there thought there was nothing and my phone turned on. I just did what EmNat recommends as fix and renamed the folder as instructed. Hope this is the fix...Thanks.

update 10/6: Well after performing the "fix" I didn't notice any immediate problems; however, my phone is doing a really slow backup. It has gone from taking about 3 minutes to around 12 minutes...that is a huge difference. I've not changed anything else. I will likely revert the name of the file back to see if it is the cause.

Last edited by Wolfmore; Oct 6, 2008 at 06:40 PM.
Wolfmore is offline   0 Reply With Quote
Old Oct 7, 2008, 07:26 PM   #22
exalted719
macrumors member
 
Join Date: Sep 2008
Just tried it.
I'll see if I have any issues waking it in the morning.
exalted719 is offline   0 Reply With Quote
Old Oct 8, 2008, 03:57 AM   #23
jonasmae
macrumors newbie
 
Join Date: Oct 2008
i have tried this fix just right now and my iphone seems to be fine. before whenever i put it on sleep mode and when i wake it up it just hangs... now it seems to be ok.. i dont know in a couple of days.. ill keep you guys posted.. thanks to you bud..

also if you want to use other program rather than winscp and openssh..
try to find disk aid for iphone. you will not be needing the wifi.. just open and it will auto detect..
jonasmae is offline   0 Reply With Quote
Old Oct 8, 2008, 07:07 AM   #24
Vegan TJ
Banned
 
Join Date: Jun 2008
OK i was having this issue but WORSE. my phone when i would be on a call would go to sleep . and then it wouldnt come back from sleep i held the home button i used to on off button and nothing i used to have to do a manual reset in order for my phone to work...

Called apple and got a new iphone or referb whatever i love it and have no problems
Vegan TJ is offline   0 Reply With Quote
Old Oct 8, 2008, 12:53 PM   #25
exalted719
macrumors member
 
Join Date: Sep 2008
Quote:
Originally Posted by exalted719 View Post
Just tried it.
I'll see if I have any issues waking it in the morning.
No issues waking.

However, since we essentially removed power management, usage statistics are wrong. The iPhone does not think it is sleeping. I also noticed more power consumption. Probably because the iPhone is not going into a "deep sleep" now that we removed power management.
exalted719 is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iOS > Jailbreaks and iOS Hacks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
change wake from sleep buttons al404 OS X 6 Sep 6, 2013 09:20 AM
MP 5,1 won't wake from sleep telequest Mac Pro 11 May 4, 2013 07:57 PM
MBP won't wake from sleep using apple Remote and display recover from sleep in clamsh aoaaron MacBook Pro 1 Jan 10, 2013 10:33 AM
Won't wake from sleep ahdickter MacBook Pro 0 Aug 4, 2012 01:59 PM
10.8 and won't wake up from sleep Buckeyes1995 OS X 10.8 Mountain Lion 1 Aug 1, 2012 03:44 AM

Forum Jump

All times are GMT -5. The time now is 02:58 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC