Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone

Reply
 
Thread Tools Search this Thread Display Modes
Old Aug 24, 2008, 10:16 PM   #1
twoodcc
macrumors P6
 
twoodcc's Avatar
 
Join Date: Feb 2005
Location: Right side of wrong
Send a message via AIM to twoodcc Send a message via MSN to twoodcc
iphone bluetooth won't connect automatically?

so i have my iphone paired with my cd player in my truck for hands-free calling, but i have to unpair and repair it everytime i get in b/c they don't see each other on their own, even though they should. can anyone help me with this?
__________________
tville
Smarter than the average bear
twoodcc is offline   0 Reply With Quote
Old Aug 24, 2008, 10:26 PM   #2
twoodcc
Thread Starter
macrumors P6
 
twoodcc's Avatar
 
Join Date: Feb 2005
Location: Right side of wrong
Send a message via AIM to twoodcc Send a message via MSN to twoodcc
after looking more into this, do i have to tell the radio to connect to the phone?
__________________
tville
Smarter than the average bear
twoodcc is offline   0 Reply With Quote
Old Aug 24, 2008, 10:45 PM   #3
HawaiiMacAddict
macrumors 6502a
 
Join Date: Dec 2006
Location: On one of my Macs of course
Aloha twoodcc,

I have a Lexus RX-350 which has a hands-free system. On my center console screen, I select the telephone portion, not the radio, to set up any Bluetooth devices I wish to connect with my vehicle's Bluetooth. I've not heard of pairing a cell phone with a radio system, but I only had to pair my iPhones with my vehicle once each (once for the original iPhone and once for the iPhone 3G).

HawaiiMacAddict
__________________
27" iMac , 17" MBP, 15" rMBP - OS X 10.8.4
64GB iPhone 5 - iOS 7B2
64GB iPad w/Retina Screen, 64GB iPad (original) iOS 6
HawaiiMacAddict is offline   0 Reply With Quote
Old Aug 24, 2008, 10:50 PM   #4
twoodcc
Thread Starter
macrumors P6
 
twoodcc's Avatar
 
Join Date: Feb 2005
Location: Right side of wrong
Send a message via AIM to twoodcc Send a message via MSN to twoodcc
Quote:
Originally Posted by HawaiiMacAddict View Post
Aloha twoodcc,

I have a Lexus RX-350 which has a hands-free system. On my center console screen, I select the telephone portion, not the radio, to set up any Bluetooth devices I wish to connect with my vehicle's Bluetooth. I've not heard of pairing a cell phone with a radio system, but I only had to pair my iPhones with my vehicle once each (once for the original iPhone and once for the iPhone 3G).

HawaiiMacAddict
thanks for the reply. so when you get into your car with your iPhone, you just select telephone and it connects?
__________________
tville
Smarter than the average bear
twoodcc is offline   0 Reply With Quote
Old Aug 25, 2008, 10:33 PM   #5
twoodcc
Thread Starter
macrumors P6
 
twoodcc's Avatar
 
Join Date: Feb 2005
Location: Right side of wrong
Send a message via AIM to twoodcc Send a message via MSN to twoodcc
well i don't know what's with my iphone, but it still won't connect with my radio without unpairing and then repairing
__________________
tville
Smarter than the average bear
twoodcc is offline   0 Reply With Quote
Old Aug 25, 2008, 10:49 PM   #6
skubish
macrumors 68030
 
skubish's Avatar
 
Join Date: Feb 2005
Location: Ann Arbor, Michigan
Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 2_0_2 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5C1 Safari/525.20)

probably a setting on the radio to auto pair. Is the Bluetooth turned on on the iPhone? All does it show in the menu that the two devices are paired?
__________________
iPad 3G 32GB
iMac C2D 24"
iPhone 3GS 32GB Black
iPod Nano 8GB Blue
skubish is offline   0 Reply With Quote
Old Aug 25, 2008, 11:21 PM   #7
twoodcc
Thread Starter
macrumors P6
 
twoodcc's Avatar
 
Join Date: Feb 2005
Location: Right side of wrong
Send a message via AIM to twoodcc Send a message via MSN to twoodcc
Quote:
Originally Posted by skubish View Post
Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 2_0_2 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5C1 Safari/525.20)

probably a setting on the radio to auto pair. Is the Bluetooth turned on on the iPhone? All does it show in the menu that the two devices are paired?
well, it's possible it's with the radio, but after reading the manual, i'm pretty sure it's setup correctly.

the bluetooth is turned on on the phone and on the radio. it shows on the iphone that it's paired with the radio, but it won't connect to it, unless i un-pair it and then re-pair it, and then it will work great, until i take it out of the car, and the next time it won't connect
__________________
tville
Smarter than the average bear
twoodcc is offline   0 Reply With Quote
Old Aug 25, 2008, 11:27 PM   #8
ribenaberrie
macrumors member
 
Join Date: Aug 2008
Location: Sydney, Australia
I think its probably your radio too...

I have a BMW 530i and it has bluetooth and I just leave my bluetooth on on the iphone and they pair up automatically when I get in the car. I don't have to do anything.
__________________
32GH iPhone 4 White
64GB iPad2 3G
27" iMac, 3.4 GHz i7, 16GB RAM, AMD Radeon HD 6970M 2GB
ribenaberrie is offline   0 Reply With Quote
Old Aug 26, 2008, 12:19 AM   #9
twoodcc
Thread Starter
macrumors P6
 
twoodcc's Avatar
 
Join Date: Feb 2005
Location: Right side of wrong
Send a message via AIM to twoodcc Send a message via MSN to twoodcc
Quote:
Originally Posted by ribenaberrie View Post
I think its probably your radio too...

I have a BMW 530i and it has bluetooth and I just leave my bluetooth on on the iphone and they pair up automatically when I get in the car. I don't have to do anything.
well that is what it's supposed to do. but for some reason it's not doing it. do you have 2.0.2 on your iphone?
__________________
tville
Smarter than the average bear
twoodcc is offline   0 Reply With Quote
Old Aug 26, 2008, 12:52 AM   #10
twoodcc
Thread Starter
macrumors P6
 
twoodcc's Avatar
 
Join Date: Feb 2005
Location: Right side of wrong
Send a message via AIM to twoodcc Send a message via MSN to twoodcc
the radio is a Sony MEX-BT2600, i think
__________________
tville
Smarter than the average bear
twoodcc is offline   0 Reply With Quote
Old Aug 26, 2008, 01:12 AM   #11
ribenaberrie
macrumors member
 
Join Date: Aug 2008
Location: Sydney, Australia
Yep I have 2.0.2

Have you tried pairing the cd player with another phone to see if that works?
__________________
32GH iPhone 4 White
64GB iPad2 3G
27" iMac, 3.4 GHz i7, 16GB RAM, AMD Radeon HD 6970M 2GB
ribenaberrie is offline   0 Reply With Quote
Old Aug 26, 2008, 01:14 AM   #12
twoodcc
Thread Starter
macrumors P6
 
twoodcc's Avatar
 
Join Date: Feb 2005
Location: Right side of wrong
Send a message via AIM to twoodcc Send a message via MSN to twoodcc
Quote:
Originally Posted by ribenaberrie View Post
Yep I have 2.0.2

Have you tried pairing the cd player with another phone to see if that works?
not yet, only cuz i don't have another phone. i will do that this weekend though.

see, heres the weird thing. when i first paired it up, the first day i got the radio, everything worked fine. but now it doesn't, and it hasn't for at least a week now, if not more
__________________
tville
Smarter than the average bear
twoodcc is offline   0 Reply With Quote
Old Aug 26, 2008, 01:16 AM   #13
RexTraverse
macrumors 6502
 
Join Date: Feb 2008
Similar problem here with my iPhone 3G except I have three BT devices - my Garmin nuvi and two headsets (a Plantronics and a Jabra) and after awhile of being paired, it refuses to reconnect with any of them.

It tends to be fine for about a day or so but then afterwards refuses to pair anymore. The only workaround I've found is after pairing the devices, never disable bluetooth on my iPhone and it's fine. It's when I turn off bluetooth and turn it back on when problems occur. I think it's a flaw with my (and your) iPhone, but since it's tough to demonstrate the problem to a genius since the amount of time it takes between pairing and not being able to pair anymore is so erratic and relatively long, I don't know how likely you are to get a replacement.
RexTraverse is offline   0 Reply With Quote
Old Aug 26, 2008, 01:21 AM   #14
twoodcc
Thread Starter
macrumors P6
 
twoodcc's Avatar
 
Join Date: Feb 2005
Location: Right side of wrong
Send a message via AIM to twoodcc Send a message via MSN to twoodcc
Quote:
Originally Posted by RexTraverse View Post
Similar problem here with my iPhone 3G except I have three BT devices - my Garmin nuvi and two headsets (a Plantronics and a Jabra) and after awhile of being paired, it refuses to reconnect with any of them.

It tends to be fine for about a day or so but then afterwards refuses to pair anymore. The only workaround I've found is after pairing the devices, never disable bluetooth on my iPhone and it's fine. It's when I turn off bluetooth and turn it back on when problems occur. I think it's a flaw with my (and your) iPhone, but since it's tough to demonstrate the problem to a genius since the amount of time it takes between pairing and not being able to pair anymore is so erratic and relatively long, I don't know how likely you are to get a replacement.
thanks for the reply. i guess i need to try to connect my iphone to another device, but i don't think i have one
__________________
tville
Smarter than the average bear
twoodcc is offline   0 Reply With Quote
Old Aug 26, 2008, 01:24 AM   #15
RexTraverse
macrumors 6502
 
Join Date: Feb 2008
Quote:
Originally Posted by twoodcc View Post
thanks for the reply. i guess i need to try to connect my iphone to another device, but i don't think i have one
You can try, but if your problem is anything like mine, it's a flaw in the bluetooth radio in your phone, not the devices you're pairing the phone with.
RexTraverse is offline   0 Reply With Quote
Old Aug 26, 2008, 11:42 AM   #16
twoodcc
Thread Starter
macrumors P6
 
twoodcc's Avatar
 
Join Date: Feb 2005
Location: Right side of wrong
Send a message via AIM to twoodcc Send a message via MSN to twoodcc
Quote:
Originally Posted by RexTraverse View Post
You can try, but if your problem is anything like mine, it's a flaw in the bluetooth radio in your phone, not the devices you're pairing the phone with.
well, if that's the case, then maybe i can take my phone to the apple store and get a replacement.
__________________
tville
Smarter than the average bear
twoodcc is offline   0 Reply With Quote
Old Nov 12, 2008, 12:17 PM   #17
iphnct
macrumors newbie
 
Join Date: Oct 2007
Same problem here:

I just bought an AT&T TL92328 DECT 6.0 Bluetooth cordless phone, and it would not autopair with my iphone: I have to unpair, repair (and enter the pin) in my iphone every time I come back home.

Any solution?
iphnct is offline   0 Reply With Quote
Old Nov 12, 2008, 01:29 PM   #18
firewood
macrumors 603
 
Join Date: Jul 2003
Location: Silicon Valley
I have to turn my Jabra off and back on anytime I go out and back in of range of it (I usually leave it in the car), or else it won't pick up calls. I leave the iPhone's BT turned on.


.
firewood is online now   0 Reply With Quote
Old Nov 12, 2008, 02:02 PM   #19
trunksu
macrumors 6502
 
Join Date: Feb 2008
i think i've been having this problem since 2.1. i have to re-pair if i turn the BT off and then back on for my devices. it was working fine before 2.1.
trunksu is offline   0 Reply With Quote
Old Nov 16, 2008, 03:22 PM   #20
dalailaptop
macrumors newbie
 
Join Date: May 2003
Quote:
Originally Posted by iphnct View Post

I just bought an AT&T TL92328 DECT 6.0 Bluetooth cordless phone, and it would not autopair with my iphone...
I'm having the same problem, I have an ATT TL92278 Dect 6 bluetooth and it constantly needs to be re-paired after I leave the house. The iPhone says it's paired but the home phone no longer has a bluetooth indicator light.

What's even crazier is that every 3 or 4 times I leave home it re-pairs automatically like it should, but 25% is pretty crappy reliability.

What a PITA. The problem with third party anything is both sides always blame the other...
dalailaptop is offline   0 Reply With Quote
Old May 27, 2009, 12:41 PM   #21
Aeyjay
macrumors newbie
 
Join Date: Mar 2009
Plantronics 855 connectivity

I have a Plantronics 855 headset that shows paired however it doesn't connect automatically. My iPhone is Jail broken and running on firmware 2.2.1. Has anyone been able to solve this issue other than re-pairing the phone and the headset.
Aeyjay is offline   0 Reply With Quote
Old Oct 19, 2010, 09:42 PM   #22
EBG87
Guest
 
I have paired my iphone with the bluetooth on my Saab 9-7x (it is a General Motores bluetooth system). Initially, the iphone automatically connected to the bluetooth system every time that i entered the vehicle with the iphone bluetooth turned on. However, the iphone bluetooth no longer automatically connects to the GM bluetooth system. Similar to the initial post in this thread, bluetooth on the iphone shows the "General Motors" system but it won't connect to it, unless I un-pair it and then re-pair it, and then it will works just fine until I turn off the ignition of the car; then, the next time it won't connect unless I un-pair and re-pair again. HELP!
  0 Reply With Quote
Old Jan 6, 2011, 09:35 AM   #23
Jenfab
macrumors newbie
 
Join Date: Jan 2011
hi Guys
I got the alpine cde-114bti for x-mas and i have been trying to make my iphone 3s connect to the raidio automaticly but i always have to go into the bt menu and pair it again is there any way that they connect once they are in bt ragnge?
Jenfab is offline   0 Reply With Quote
Old Jun 25, 2011, 12:36 PM   #24
Chealy
macrumors newbie
 
Join Date: Jun 2011
I have a 2011 Silverado with the same Bluetooth connection problem. I figured out that the car wouldn't recognize the phone whenever I had the 12V charger plugged in. Disconnect the charger and restart the truck and it connects every time. Hope this helps.
Chealy is offline   0 Reply With Quote
Old Aug 15, 2011, 09:13 AM   #25
soupdog
macrumors newbie
 
Join Date: Aug 2011
I just got a brand new iPhone 4 for work and I have a Panasonic in my truck. I am having the same problem. I just changed from a blackberry to this. Anytime I got within ten feet of the truck with the blackberry the radio would "see" the phone and connect automatically. No problem for over a year. Now with the iPhone it wont connect after one or two times. I get the message that the phone is "paired" but it wont connect. When I try to connect the radio says "error". I then have to turn Bluetooth off on the phone and back on and then try to manually connect again. After that it works fine for about a day and then fails again.

I hate to change back but I may need to go back to blackberry.
soupdog is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iPhone: New iPhone 5s - bluetooth comes on automatically! Thunderbird8 iOS 7 4 Oct 9, 2013 11:26 AM
My iphone won't connect automatically to the home wifi zozomaniok iPhone Tips, Help and Troubleshooting 2 Jul 15, 2013 11:26 AM
Mac won't automatically connect to network NikkiJayne OS X 10.8 Mountain Lion 3 Dec 11, 2012 07:15 AM
iPhone wont automatically connect to wifi II BISTRO II iPhone 1 Sep 28, 2012 12:46 AM
Macbook Pro won't connect automatically WiFi ivoruest MacBook Pro 5 Aug 26, 2012 11:22 AM

Forum Jump

All times are GMT -5. The time now is 07:14 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC