Go Back   MacRumors Forums > Apple Hardware > PowerPC Macs

Reply
 
Thread Tools Search this Thread Display Modes
Old Sep 10, 2008, 09:17 AM   #1
andyburness
macrumors newbie
 
Join Date: Sep 2008
Powermac G4 won't boot from anything

(Disclaimer, I consider myself an experienced "PC person", I work in the IT department at Fujitsu Siemens, but aside from an iphone this is my first experience with macs, so please bear with me if I'm overlooking something stupid )

A long while back I bought a 2nd hand Powermac G4 from ebay. It was running OS X 10.4.8 and didn't come with any install CD/DVDs. I upgraded the RAM from 2x128 to 2x256 which worked fine. Next however I tried to upgrade the hard disk from a 10GB IDE to a spare 40GB IDE I had laying around.

Not having any OS X install media, I put both the 10GB and 40GB disks into a spare PC case, and booted from a Norton Ghost CD. I tried to clone the 10GB disk to the 40GB, but it complained that it couldn't do it due to the file system.

Next I tried g4l which apparently doesn't concern itself with file systems and reads and writes raw data on the disk. This seemed to work OK, cloned the single partition on the 10GB disk to a new 10GB partition on the blank 40GB disk, with no errors. When I came to boot from the 40GB disk in the powermac though, I got the flashing question mark/folder screen. More worryingly the same thing happened when I put the 10GB disk back in. (I had tried all the various jumper settings on the two drives, replaced IDE cables etc etc, no difference)

After that, following the advice on various forums I booted into Openfirmware and tried resetting the PRAM I believe, things like reset-all set-defaults etc etc, none of which made a difference. I've also tried holding down alt to bring up the "boot menu" but it didn't show any drives.

The other night I took the powermac round to a friends who has an iBook G4. My plan was to put the iBook into target disk mode and install OS X from his iBook's DVD drive, using his original panther CDs and a tiger DVD. So we booted the powermac holding alt, c, d and all the other keys we thought were relevant (from here and various forums etc) but it wouldn't see any hard disks / DVD drives. We tried the other way around however, powermac in disk mode and installed panther from the iBook, onto the powerbook's hard disk over firewire. This worked and after the install the iBook booted from the powermac's hard disk. So we turned both machines off, disconnected the firewire cable, booted them both back up, the ibook booted to its hard disk running tiger, and my powermac threw up the same flashing ? folder icon....

The last thing we tried before we gave up for the night was booting the ibook into target disk mode, and booting the powermac holding alt. This time it does see the 40GB hard disk, and the hard disk and DVD drive in the iBook. Whichever one I select though, when I click next the screen flickers then comes back exactly the same, after about 20 seconds I can select another disk and try again, with the same looping result.

So we're both stumped now. Back before I knew the guy with the iBook I was playing around in openfirmware trying to set the aliases for the hd and cd devices I think, so I've got a feeling I've done something in there. However I would have thought when I've done set-defaults reset-all etc this would have, well, reset everything?

Does anyone have any ideas how I can get this thing to boot again? If you want devalias printenv etc etc outputs I can take photos of the screen.

Thanks in advance for any advice!
andyburness is offline   0 Reply With Quote
Old Sep 13, 2008, 06:43 PM   #2
Earl Urly
macrumors regular
 
Join Date: Jul 2004
What kind of install media did he have, the Panther retail CDs or the Tiger retail DVDs? Why couldnt you just try booting the PowerMac G4 direct from those media?
Earl Urly is offline   0 Reply With Quote
Old Sep 14, 2008, 04:24 AM   #3
andyburness
Thread Starter
macrumors newbie
 
Join Date: Sep 2008
He had retail DVDs for both I think, the panther disc said iBook on it and the tiger one was black with a big os x logo. I didn't really expect the panther iBook one to work but I still expected it to boot... neither of them booted in my powermac, even if I held down c or alt/option to choose what to boot from. The iBook does boot from both discs. Since then we've tried replacing the DVD drive with a new one, but that hasn't made any difference.

It's weird how if we put the iBook into target disk mode, the powermac won't boot from the iBooks drives either, but the iBook can boot from the powermacs if we do it the other way round
andyburness is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > PowerPC Macs

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Powermac G5 1.8 DP Won't Boot - Help? OChrisJonesO PowerPC Macs 3 Mar 27, 2014 01:59 AM
Macbook Pro (early 2008) won't boot, then booted, now won't boot again. ruyen MacBook Pro 12 Dec 21, 2013 07:27 PM
Why won't boot recovery mode? Won't start even from boot usb cicchilitto MacBook 2 Oct 19, 2013 05:17 PM
Powermac G5 Quad Core won't boot a display jadden PowerPC Macs 5 Nov 10, 2012 04:58 PM
Powermac G4 QS won't boot with SIL3112 SATA card installed max•• PowerPC Macs 12 Sep 4, 2012 04:10 PM

Forum Jump

All times are GMT -5. The time now is 11:23 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC