Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Reply
 
Thread Tools Search this Thread Display Modes
Old Sep 27, 2008, 11:37 AM   #1
rye9
macrumors 65816
 
rye9's Avatar
 
Join Date: Sep 2005
Location: New York (not NYC)
iPhone won't send emails

I can receive emails perfectly with my phone, however whenever I try to reply to an email, it always tells me the address is invalid. Why is this? It's not like I'm entering an address wrong, since I'm replying to an email.. but yeah, I can't send emails due to this. How do I fix this?
__________________
-13" MBP (2.26 Ghz, 160 GB, 4 GB DDR3, Mac OS 10.9)
-Some old iPods...
-iPhone 5S

=
rye9 is offline   0 Reply With Quote
Old Sep 27, 2008, 01:56 PM   #2
neesh0
macrumors 6502a
 
neesh0's Avatar
 
Join Date: Sep 2008
Location: Toronto, Ontario
are you using microsoft exchange, yahoo, or gmail? Maybe deleting and re entering the account can help. Also I hear that 2.0.2 (if you have it) has mail glitches, you might need to go to 2.1
__________________
Black 16gb iphone 3g......sweet
Unibody Macbook
2.4 Ghz
2 Gb DDR3 RAM
neesh0 is offline   0 Reply With Quote
Old Sep 27, 2008, 03:40 PM   #3
Moi un Mouton
macrumors 68000
 
Join Date: Mar 2008
Location: Bracknell UK
It's a common problem. There's another thread about it here:
http://forums.macrumors.com/showthread.php?t=538335
with some possible solutions
Moi un Mouton is offline   0 Reply With Quote
Old Sep 29, 2008, 01:01 PM   #4
rye9
Thread Starter
macrumors 65816
 
rye9's Avatar
 
Join Date: Sep 2005
Location: New York (not NYC)
I checked out that link and the other one that it directs me too, however nothing seemed to pertain to me in order to try and troubleshoot. The only difference in my settings that could be addressed as far as I could tell was to change the port from 587 to 25... but that did nothing. Otherwise, I have an AOL mail account, IMAP receives emails beautifully. SSL is on, and authentication is set to password, with the password tab empty, though. That's all of my settings other than my email address of course. I don't know what to change; the threads didn't seem to have helped me since I had everything set up correctly I thought.

My other issue, is that I don't know whether to contact Apple or AT&T about the constant changing between the EDGE and 3G network; when I'm in 3G it's a good connection I am sure, considering I'm in the middle of a 3G covered area. My phone will be sitting on a desk, immobile, and keep switching between networks. Additionally, someone will try and call through, but the phone never rings and I magically receive a voicemail. So yeah, if there's any input on this I would love it, however I'd also like to see this improved in the future, but I don't know which company would be responsible for these occurrences.

Oh, and also; similar to the preceding paragraph... I don't know who to complain about dropped calls to. I would imagine AT&T, however Apple's software update claims fewer dropped calls; so I thought, maybe the hardware/software has something to do with it? Because I switched over from Verizon, where I never had any issues, and now I am met with a few. So I'd like to know where to voice my complaints about these dropped calls.
__________________
-13" MBP (2.26 Ghz, 160 GB, 4 GB DDR3, Mac OS 10.9)
-Some old iPods...
-iPhone 5S

=

Last edited by rye9; Sep 29, 2008 at 01:09 PM.
rye9 is offline   0 Reply With Quote
Old Oct 10, 2008, 09:29 PM   #5
smitri
macrumors newbie
 
Join Date: Oct 2008
Found something that worked...

I was having the same problem -- couldn't send e-mail coz it said address was invalid. I found a suggestion on another forum, tried it and it worked. Go to settings, mail, accounts, outgoing Mail Server. First, I enabled other SMTP servers by turning them on, so it can try other servers. Then, under my primary server,l I enable SSL (ON) and change the server port to 465. Once I did this, it worked!
smitri is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Can't send or receive emails to / from my work, but can get emails from Hotmail, etc. TheDude75 iPhone Tips, Help and Troubleshooting 0 May 29, 2014 05:11 AM
Can't send emails?! barneyman iOS 7 3 Sep 18, 2013 03:16 PM
Hotmail email on iphone won't let me send emails Macaroooon iPhone 4 Aug 5, 2013 08:32 PM
new iPhone 5 won't work with exchange emails barrett14 iPhone Tips, Help and Troubleshooting 1 Feb 25, 2013 07:55 PM
Can not send emails JaneRoth iPod 3 Feb 20, 2013 08:48 AM

Forum Jump

All times are GMT -5. The time now is 03:20 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC