Go Back   MacRumors Forums > Apple Hardware > Notebooks > MacBook Pro

Reply
 
Thread Tools Search this Thread Display Modes
Old Oct 26, 2008, 12:42 AM   #1
NEENAHBOY
macrumors 6502
 
Join Date: Aug 2004
Location: Arlington, VA
How do I disable select multi-touch gestures?

Since getting the new MBP, I've found that I accidentally do the pinch command in Safari ALL the time, which either increases or decreases the text size. This is incredibly annoying, and there doesn't seem to be a way to disable it in Trackpad System Preferences. Is there a workaround (Terminal or otherwise)? If it requires disabling all multi-touch functionality, I'm fine with it.
NEENAHBOY is offline   0 Reply With Quote
Old Oct 26, 2008, 12:48 AM   #2
rolex54
macrumors 6502
 
Join Date: Aug 2007
Location: Houston, TX
Send a message via AIM to rolex54
you can set a minimum font size in safari preferences which should stop it from getting smaller, but other than that I don't know of another way
__________________
rolex54 is offline   0 Reply With Quote
Old Oct 26, 2008, 12:53 AM   #3
emt1
macrumors 65816
 
Join Date: Jan 2008
Location: Wisconsin
Quote:
Originally Posted by NEENAHBOY View Post
Since getting the new MBP, I've found that I accidentally do the pinch command in Safari ALL the time, which either increases or decreases the text size. This is incredibly annoying, and there doesn't seem to be a way to disable it in Trackpad System Preferences. Is there a workaround (Terminal or otherwise)? If it requires disabling all multi-touch functionality, I'm fine with it.
Out of curiosity, how do you accidently do that? I didn't even think it did that until I tried it just now. Maybe you should reposition your fingers... idk...
emt1 is offline   0 Reply With Quote
Old Oct 26, 2008, 01:02 AM   #4
nitewolfgtr
macrumors regular
 
Join Date: Jul 2008
Send a message via MSN to nitewolfgtr
[System Preferences] --> [Trackpad] ?????
__________________
15" MacBook Pro (unibody), 2.4 GHz, 4GB RAM, 500GB HDD (7200RPM)
iPhone 3G 16GB
iPod Classic 80GB
nitewolfgtr is offline   0 Reply With Quote
Old Oct 26, 2008, 01:09 AM   #5
emt1
macrumors 65816
 
Join Date: Jan 2008
Location: Wisconsin
Quote:
Originally Posted by nitewolfgtr View Post
[System Preferences] --> [Trackpad] ?????
If you would have read the whole post or tried that yourself you would have found that there is no way to disable that gesture in preferences.
emt1 is offline   0 Reply With Quote
Old Dec 22, 2008, 09:22 PM   #6
j-a-x
macrumors 65816
 
j-a-x's Avatar
 
Join Date: Apr 2005
Location: Houston, Texas
I've been wondering the same thing. Specifically, how do I just disable the pinch to zoom gesture in Safari. I always change the font size accidentally while scrolling. very annoying. It is probably confusing to new mac users too...
j-a-x is offline   0 Reply With Quote
Old Jan 9, 2009, 06:33 PM   #7
jguluarte
macrumors newbie
 
Join Date: Jan 2009
Cool Solution!!!

I finally fixed it for me!

1) Download and Install "MultiClutch".

2) Once you have it installed, add Safari to the Application list (it is the plus image in the lower left corner).

3) Click Safari from that list to access Safari settings.

4) Add two new rules (the plus in the lower right corner).

5) Set one to "Zoom In" and one to "Zoom Out"

6) Set a key command sequence that does nothing (I set mine to apple+option+crtl+shift+] because I know that doesn't do anything)

7) ...

8) PROFIT!

Now I no longer accidentally resize the text!!!
jguluarte is offline   0 Reply With Quote
Old Jan 14, 2009, 11:53 AM   #8
Fofer
macrumors 6502a
 
Join Date: Oct 2002
Quote:
Originally Posted by jguluarte View Post
I finally fixed it for me!

1) Download and Install "MultiClutch".

2) Once you have it installed, add Safari to the Application list (it is the plus image in the lower left corner).

3) Click Safari from that list to access Safari settings.

4) Add two new rules (the plus in the lower right corner).

5) Set one to "Zoom In" and one to "Zoom Out"

6) Set a key command sequence that does nothing (I set mine to apple+option+crtl+shift+] because I know that doesn't do anything)

7) ...

8) PROFIT!

Now I no longer accidentally resize the text!!!
Simply... awesome. Thanks for this. It's the one pet peeve I've had with this new Unibody MBP -- I was thinking of asking the developer of Saft to address it. Or resign myself to waiting for Apple.

You just resolved it, with a System Pref I'd already had installed. Thanks again!
Fofer is offline   0 Reply With Quote
Old Feb 25, 2009, 04:18 AM   #9
DJ567
macrumors regular
 
Join Date: Mar 2006
Location: London, UK
thanks for finding this solution it really is annoying because the way i use my trackpad with 1 digit treating it as a button and the others as a trackpad i was always zooming in and out. and the pinching doesnt appear to be very accurate as when i tried to pinch it back to normal it would always be too much or too little
__________________
Unibody MacBook Pro, 2.4GHz, 4GB RAM, 250GB HD
32GB iPhone 3G S Black
AirPort Extreme Wifi N
DJ567 is offline   0 Reply With Quote
Old Feb 26, 2009, 10:26 AM   #10
EricBrian
macrumors 6502a
 
Join Date: Jul 2005
Has anybody found how to totally turn of the gestures? I hate them in all applications. Thanks.
EricBrian is offline   0 Reply With Quote
Old Feb 26, 2009, 02:25 PM   #11
robotfist
macrumors member
 
Join Date: Nov 2007
Trackpad issues among other things....

I agree. In fact, it's so annoying that I've been debating getting rid of my machine. I have been a loyal Mac user for 18 years now. This is the first time I've ever debated returning a machine because of a feature! I use photoshop all day and the canvas is constantly rotating and zooming with even the slightest misstep. It's extremely aggravating and anti-productive.

These new machines are neat, but I can't believe how many issues I run into with mine. And I'm talking about issues that Apple either overlooked or actually approved (i.e. the removal of Firewire 400 ports, stiff and noisy trackpad, unable to replace a single keyboard key without replacing the ENTIRE case, cheaper keys, no matte screen, loose screen hinge, blah, blah, blah, b*$tch, b$#itch, b$#tch).

I am currently in Oklahoma City for 5 days and last week I went to buy a Firewire 800 to 400 cable as well as a miniDisplay port to DVI adapter to plug in my Cinema Display. *Besides the Apple store, there is not a single store in the ENTIRE CITY that carries these cables. Because of this, even the overpriced Apple store's inventory was sold out. These laptops have been out for half a year now. If Apple is going to change their ports with every model and remove ports that are still common among most devices, they'd better make sure they've got the cables and adapters to support those ports. Currently I cannot access even ONE of my TWENTY FIVE firewire 400 drives and my Cinema Display is utterly useless.

*Correction, Best Buy carries a Dynex Firewire 800 to 400 adapter. It's $51.00. I guess I'll just spend the dog food money and he can eat dirt for a month.
robotfist is offline   0 Reply With Quote
Old Feb 26, 2009, 04:27 PM   #12
EricBrian
macrumors 6502a
 
Join Date: Jul 2005
Quote:
Originally Posted by robotfist View Post
I agree. In fact, it's so annoying that I've been debating getting rid of my machine. I have been a loyal Mac user for 18 years now. This is the first time I've ever debated returning a machine because of a feature! I use photoshop all day and the canvas is constantly rotating and zooming with even the slightest misstep. It's extremely aggravating and anti-productive.

These new machines are neat, but I can't believe how many issues I run into with mine. And I'm talking about issues that Apple either overlooked or actually approved (i.e. the removal of Firewire 400 ports, stiff and noisy trackpad, unable to replace a single keyboard key without replacing the ENTIRE case, cheaper keys, no matte screen, loose screen hinge, blah, blah, blah, b*$tch, b$#itch, b$#tch).

I am currently in Oklahoma City for 5 days and last week I went to buy a Firewire 800 to 400 cable as well as a miniDisplay port to DVI adapter to plug in my Cinema Display. *Besides the Apple store, there is not a single store in the ENTIRE CITY that carries these cables. Because of this, even the overpriced Apple store's inventory was sold out. These laptops have been out for half a year now. If Apple is going to change their ports with every model and remove ports that are still common among most devices, they'd better make sure they've got the cables and adapters to support those ports. Currently I cannot access even ONE of my TWENTY FIVE firewire 400 drives and my Cinema Display is utterly useless.

*Correction, Best Buy carries a Dynex Firewire 800 to 400 adapter. It's $51.00. I guess I'll just spend the dog food money and he can eat dirt for a month.
LOL... yeah, I stopped using PS when I don't have a mouse handy.
EricBrian is offline   0 Reply With Quote
Old Feb 27, 2009, 08:29 AM   #13
w8ing4intelmacs
macrumors 6502a
 
Join Date: Feb 2006
Location: East Coast, US
Quote:
Originally Posted by jguluarte View Post
I finally fixed it for me!

1) Download and Install "MultiClutch".

2) Once you have it installed, add Safari to the Application list (it is the plus image in the lower left corner).

3) Click Safari from that list to access Safari settings.

4) Add two new rules (the plus in the lower right corner).

5) Set one to "Zoom In" and one to "Zoom Out"

6) Set a key command sequence that does nothing (I set mine to apple+option+crtl+shift+] because I know that doesn't do anything)

7) ...

8) PROFIT!

Now I no longer accidentally resize the text!!!
Works great. Thanks. But, isn't this the epitome of kluge?
w8ing4intelmacs is offline   0 Reply With Quote
Old Mar 9, 2009, 12:30 PM   #14
mmcxiiad
macrumors regular
 
Join Date: Jul 2002
Quote:
Originally Posted by robotfist View Post
Because of this, even the overpriced Apple store's inventory was sold out. These laptops have been out for half a year now. If Apple is going to change their ports with every model and remove ports that are still common among most devices, they'd better make sure they've got the cables and adapters to support those ports. Currently I cannot access even ONE of my TWENTY FIVE firewire 400 drives and my Cinema Display is utterly useless.

*Correction, Best Buy carries a Dynex Firewire 800 to 400 adapter. It's $51.00. I guess I'll just spend the dog food money and he can eat dirt for a month.
Why don't you just get a firewire 800 to 400 cable. I bought several of them from monoprice for under $5. This should solve the inability for your 25 firewire 400 drives from connecting to you MBP.
mmcxiiad is offline   0 Reply With Quote
Old Jun 2, 2009, 10:39 AM   #15
dandaman2
macrumors regular
 
Join Date: Aug 2008
Quote:
Originally Posted by EricBrian View Post
Has anybody found how to totally turn of the gestures? I hate them in all applications. Thanks.
I imagine the same pref pane.
__________________
~Dan
Samsung Galaxy S Phone (Captivate); MacBook Pro 15" w/ HiRes Antiglare, 8GB RAM, and I sprung for the 512GB SSD for durability; 32GB iPad 2
dandaman2 is offline   0 Reply With Quote
Old Jun 8, 2009, 09:33 AM   #16
mfaina
macrumors newbie
 
Join Date: Jun 2009
Can't assign command keys

Installed MultiClutch, was able to assign keys first time, the zoom in/out was finally solved for Safari, after I closed and open it via System Preferences, I can't delete or assign command keys anymore! I deleted (-) Safari added it again and now I can't assign command keys anymore. Any suggestions? Thanks!
mfaina is offline   0 Reply With Quote
Old Jul 23, 2009, 01:15 AM   #17
samsoffes
macrumors newbie
 
Join Date: May 2009
Snow Leopard

I know I turned off those gestures when I got my new 13-inch MBP. I installed Snow Leopard the day I got it and recently reinstalled Leopard and was looking for how to turn it off.

So there may or may not be a way in Snow Leopard if you know what I mean (yay for NDAs)
samsoffes is offline   0 Reply With Quote
Old Aug 13, 2009, 01:34 PM   #18
NJRonbo
macrumors 65816
 
Join Date: Jan 2007
Multi-clutch is solving the main problem with gestures but
has created another...

Now, with a certain gesture on the trackpad (have no idea what
I am doing) Safari is mimimizing itself.

Any idea what may be happening?
NJRonbo is offline   0 Reply With Quote
Old Aug 14, 2009, 01:16 AM   #19
dandaman2
macrumors regular
 
Join Date: Aug 2008
Quote:
Originally Posted by NJRonbo View Post
Multi-clutch is solving the main problem with gestures but
has created another...

Now, with a certain gesture on the trackpad (have no idea what
I am doing) Safari is mimimizing itself.

Any idea what may be happening?
Do you have tap-to-click turned on?
__________________
~Dan
Samsung Galaxy S Phone (Captivate); MacBook Pro 15" w/ HiRes Antiglare, 8GB RAM, and I sprung for the 512GB SSD for durability; 32GB iPad 2
dandaman2 is offline   0 Reply With Quote
Old Nov 5, 2009, 10:36 PM   #20
equis
macrumors newbie
 
Join Date: Nov 2009
I've been having the same issue - very frustrating. But I have just found something that worked for me. In the trackpad panel I unchecked Pinch Open & Close. The resizing doesn't occur anymore. Hope this works for others.
equis is offline   0 Reply With Quote
Old Nov 5, 2009, 11:07 PM   #21
combine
macrumors newbie
 
Join Date: Jul 2009
multi touch is great, until you start using photoshop without a mouse
__________________
13" Macbook Pro 2.26 GHz, 4GB DDR3, 160GB ; iPod Touch 2G 16GB
combine is offline   0 Reply With Quote
Old Nov 5, 2009, 11:16 PM   #22
dandaman2
macrumors regular
 
Join Date: Aug 2008
@equis
Yeah, that's the SL way. You used to have to install MultiClutch (still do on Leopard). My way was a Logimouse VX Nano.
__________________
~Dan
Samsung Galaxy S Phone (Captivate); MacBook Pro 15" w/ HiRes Antiglare, 8GB RAM, and I sprung for the 512GB SSD for durability; 32GB iPad 2
dandaman2 is offline   0 Reply With Quote
Old Nov 6, 2009, 08:42 AM   #23
Fofer
macrumors 6502a
 
Join Date: Oct 2002
Quote:
Originally Posted by equis View Post
I've been having the same issue - very frustrating. But I have just found something that worked for me. In the trackpad panel I unchecked Pinch Open & Close. The resizing doesn't occur anymore. Hope this works for others.
That's great but then it turns off Pinch Open (zoom in) and Pinch Close (zoom out) in *all* apps. Not just Safari, where it was bugging me. I like pinch open & close in Preview, for example.

Luckily there is an update to MultiClutch that now works in Snow Leopard:
http://blog.prashantv.com/2009/multi...-instructions/

I use this to disable Pinch Open & Close in Safari only (follow jguluarte's instructions in this thread.) And also to create a gesture to "swipe up" and "swipe down" to move from message to message in Gmail/MailPlane.
Fofer is offline   0 Reply With Quote
Old Jan 9, 2010, 11:26 PM   #24
Jazzop
macrumors newbie
 
Join Date: Jan 2010
So, as I understand this thread, there is no way to disable ALL gesture functionality of the trackpad under an OS X version earlier than Snow Leopard?

I cannot install Snow Leopard for some licensing reasons, so am I screwed?

Also, I would like to disable all gestures under Win XP. I also want some kind of right-click capability. So far everyone suggests some weird two-finger method for right-clicking, which is not compatible with my physical appendages and would also be incompatible with my plan to disable gesturing.

In summary, I want the trackpad to act as a trackball, with clicking to be accomplished only through the mechanical switch by pressing hard on the pad.

Does anyone have any advice for me? I am 3 days into my first Mac (other than headless servers running linux, with no silly proprietary Mac input devices).
Jazzop is offline   0 Reply With Quote
Old Jan 10, 2010, 11:26 PM   #25
dandaman2
macrumors regular
 
Join Date: Aug 2008
Quote:
Originally Posted by Jazzop View Post
So, as I understand this thread, there is no way to disable ALL gesture functionality of the trackpad under an OS X version earlier than Snow Leopard?

I cannot install Snow Leopard for some licensing reasons, so am I screwed?

Also, I would like to disable all gestures under Win XP. I also want some kind of right-click capability. So far everyone suggests some weird two-finger method for right-clicking, which is not compatible with my physical appendages and would also be incompatible with my plan to disable gesturing.

In summary, I want the trackpad to act as a trackball, with clicking to be accomplished only through the mechanical switch by pressing hard on the pad.

Does anyone have any advice for me? I am 3 days into my first Mac (other than headless servers running linux, with no silly proprietary Mac input devices).
Welcome to mac. A lot of us here on macrumors tend to prefer it.

You misunderstood the thread. In this situation, that is a good thing. Without Snow Leopard, there is no way to disable all multi-touch gestrures....

without installing something. Which you can do. Download and install MultiClutch. Then, set rules for "System Wide" or "All Programs" or something to that effect (I'm running Snow Leopard, and uninstalled the program, so I don't remember all the terminology). Add all the gestures and make sure they're all set to "No Action." I don't know if this applies to Windows, too, you might have to mess with Windows prefs to do that. I've never used Windows on my mac, just Ubuntu via Sun Virtualbox. The gestures I had turned on still worked, but that was just scrolling, etc, so I don't know if it was because of Ubuntu or MultiClutch.

In terms of write-click, the traditional way was to hold down the "control" key and then click. It was very annoying. But it works. Ask us if you have any other questions about your new mac!
__________________
~Dan
Samsung Galaxy S Phone (Captivate); MacBook Pro 15" w/ HiRes Antiglare, 8GB RAM, and I sprung for the 512GB SSD for durability; 32GB iPad 2
dandaman2 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Notebooks > MacBook Pro

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
move+resize windows using multi-touch gestures! InnovD Mac Applications and Mac App Store 0 Mar 1, 2014 12:35 PM
(Some) multi-touch gestures do not work on my MBP ZillaG Mac OS X 10.7 Lion 0 Nov 23, 2012 09:37 AM
iOS needs better multi-touch gestures... jv311 iOS 6 3 Nov 4, 2012 10:04 AM
Multi touch gestures ipos iOS 6 3 Oct 17, 2012 10:48 AM
Wacom Bamboo and Multi-Touch Gestures? Mac In School Mac Peripherals 1 Sep 27, 2012 01:12 PM

Forum Jump

All times are GMT -5. The time now is 07:58 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC