Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > OS X

Reply
 
Thread Tools Search this Thread Display Modes
Old Oct 30, 2008, 10:16 PM   #1
teleromeo
macrumors 65816
 
teleromeo's Avatar
 
Join Date: Dec 2006
Location: kidnapped by aliens
Your network settings have been changed by another application ...

When I try to open the network control panel I get this warning. I have no idea what application changed it and why it pops up. Also, when I click Ok the warning pops up again and again and ... In other words, I can no longer acces the control panel to change my settings. Can anyone tell me what I can do to solve this ?


__________________
wie heb ik aan de lijn hallo hallo
teleromeo is offline   0 Reply With Quote
Old Oct 30, 2008, 10:34 PM   #2
emt1
macrumors 65816
 
Join Date: Jan 2008
Location: Wisconsin
Quote:
Originally Posted by teleromeo View Post
When I try to open the network control panel I get this warning. I have no idea what application changed it and why it pops up. Also, when I click Ok the warning pops up again and again and ... In other words, I can no longer acces the control panel to change my settings. Can anyone tell me what I can do to solve this ?


As a workaround, I suggest you go to preferences -> Security, and check the box that says "require a password to unlock each system preferences pane". This should prevent whatever is changing your settings from doing that.
emt1 is offline   0 Reply With Quote
Old Oct 30, 2008, 11:04 PM   #3
teleromeo
Thread Starter
macrumors 65816
 
teleromeo's Avatar
 
Join Date: Dec 2006
Location: kidnapped by aliens
That does the trick as long as I leave that box checked, when I uncheck it, the message starts popping up again, I guess I better leave it on.
Thanks for the help.
__________________
wie heb ik aan de lijn hallo hallo
teleromeo is offline   0 Reply With Quote
Old Nov 5, 2008, 09:01 PM   #4
elZotto
macrumors newbie
 
Join Date: Jun 2007
Same thing happened to me. The same repeating message.
The only way out was to force quit the System Preferences.

Started about three days ago. I was about to post a query when I searched first and found this thread.

I tried what you suggested and it seems to have worked.
Thanks emt1! You Rock!

Now, inquiring minds wish to know:
Why does this happen?
How can we find which app changed my settings?
Why did an app change my settings without my permission?
Why does emt1's workaround make it all allright?
Why now and why to two people? Any more out there?

Thanks in advance,

elZ

Last edited by elZotto; Nov 6, 2008 at 12:39 AM. Reason: Mixed up the names.
elZotto is offline   0 Reply With Quote
Old Nov 29, 2008, 09:27 AM   #5
zerotsm
macrumors newbie
 
Join Date: Nov 2008
Happened After Update

This problem happened to me after the latest software update. Hopefully Apple will figure out the conflict and issue a new patch to fix it.
zerotsm is offline   0 Reply With Quote
Old Nov 29, 2008, 11:43 AM   #6
misterredman
macrumors 6502a
 
misterredman's Avatar
 
Join Date: Oct 2007
Look here for a possible solution:

http://forums.macrumors.com/showthread.php?t=606716
misterredman is offline   0 Reply With Quote
Old Dec 18, 2008, 01:31 AM   #7
jimmosk
macrumors newbie
 
Join Date: Dec 2008
I just had this problem, and found a solution which worked for me (OS X.4.11 on a G4 ibook)

I went to Preferences > Network and pulled down the Location menu (I had to time it carefully, hitting return to clear the alert message and instantly clicking on the menu) to choose Edit Locations. Then I deleted all locations except for Automatic. (The alert did not pop up while I was doing this). Once that was done everything was back to normal.
.
Of course, it was easy for me to ditch those other locations since they were years old and obsolete. If you need those other locations you can recreate them again without the problem returning.

-Jim
jimmosk is offline   0 Reply With Quote
Old Dec 18, 2008, 01:49 AM   #8
madog
macrumors 65816
 
madog's Avatar
 
Join Date: Nov 2004
Location: Korova Milkbar
This currently reported problem, which manifests after applying Security Update 2008-06, can be fixed permanently by removing the following preferences files:

Go to Library/Preferences/SystemConfiguration and delete the following (suggest make copies to the desktop first if in doubt):

com.apple.airport.preferences.plist
NetworkInterfaces.plist
preferences.plist
com.apple.nat.plist

All these files will regenerate as necessary when the associated system features are accessed. If you're using Airport or Internet Sharing you'll have to reestablish the appropriate settings, because these will have been lost when the preferences files are removed. Small price to pay, however for a permanent, and very simple solution to this irritating problem.

Found this too:
Open "System Preferences" and go to "Security".

Tick off "Require password to unlock each secure system preference".

Now click "show all" at the top. I had to quit "System Preferences" to make the change take effect.

Open "System Preferences" again and choose "Network". (You will probably get the annoying pop up once, but this time when you click "OK" it shouldn't loop).

Notice that the padlock in the bottom left corner is now locked. Click it to unlock, and enter your password (assuming you are the administrator).

Now click back on the show all button. The Mac will think you made a change and ask if you want to " Apply configuration changes" click "Apply".

Once it saves the changes your problem should be fixed. You can go back to the "Security" pane and untick the option you enabled earlier.
__________________
CLEAN INSTALL - Format your hard drive, install your operating system of choice, install applications, and manually copy over personal data. For a good, clean feeling that lasts.
madog is offline   0 Reply With Quote
Old Dec 18, 2008, 02:04 PM   #9
jhoffa
macrumors newbie
 
Join Date: Nov 2006
Madog is correct. Depending on your airport settings you may have to remove all of the com.apple.airport.* files. Just "move" them to your desktop first to see if it works.
jhoffa is offline   0 Reply With Quote
Old Jan 22, 2009, 07:13 AM   #10
legs111
macrumors newbie
 
Join Date: Jan 2009
Quote:
Originally Posted by madog View Post
Once it saves the changes your problem should be fixed. You can go back to the "Security" pane and untick the option you enabled earlier.
after saving the changes and i went back to untick the option i enabled earlier, it started again.....
any help? or should i just leave it ticked off? is that a big problem?

thanks
legs111 is offline   0 Reply With Quote
Old Jan 22, 2009, 06:17 PM   #11
bizzle
macrumors 6502a
 
bizzle's Avatar
 
Join Date: Jun 2008
Quote:
Originally Posted by legs111 View Post
after saving the changes and i went back to untick the option i enabled earlier, it started again.....
any help? or should i just leave it ticked off? is that a big problem?

thanks
Unlock, delete the files, reboot, run software update (their should be a security update newer than the one that caused this issue), reboot, check then. That should rule out everything.
__________________
get your own damn blood.
bizzle is offline   0 Reply With Quote
Old Feb 17, 2009, 03:40 AM   #12
allan_zip
macrumors regular
 
Join Date: Feb 2005
Location: Belfast, N. Ireland
My girlfriend had this problem on her G4 iBook 10.4.11, I got it fixed by deleting the files as per madog's suggestion (although the com.apple.nat.plist file was not there). At the same time as this glitch appeared we were both kicked off our D-Link router and I'm wondering if this is the common denominator in the problem. I checked the router's log and kept seeing a "deny all" message, there was no problem with my service provider, the sync and ready lights remained on throughout. I have contacted D-Link previously about this problem and the constant TX TCP reset message I get that coincides with my connection hanging on and off but they had no fix and eventually just stopped responding to me.
Anyroad... thanks for the fix!
__________________
2.7 GHz Intel i7 MacBook Pro, OSX 10.6.7 + Freecom 400gb Mobile Drive USB2, Lacie 160gb firewire drive, Lacie dual-layer firewire dvdrw, M-Audio Profire 610
allan_zip is offline   0 Reply With Quote
Old Feb 17, 2009, 04:57 PM   #13
doug in albq
macrumors 65816
 
doug in albq's Avatar
 
Join Date: Oct 2007
Also, changing your firewall settings with a 3rd party app. like WaterRoof will give you the same message...
__________________
http://dougitdesign.com/blog
doug in albq is offline   0 Reply With Quote
Old Feb 24, 2009, 06:08 PM   #14
attisun
macrumors newbie
 
Join Date: Feb 2009
I had the same problem on a PB G4 running 10.4.11. For me the trick was to disable/turn off iDisk Syncing in the .Mac Control Panel.
attisun is offline   0 Reply With Quote
Old Jun 4, 2009, 01:56 PM   #15
mstish
macrumors newbie
 
Join Date: Jun 2009
Your network settings have been changed...

Thank you, thank you Madog!
mstish is offline   0 Reply With Quote
Old Jun 19, 2009, 06:21 AM   #16
macnme
macrumors newbie
 
Join Date: Jun 2009
Jim's suggestion worked for me. Thanks.

Jim's suggestion worked for me. Thanks.

Quote:
Originally Posted by jimmosk View Post
I just had this problem, and found a solution which worked for me (OS X.4.11 on a G4 ibook)

I went to Preferences > Network and pulled down the Location menu (I had to time it carefully, hitting return to clear the alert message and instantly clicking on the menu) to choose Edit Locations. Then I deleted all locations except for Automatic. (The alert did not pop up while I was doing this). Once that was done everything was back to normal.
.
Of course, it was easy for me to ditch those other locations since they were years old and obsolete. If you need those other locations you can recreate them again without the problem returning.

-Jim
macnme is offline   0 Reply With Quote
Old Aug 17, 2009, 12:15 AM   #17
criticalmac
macrumors newbie
 
Join Date: Aug 2009
thanks

me too...PB G4. Jim's suggestion above worked for me too. Ridiculous little mac bug huh! jeez.
criticalmac is offline   0 Reply With Quote
Old Jan 3, 2010, 04:35 PM   #18
Hemingray
macrumors 68030
 
Hemingray's Avatar
 
Join Date: Jan 2002
Location: Ha ha haaa!
Jim's suggestion also worked for me (iBook G4 running 10.4.11). Had an old Earthlink dial-up location still in there. Deleting everything except the "Automatic" location did the trick. Thanks!
Hemingray is offline   0 Reply With Quote
Old Jan 10, 2010, 01:55 PM   #19
rw55
macrumors newbie
 
Join Date: Jan 2010
Add me to the list who (a) were driven nuts by this bug and more importantly, (b) were helped by Jim's suggestion. In my case, in addition to "automatic", I had two other locations--including one that I used and one I no longer used. I tried deleting only the location I didn't use--leaving automatic and my location I currently used. Just doing that worked for me. Thanks!!!

-Rob
rw55 is offline   0 Reply With Quote
Old Jan 17, 2010, 08:15 AM   #20
cpgneinc
macrumors newbie
 
Join Date: Jan 2010
There is another way to deal with the looping issue...

Hi all. This has happened to my G4 tower about a year back, and most recently to my friends Mac Mini, both PPC running latest Tiger. As soon as you click "OK", "OK" pops right up again. Here's some fun for you gamers: if you set your mouse over "location", and put your other finger on the return key, hit the return key and click your mouse almost simultaneously. If you hit it just right, it will break you out of the loop. Yes it works. Not a joke. It will allow you to access the settings and make a change. Once I made some authorized changes, my machine stopped putting up the warning window. Also, without deleting plist files, etc.. the problem, at least in my case, has not returned. With my friends Mac Mini, she was also able to break the loop and get into setting up a new account (she was changing ISP's). It only took her two or three tries. She had never opened this window before, although the machine had been working all along. At least we have some ways to deal with it. One last thing. There was a trojan said to possible cause this issue, but I think it's an isolated once in a blue moon cause. There was a small freeware utility called 'DNSChanger removal tool', put out by MacScan. You might want to find it and run it just for the heck of it. In my case, both machines came up clean.
cpgneinc is offline   0 Reply With Quote
Old Jan 20, 2010, 05:00 AM   #21
Yorkshirechav
macrumors newbie
 
Join Date: Jan 2010
Interesting what 'cpgneinc' said about the DNS changer.

I've also had the network message panel problem too on my G4 laptop, however I also had another problem which was a 5 second delay on my broadband internet - I'd click a link and nothing would happen, then the page would eventually load. I tried everything changing cables, routers etc. Eventually I found this blog:

http://www.skyuser.co.uk/forum/sky-b...age-loads.html

In turned out my DNS settings had been changed and when I put them back to the right ones my internet was back to normal. I wonder if it was down to a trojan, could the delay have been someone re-routing my internet access?
Yorkshirechav is offline   0 Reply With Quote
Old Feb 20, 2010, 04:53 AM   #22
sklucky9
macrumors newbie
 
Join Date: Feb 2010
Quote:
Originally Posted by jimmosk View Post
I just had this problem, and found a solution which worked for me (OS X.4.11 on a G4 ibook)

I went to Preferences > Network and pulled down the Location menu (I had to time it carefully, hitting return to clear the alert message and instantly clicking on the menu) to choose Edit Locations. Then I deleted all locations except for Automatic. (The alert did not pop up while I was doing this). Once that was done everything was back to normal.
.
Of course, it was easy for me to ditch those other locations since they were years old and obsolete. If you need those other locations you can recreate them again without the problem returning.

-Jim

This solution worked for me.
sklucky9 is offline   0 Reply With Quote
Old Feb 20, 2010, 08:01 PM   #23
HenryAZ
macrumors regular
 
Join Date: Jan 2010
Location: South Congress AZ
I had this same problem on Tiger after the mentioned security update. In my case I was able to track down the offending software to Verizon's Access Manager, used to manage cellular broadband devices. Installing VZAM caused the problem to occur, and deleting VZAM would get rid of the problem in direct correlation. I also experimented with the other workarounds such as requiring a password to make changes and deleting the plist files. In the long run, for me, the simplest (and most satisfying) thing was just not use VZAM for my broadband card.
HenryAZ is offline   0 Reply With Quote
Old Aug 17, 2010, 02:19 PM   #24
omedinamacru
macrumors newbie
 
Join Date: Aug 2010
this is absolutely the easiest fix

Quote:
Originally Posted by jimmosk View Post
I just had this problem, and found a solution which worked for me (OS X.4.11 on a G4 ibook)

I went to Preferences > Network and pulled down the Location menu (I had to time it carefully, hitting return to clear the alert message and instantly clicking on the menu) to choose Edit Locations. Then I deleted all locations except for Automatic. (The alert did not pop up while I was doing this). Once that was done everything was back to normal.
.
Of course, it was easy for me to ditch those other locations since they were years old and obsolete. If you need those other locations you can recreate them again without the problem returning.

-Jim
I found this to be the easiest solution to the problem. I did it once and the problem was gone. thanks!
omedinamacru is offline   0 Reply With Quote
Old Jan 30, 2011, 12:45 PM   #25
Vuurvogel
macrumors newbie
 
Join Date: Jan 2011
unable to change network settings and Verizon VZAccess Manager

Jim's suggestion worked very well to get rid of the looping message, after which I was able to get rid of the Verizon tentacles. The problem had to do with the installation of a VZAccess Manager. Verizon should be clobbered for taking over network settings.


Quote:
Originally Posted by jimmosk View Post
I just had this problem, and found a solution which worked for me (OS X.4.11 on a G4 ibook)

I went to Preferences > Network and pulled down the Location menu (I had to time it carefully, hitting return to clear the alert message and instantly clicking on the menu) to choose Edit Locations. Then I deleted all locations except for Automatic. (The alert did not pop up while I was doing this). Once that was done everything was back to normal.
.
Of course, it was easy for me to ditch those other locations since they were years old and obsolete. If you need those other locations you can recreate them again without the problem returning.

-Jim
Vuurvogel is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
General: Control Center application shortcut changed humar iOS 7 6 Mar 21, 2014 06:37 PM
When was the settings icon changed? oliversl iOS 6 13 Apr 3, 2013 03:35 PM
iPhone: SMS stopped working, noticed APN settings changed, need help Grumpy232 Jailbreaks and iOS Hacks 14 Jul 26, 2012 05:38 PM
Settings that need to be changed when installing a new SSD? 0r30 MacBook Pro 0 Jun 27, 2012 07:05 PM
Cellular Data Network on Network Settings chestvrg iPhone 4 Jun 15, 2012 11:08 AM

Forum Jump

All times are GMT -5. The time now is 06:46 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC