Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > PowerPC Macs

Reply
 
Thread Tools Search this Thread Display Modes
Old Nov 18, 2008, 06:50 PM   #1
NewMacguyibook
macrumors newbie
 
Join Date: Oct 2008
iBook - I love apple's/mac's so well, BUT WHY ME??? I need some help:(

I have 2 ibook g4's, 1.07 and 1.33.

The 1.07 fell and broke the LCD, VGA works great on a monitor.

I swapped the LCD from the 1.33 and nothing came on the screen, I read someplace that 1.20-1.33 use a different LCD then the rest, is that right?

Also the other night I was using my 1.33 and shut it down and the next day all I got was a "White screen", so I take it it's dead, this really sucks, I googled "ibook G4 white/dead/LCD/Display.

I think it's toast for sure, but when I switch the Res to 800x640 the display show's 6 really small pictures of the screen, well what it would look like if it was working normally, it's really crazy.
I took a screen snap shot "CMD+CONT+4 and the picture it took look normal.

Could an inverter be bad??

The VGA works fine on my monitor and everything seems to be kosher, BUT the screen.

Also the battery took a dive on me, just died no light no NOTHING!!
But the computer worked great for a week till the screen died on me.

Reset PRAM, NVRAM, PMU and etc, but still nothing.

HELP ME PLEASE

Thanks ladies and gents!!
NewMacguyibook is offline   0 Reply With Quote
Old Nov 18, 2008, 06:54 PM   #2
DannyBres
macrumors 65816
 
Join Date: Oct 2007
Location: UK
Go see the genius' im sure they'll be more than pleased to help
__________________
2011 MacBook Air i5 1.7 w/ 27" TB Display
32GB iPhone 5 & 32GB iPad Mini with Retina Display
DannyBres is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > PowerPC Macs

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
thread Thread Starter Forum Replies Last Post
So I am really screwed here, need some help! 3goldens iPad Hacks 2 Mar 17, 2011 04:55 PM
New here, but pretty Mac savvy. Need some advice: DW1221 Mac Basics and Help 4 Nov 1, 2008 12:36 PM
iday for me tomoro, need some help tho (UK) gimmeiphone Jailbreaks and iOS Hacks 1 Nov 27, 2007 05:01 PM
Windows Is So Slow, but Why? MacBytes MacBytes.com News Discussion 28 Mar 28, 2006 08:37 PM
Don't Shoot Me! (I Need Some Buying Advice) bobber205 Buying Tips and Advice 26 Feb 13, 2006 01:42 PM


All times are GMT -5. The time now is 09:49 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC