Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Archive > Archives of Old Posts > Web Design and Development (archive)

 
 
Thread Tools Search this Thread Display Modes
Old Feb 26, 2004, 09:58 AM   #1
kgarner
macrumors 68000
 
kgarner's Avatar
 
Join Date: Jan 2004
Location: Utah
localhost webserver problem--no SSI

I hope someone can clear this up for me. I have been following the WebServing with Jaguar Series at MacDevCenter.com so that I can start learning PHP and MySQL. Anyway, I got everthing turned on right for SSI and could use includes when working from the /Library/WebServer/Documents folder.

The problem is I want to keep everything in my Sites folder. So I configured my User configuration file (shortname.conf) according to the article using these settings:

<Directory "/Users/shortname/Sites/">
Options Includes Indexes Multiviews
AllowOverride None
Order allow,deny
Allow from all
</Directory>

ScriptAlias /~shortname/cgi-bin/ "/Users/shortname/Sites/cgi-bin/"

And I copied my index.shtml file from the /Library/WebServer/Documents folder to my Sites folder. The index.shtml file contains the following:

<html>
<body>
<h1>Served By Panther, Mac OS X 10.3</h1>
<pre>
<!--#include virtual="/cgi-bin/test-cgi"-->
</pre>
</body>
</html>

I moved the test-cgi script to the cgi-bin folder I created in my Sites folder and tried it out.

I see the Served by Panther line, bu the test-cgi is not shown and I don't get any errors. I have tried <!--#include virtual="/~shortname/cgi-bin/test-cgi"--> but to no avail. Any ideas?
__________________
Mac Pro 2.66 Quad | Mini 1.42 G4 (running as HTPC)
digitalsandbox.net
"Monkeys are like bacon. They improve just about anything." -Andy Ihnatko
kgarner is offline   0
Old Feb 26, 2004, 11:50 AM   #2
tomf87
Guest
 
tomf87's Avatar
 
Join Date: Sep 2003
In your /etc/httpd/httpd.conf file under the ScriptAlias, you need to have:

<Directory "/Users/shortname/Sites/">
Options Includes Indexes Multiviews
AllowOverride None
Order allow,deny
Allow from all
</Directory>

ScriptAlias /~shortname/cgi-bin/ "/Users/shortname/Sites/cgi-bin/"

<Directory "/Users/shortname/Sites/cgi-bin/">
Options ExecCGI
AllowOverride None
Order allow,deny
Allow from all
</Directory>
tomf87 is offline   0
Old Feb 26, 2004, 12:05 PM   #3
kgarner
Thread Starter
macrumors 68000
 
kgarner's Avatar
 
Join Date: Jan 2004
Location: Utah
Thanks! I'll try that when i get home tonight.
__________________
Mac Pro 2.66 Quad | Mini 1.42 G4 (running as HTPC)
digitalsandbox.net
"Monkeys are like bacon. They improve just about anything." -Andy Ihnatko
kgarner is offline   0
Old Feb 27, 2004, 09:45 AM   #4
kgarner
Thread Starter
macrumors 68000
 
kgarner's Avatar
 
Join Date: Jan 2004
Location: Utah
In case anyone else is having a similar problem, here is what I did. The steps in the article were almost right. You do need to put those entries in your /etc/httpd/users/shortname.conf file. Also you do need to add the other <Directory ...> that tomf87 suggested. Here is what I put in my .conf file.

<Directory "/Users/shortname/Sites/">
Options Includes Indexes Multiviews
AllowOverride None
Order allow,deny
Allow from all
</Directory>

ScriptAlias /~shortname/cgi-bin/ "/Users/shortname/Sites/cgi-bin/"

<Directory "/Users/shortname/Sites/cgi-bin/">
Options None
AllowOverride None
Order allow,deny
Allow from all
</Directory>

Basically I copied the <Directory>, the ScriptAlias, and the ScriptAlias <Directory> from the /etc/httpd/httpd.conf file, and then I modified them with the proper file path.
__________________
Mac Pro 2.66 Quad | Mini 1.42 G4 (running as HTPC)
digitalsandbox.net
"Monkeys are like bacon. They improve just about anything." -Andy Ihnatko
kgarner is offline   0

 
MacRumors Forums > Archive > Archives of Old Posts > Web Design and Development (archive)

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
thread Thread Starter Forum Replies Last Post
New in working with SSI and html developments Txutx Web Design and Development 5 Feb 24, 2009 06:43 AM
Problem with enabling SSI on Mac OS X 10.5.6 happyjohn Web Design and Development 2 Jan 25, 2009 09:37 AM
Planning for Growth with SSI bricktowntom Web Design and Development 4 Mar 30, 2006 02:18 PM
Taxes, Insurance, Interest, SSI & more Taxes Cadkiller Community Discussion 5 Mar 26, 2006 10:13 AM
SSI mac os 9 trainguy77 Web Design and Development (archive) 2 Dec 16, 2003 05:31 PM


All times are GMT -5. The time now is 05:14 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC