Go Back   MacRumors Forums > Apple Applications > Mac Applications and Mac App Store

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 1, 2009, 08:30 PM   #1
xury
macrumors newbie
 
Join Date: Nov 2008
Netflix / MS Silverlight DRM

I am having problems with Microsoft Silverlight on my Intel 2.0 macbook.

Apparentely, it is not recognizing DRM. I have tested the application at a silverlight DRM test site http://www.tinyurl.com/netflixsl and did not get a response from the testing device telling me it was working properly.

I am primarily attempting to watch movies instantly on Netflix. Nexflix recognizes that the software has been installed correctly (going to www.netflix.com/silver confirms my 'successful installation'), and the netflix application will even load and buffer the movies. The application sticks on the 'setting up your movie player' screen.

I called Netflix, and they said 'call microsoft'. I don't think they have a clue.

I have noticed a problem viewing episodes of programs on ABC.com and they apparently use silverlight as well. There is another 'flash' type program that won't run properly as well on my browser. (fyi - I am using safari, but have tried firefox as well).

Can someone point me in the right direction on how I might remedy this issue?

Thanks in advance,

X
xury is offline   0 Reply With Quote
Old Jan 1, 2009, 08:38 PM   #2
Nermal
Moderator
 
Nermal's Avatar
 
Join Date: Dec 2002
Location: Whakatane, New Zealand
I'm not sure whether the Mac version of Silverlight supports DRM or not. I just tried to install it on my machine but the installer fell over and told me that it doesn't run on PowerPC (my system is Intel). Go Microsoft!
Nermal is offline   0 Reply With Quote
Old Jan 1, 2009, 10:55 PM   #3
xury
Thread Starter
macrumors newbie
 
Join Date: Nov 2008
According to Netflix, it should be working - they specifically support Intel Macs. I have seen some other users post different questions about Netflix streaming problems using Intel Macs (they were able to stream, however with choppy issues, etc.), which adds to my confusion further.

The error message I received on Netflix, and on the Silverlight DRM test was:

"Individualization Failed".

Again, thanks for the help. Any further solutions or direction would be greatly appreciated.
xury is offline   0 Reply With Quote
Old Jan 1, 2009, 11:05 PM   #4
NeoMayhem
macrumors 6502a
 
Join Date: Aug 2003
Uninstall the silverlight plugin, reset safari and then install silverlight again. Make sure you have the newest versions of both.
NeoMayhem is offline   0 Reply With Quote
Old Feb 14, 2009, 10:11 AM   #5
wildthing
macrumors newbie
 
Join Date: Feb 2009
Can't stream DRM-Protected Netflix Movies

I an havng the same problem trying to play Netflix movies on my iMAC Intel 10.4.

I get this message: "Individualization failed. Unable to playback unprotected (DRM) content. Error Code: 8152."

I have re-installed the Silverlight plugin 3 times and tried playing the movie in both Firefox and Safari browsers after clearing the cache, turning off firewalls, etc., all to no avail.

Neither Netflix or Microsoft couldn't advise me. If anyone has had this experience and fixed it, let me know and thanks.
wildthing is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Applications > Mac Applications and Mac App Store

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
My air video on netflix doesn't look good as iPad 2 netflix hthomas MacBook Air 2 Aug 15, 2013 12:19 PM
Silverlight (Netflix) causing kernel CPU overload Makosuke OS X 10.8 Mountain Lion 2 May 3, 2013 02:49 AM
Cant install Silverlight, help? 2012Tony2012 Mac Applications and Mac App Store 4 Mar 11, 2013 03:11 PM
Silverlight Technology Tech198 Community Discussion 3 Oct 9, 2012 02:37 PM
Silverlight rmkonrath MacBook Pro 1 Sep 10, 2012 02:04 PM

Forum Jump

All times are GMT -5. The time now is 04:01 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC