Go Back   MacRumors Forums > iPhone, iPod and iPad > iPod

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 11, 2009, 09:22 PM   #1
kayem1
macrumors newbie
 
Join Date: Jan 2009
Authorization help needed..

Hey everyone.
I'm having trouble with authorization.
All of my purchases continually require authorization.
When I type in my password it says that my computer is already authorized and is the one of 5 computers that have been authorized. But it still continually asks every time I try to play a song, therefore rendering my songs unplayable.

I have de-authorized all computers and this computer and tried again.
I've been through all the steps in the knowledge base help article for these symptoms without success.

I then tried to upgrade my purchased items to be DRM free but some wouldn't, even though on the store it says they're available to iTunes plus.
It even says some aren't available on the Australian store, but that is what I used to purchase them in the first place.

Anyone have a solution for this?
Thanks.
kayem1 is offline   0 Reply With Quote
Old Jan 12, 2009, 02:29 AM   #2
JediMeister
macrumors 68040
 
Join Date: Oct 2008
One thing you could try to do, if you haven't already done so, is to uninstall/reinstall iTunes. I have seen it fix issues with connecting to the iTunes Store and authorization. There could also possibly be a problem with the .itl database file as well if its not recognizing that you're authorized to playback all that content...
JediMeister is offline   0 Reply With Quote
Old Jan 12, 2009, 02:31 AM   #3
yourdream
macrumors regular
 
Join Date: Aug 2008
If the solution above does not work, you can try calling Apple, I'm sure they can help you with your problem.
yourdream is offline   0 Reply With Quote
Old Jan 12, 2009, 02:50 AM   #4
Nermal
Moderator
 
Nermal's Avatar
 
Join Date: Dec 2002
Location: Whakatane, New Zealand
I hate that error. This is why DRM is bad and why I'm pleased to see Apple finally taking unprotected music seriously. Now if only it gets extended to the whole store...

</mini-rant>
Nermal is offline   0 Reply With Quote
Old Feb 14, 2009, 03:27 PM   #5
msc66
macrumors newbie
 
Join Date: Feb 2009
ever solved?

Was this issue ever resolved? I'm having the same problem.
msc66 is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPod

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Regulatory Agency Grants Apple Authorization Needed to Sell iPhone 5s and iPhone 5c in Brazil MacRumors iOS Blog Discussion 4 Oct 10, 2013 06:45 PM
CLLocationManager Authorization erdinc27 iPhone/iPad Programming 4 May 22, 2013 10:50 AM
iTunes Match keeps asking for authorization bcnmac iCloud and Apple Services 0 Mar 20, 2013 01:31 PM
UPS - Authorization Release dyzfnctional iPhone 0 Sep 21, 2012 04:57 AM
Authorization in Sandboxed App? ArtOfWarfare Mac Programming 4 Jun 14, 2012 11:13 AM

Forum Jump

All times are GMT -5. The time now is 04:51 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC