Go Back   MacRumors Forums > Apple Hardware > PowerPC Macs

Reply
 
Thread Tools Search this Thread Display Modes
Old Feb 26, 2009, 04:47 PM   #1
RyConn M.D.
macrumors newbie
 
Join Date: Feb 2009
Powered USB hub won't work for my PowerBook. Not even pigtail wire!

I have a 15" PowerBook G4 1.33 Ghz and I discovered that the provided USB ports do not power such devices as portable hard drives or audio interfaces.

So I heard that you need a POWERED USB hub.
I get one, Plug it in. And the PowerBook still doesn't recognize my external hard drive.

My hard drive has two wires on the opposite side from the enclosure that connect to female USB ports. I run an extension cord from one of the males to the other USB port on the PowerBook which is said to work but that also does nothing..

Disk Utility DOES recognize it.

I can't find it in Finder,
...some Powerbook..

Any idea?
RyConn M.D. is offline   0 Reply With Quote
Old Feb 26, 2009, 05:00 PM   #2
Darth.Titan
macrumors 68020
 
Darth.Titan's Avatar
 
Join Date: Oct 2007
If Disk Utility recognizes it, can you highlight it and click the 'Mount' button?
Does this external drive work with other computers?
Darth.Titan is offline   0 Reply With Quote
Old Feb 26, 2009, 05:01 PM   #3
illegallydead
macrumors 6502a
 
illegallydead's Avatar
 
Join Date: Oct 2007
Location: Colorado!!!
Quote:
Originally Posted by RyConn M.D. View Post
I have a 15" PowerBook G4 1.33 Ghz and I discovered that the provided USB ports do not power such devices as portable hard drives or audio interfaces.

So I heard that you need a POWERED USB hub.
I get one, Plug it in. And the PowerBook still doesn't recognize my external hard drive.

My hard drive has two wires on the opposite side from the enclosure that connect to female USB ports. I run an extension cord from one of the males to the other USB port on the PowerBook which is said to work but that also does nothing..

Disk Utility DOES recognize it.

I can't find it in Finder,
...some Powerbook..

Any idea?
If disk utility does recognize the disk, then the problem is not in the hub.
Are you sure you have the Disk Mounted? Disk Utility may see it, but the Name of the partition may be grayed out... Is that your problem?

Other than that, not sure what t tell you...

[EDIT]
haha damn looks like I was beat to it
[/EDIT]
__________________
"Lord, what fools these mortals be." - Shakespeare (A Midsummer Night's Dream)
Stupidica.com
illegallydead is offline   0 Reply With Quote
Old Feb 26, 2009, 09:26 PM   #4
RyConn M.D.
Thread Starter
macrumors newbie
 
Join Date: Feb 2009
I think I made a little bit of progress

I decided I would try one last thing. The last thing I could think of.

I backed up my har drive to my Windows machine and then went ahead and erase/formatted the drive. THIS WORKED!

One problem:

I have a USB Audio Interface (Tascam US-122) that I used to use with my old PowerMac G4 and IT WON'T WORK. So the hub is working...but my audio interface won't power on? It was a phantom power on/off switch and when I switch it on, a red light turns on. So it is getting power it seems, my mac just isn't recognizing it.

What to do, what to do.....
RyConn M.D. is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > PowerPC Macs

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Possible to recharge multiple USB devices with powered hub? kylera Community Discussion 0 Feb 23, 2013 05:40 AM
Resolved: Lumix And Powered USB Hub Macman45 Digital Photography 5 Sep 18, 2012 05:05 AM
7 Port Powered USB Hub? ohla313 Mac Peripherals 4 Aug 27, 2012 11:56 AM
2012 MBA won't work with Belkin USB Hub ohla313 Mac Peripherals 1 Aug 26, 2012 01:32 PM

Forum Jump

All times are GMT -5. The time now is 10:33 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC